Pervasive.SQL V8 Documentation (v8.5)

This help system contains all the documentation for Pervasive.SQL, including the manuals listed on this page. Please also see the README FILE for important information on the product. The Index for this help file contains entries from all manuals in the documentation set. You can use the Search tab to find specific words and phrases throughout the documentation set as well.

If you want suggestions on maximizing your use of this system, please see the Using Pervasive.SQL Help page.

What's New in Pervasive.SQL V8 (v8.5) | Documents the additions and updates that are part of the Pervasive.SQL V8 (v8.5) release.
Getting Started with Pervasive.SQL V8 (Server) | Documents installation of Pervasive.SQL server and initial configuration.
Getting Started with Pervasive.SQL V8 (Workgroup) | Documents installation of Pervasive.SQL workgroup and initial configuration.
SQL Engine Reference | Documents Pervasive SQL syntax and ODBC API conformance
Status Codes and Messages | Documents status codes and messages that you can receive from the Pervasive engine.
Pervasive Products and Services | Documents Pervasive access methods and company information.
Pervasive.SQL User's Guide | Documents Pervasive utilities and common tasks.
Advanced Operations Guide | Documents database and maintenance procedures for more experienced users.
Glossary | Contains a listing of Pervasive specific terms and their definitions.

Register Your Product

See the registration page for information on how to register your Pervasive.SQL product.

Other Pervasive Documentation

This help set dynamically includes documentation on the following Pervasive products if they are installed:

  • Pervasive.SQL SDK
  • Pervasive AuditMaster
  • Pervasive Backup Agent
  • Pervasive DataExchange

For Pervasive developer related material, sample code, components, and up-to-date news, see the Pervasive Developer Center at http://www.pervasive.com/developerzone. You can download the Pervasive.SQL SDK and view SDK documentation at the Developer Center.

Contacting Pervasive

If you encounter problems with this help file or have other documentation questions or comments, please post them on the Pervasive DevTalk forums at http://www.pervasive.com/devtalk.

Visit http://www.pervasive.com/company/contact for detailed contact information.
Visit http://www.pervasive.com/support for the Pervasive Support home page.

Call 1-800-BTRIEVE or 512-231-6000
or write to:

Pervasive Software Inc.
12365 Riata Trace Parkway
Building B
Austin, TX 78727 USA

View Legal Notices


Pervasive Online Resources

This page contains links to more information for Pervasive.SQL customers.

Link | Description
README FILE | Documents important information that you need to know about the Pervasive.SQL V8.5 release.
Registration | Allows you to register your Pervasive.SQL V8.5 product.
Pervasive Home Page | Explore the content of Pervasive Software.
Pervasive Library | The complete online collection of documentation, white papers, technical papers, and forums for the Pervasive developer community.
Pervasive DevTalk | Discuss issues with Pervasive developers and other Pervasive.SQL users. Make a product suggestion and tell us what you think.
Pervasive Knowledge Base | Search for support information on Pervasive products
Pervasive Developer Center | The focus website for the Pervasive developer community - download updates, research white papers, and more.
Pervasive Component Zone | Download sample applications, code snippets, and other useful tools. Upload a component for others to use

Pervasive Software, Inc.
512-231-6000, 1-800-287-4383
12365 Riata Trace Parkway
Building B
Austin, TX 78727 USA


/*
 * The Apache Software License, Version 1.1
 *
 *
 * Copyright (c) 1999-2000 The Apache Software Foundation.  All rights
 * reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 *
 * 1. Redistributions of source code must retain the above copyright
 *    notice, this list of conditions and the following disclaimer.
 *
 * 2. Redistributions in binary form must reproduce the above copyright
 *    notice, this list of conditions and the following disclaimer in
 *    the documentation and/or other materials provided with the
 *    distribution.
 *
 * 3. The end-user documentation included with the redistribution,
 *    if any, must include the following acknowledgment:
 *       "This product includes software developed by the
 *        Apache Software Foundation (http://www.apache.org/)."
 *    Alternately, this acknowledgment may appear in the software itself,
 *    if and wherever such third-party acknowledgments normally appear.
 *
 * 4. The names "Xerces" and "Apache Software Foundation" must
 *    not be used to endorse or promote products derived from this
 *    software without prior written permission. For written
 *    permission, please contact apache@apache.org.
 *
 * 5. Products derived from this software may not be called "Apache",
 *    nor may "Apache" appear in their name, without prior written
 *    permission of the Apache Software Foundation.
 *
 * THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED
 * WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
 * OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
 * DISCLAIMED.  IN NO EVENT SHALL THE APACHE SOFTWARE FOUNDATION OR
 * ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
 * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
 * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
 * USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
 * ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
 * OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
 * OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
 * SUCH DAMAGE.
 * ====================================================================
 *
 * This software consists of voluntary contributions made by many
 * individuals on behalf of the Apache Software Foundation and was
 * originally based on software copyright (c) 1999, International
 * Business Machines, Inc., http://www.ibm.com.  For more
 * information on the Apache Software Foundation, please see
 * <http://www.apache.org/>.
 */


Pervasive Documentation Maintenance

Product Documentation Downloads

Please carefully read these instructions before downloading:

You can download additional product documentation that will display in this Pervasive Library interface, even if you do not have the actual product installed.

  1. Browse to the Products page of the online Pervasive Library.
  2. Select the product and version you want through this product page and follow the link to download the CHM set of documentation.
  3. To enable the display of the documentation in your local Pervasive Library window, you need to either:
    1. Unpack the zip file into your Pervasive.SQL documentation directory (default C:\Program Files\Common Files\Pervasive Software Shared\Doc

    or

    1. Unpack the zip file and place the file(s) in the appropriate directories listed on Documentation Maintenance window.
    2. Register the help files as specified on the Documentation Maintenance window
  4. Close all open Pervasive documentation windows and reload the Pervasive Library (pvswdocs.chm) interface. The new files will display in the Product Documentation section.


Product Documentation Maintenance

This help file, pvswdocs.chm, serves as the master help file for Pervasive.SQL, and optionally for all Pervasive products. You can maintain aspects of your Pervasive documentation through this interface.

  • Help File Registration
  • Help File Testing

Help File Registration

Help files are normally registered by Pervasive installers so that they are easily accessible by programs. This interface provides the ability to register or unregister help files from the Pervasive Library. After registering or unregistering a help file, you must close and reopen all Pervasive documentation windows for the change to take effect.

The Pervasive Library will try to include all help files listed here, assuming they can be found. The Pervasive Library can find help files if they are located in the same folder as pvswdocs.chm, or in another location if the help file is registered at that location.

If a product has more than one help file, that product has a master help file which controls the inclusion of the various manuals in that product. To add or remove an entire product from the pvswdocs.chm window, you need only register or unregister the master help file for that release, which can be identified by asterisks (*) in the table below.

Note: Depending on the Internet Explorer security restrictions on your workstation, you may receive an ActiveX warning that you must accept in order to perform this function:

Other default product documentation locations are shown in the following table. You will need to adjust the path as necessary for your installation.

Product | Default Documentation Location
Pervasive.SQL | C:\\Program Files\\Common Files\\Pervasive Software Shared\\Doc\\ *pvswdocs.chm, sgs.chm, wgs.chm, sqlref.chm, prodserv.chm, code_msg.chm, advops.chm, usrguide.chm, pvswglos.chm
Pervasive.SQL SDK | C:\\pvsw\\sdk\\doc\\ *psdkdocs.chm, prog_gst.chm, prog_gde.chm, prog_ocx.chm, prog_api.chm, sampcode.chm, prog_ids.chm (optional)
Pervasive Install Toolkit (single help file that merges with SDK set) | C:\\Program Files\\Pervasive Software\\Pervasive Install Toolkit\\doc\\insttk.chm
Pervasive AuditMaster (single help file) | C:\\pvsw\\audit\\docs\\amug.chm
Pervasive Backup Agent (single help file) | C:\\pvsw\\pba\\doc\\doc\\pbasst.chm
Pervasive DataExchange | C:\\pvsw\\replication\\docs\\ *dxdocs.chm, dxgsrtb.chm, dxgssync.chm, dxusrgde.chm
Enter FULLY qualified path to CHM file, including two backslashes to separate each folder:
Example: c:\\program files\\common files\\pervasive software shared\\doc\\pvswdocs.chm

Help File Testing - Mapped IDs

Help for utilities and interfaces loads through pvswdocs.chm using a six-digit help topic number. This interface can test those help IDs as routed through pvswdocs.chm. Example: 153100 for Pervasive Control Center help.


Help for Pervasive Documentation

This help file, pvswdocs.chm, contains all documentation relating to your Pervasive.SQL product.

Features of this documentation set include:

  • Integrated content and index for all manuals
  • Ability to do a search across all manuals
  • Links to more information on the Pervasive website

Browsing for Information

The contents and index of the Pervasive.SQL documentation is linked together. This means that you only need to look in one place for documentation and when you use the Index, it is the combined index of all the manuals.

Searching for Information

To search across all manuals, click the Search tab located at the top of the window. Then enter a term for which to search. To search for a phrase, enclose it in quotes. For example, "event log". You can also use expressions to narrow the search. These keywords include AND, OR, NEAR, and NOT.

For example, to search for topics that had to do with network troubleshooting, you could enter "troubleshooting AND network" in the Search field. This would search only for topics where both two terms are used. Use "NEAR" when you want the two terms to be within a paragraph of each other.

To search for all information relating to Pervasive, including that which is online, use the Search feature of the online Pervasive Library.

Links to Online Information

You can use the online resources page to find links to Pervasive websites with additional information. One such site is the Pervasive Library, which contains online copies of all documentation, white papers, technical papers, and other information

Asking for Documentation Assistance

If you cannot find the information you seek, or you have questions or comments about Pervasive documentation, please post them at Pervasive DevTalk Forums. We will be happy to assist you in any way.


Legal Notices

Prev Legal Notices

Pervasive.SQL V8

Pervasive.SQL V8 Documentation

Pervasive Software Inc.
12365 Riata Trace Parkway
Building B
Austin, TX 78727 USA

Telephone: 512 231 6000 or 800 287 4383
Fax: 512 231 6010
Email: info@pervasive.com
Web: http://www.pervasive.com

disclaimer

PERVASIVE SOFTWARE INC. LICENSES THE SOFTWARE AND DOCUMENTATION PRODUCT TO YOU OR YOUR COMPANY SOLELY ON AN "AS IS" BASIS AND SOLELY IN ACCORDANCE WITH THE TERMS AND CONDITIONS OF THE ACCOMPANYING LICENSE AGREEMENT. PERVASIVE SOFTWARE INC. MAKES NO OTHER WARRANTIES WHATSOEVER, EITHER EXPRESS OR IMPLIED, REGARDING THE SOFTWARE OR THE CONTENT OF THE DOCUMENTATION; PERVASIVE SOFTWARE INC. HEREBY EXPRESSLY STATES AND YOU OR YOUR COMPANY ACKNOWLEDGES THAT PERVASIVE SOFTWARE INC. DOES NOT MAKE ANY WARRANTIES, INCLUDING, FOR EXAMPLE, WITH RESPECT TO MERCHANTABILITY, TITLE, OR FITNESS FOR ANY PARTICULAR PURPOSE OR ARISING FROM COURSE OF DEALING OR USAGE OF TRADE, AMONG OTHERS.

trademarks

Btrieve, Client/Server in a Box, Pervasive, Pervasive Software, and the Pervasive Software logo are registered trademarks of Pervasive Software Inc.

Built on Pervasive Software, DataExchange, MicroKernel Database Engine, MicroKernel Database Architecture, Pervasive.SQL, Solution Network, Ultralight, and ZDBA are trademarks of Pervasive Software Inc.

Microsoft, MS-DOS, Windows, Windows 95, Windows 98, Windows NT, Windows Millennium, Windows 2000, Windows XP, Win32, Win32s, and Visual Basic are registered trademarks of Microsoft Corporation.

NetWare and Novell are registered trademarks of Novell, Inc.

NetWare Loadable Module, NLM, Novell DOS, Transaction Tracking System, and TTS are trademarks of Novell, Inc.

All other company and product names are the trademarks or registered trademarks of their respective companies.

Copyright 2002 Pervasive Software Inc. All rights reserved. Reproduction, photocopying, or transmittal of this publication, or portions of this publication, is prohibited without the express prior written consent of the publisher.

This product includes software developed by Powerdog Industries. Copyright 1994 Powerdog Industries. All rights reserved. This product includes software developed by KeyWorks Software. Copyright 2002 KeyWorks Software. All rights reserved. This product includes software developed by DUNDAS SOFTWARE. Copyright 1997-2000 DUNDAS SOFTWARE LTD., all rights reserved. This product includes software developed by the Apache Software Foundation (http://www.apache.org/). See the Apache Software License.

The ODBC Driver Manager for NetWare (ODBC.NLM) included in this product is based on the GNU iODBC software Copyright 1995 by Ke Jin <kejin@empress.com> and was modified by Simba Technologies Inc. in June 1999.

This library is free software; you can redistribute it and/or modify it under the terms of the GNU Lesser General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for more details.

A copy of the GNU Lesser General Public License is included in your installation of Pervasive.SQL at \program files\common files\Pervasive Software Shared\doc\lesser.htm. If you cannot find this license, write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA. You may contact Pervasive Software Inc. using the contact information on the back cover of this manual.

Prev