About This Manual

This manual describes the status codes and messages you may encounter while using components of Pervasive.SQL V8. An explanation or corrective action accompanies each message or code.

The status codes and messages in this manual are not specific to any one platform or product. This manual may refer to utilities, products, or platforms that are not part of your product distribution.

Pervasive Software would appreciate your comments and suggestions about this manual. As a user of our documentation, you are in a unique position to provide ideas that can have a direct impact on future releases of this and other manuals. If you have comments or suggestions for the product documentation, post your request at http://www.pervasive.com/devtalk or send e-mail to docs@pervasive.com.

Prev
Check for Revisions 		Next
Who Should Read This Manual?


Who Should Read This Manual?

This manual provides information for developers, testers, and support personnel who install and run Pervasive.SQL Server and Workgroup products. Status codes may be displayed during product installation, while using the utilities, or while using an application.

Prev
About This Manual 		Up
Check for Revisions 		Next
Manual Organization


Manual Organization

The following list briefly describes each chapter in the manual:

  • Chapter 1 — Status Codes

    This chapter lists and explains each status code you may receive. A brief description follows each code. The status codes are listed in numeric order. Some status codes listed in this chapter refer to engines and utilities for environments other than your own. Status codes are returned by API calls.

  • Chapter 2 — Messages

    This chapter lists and explains the numbered and non-numbered text message you may receive. The messages are categorized by the application or component that generates them. Some messages listed in this chapter refer to engines and utilities for environments other than your own.

This manual also includes an index.

Prev
Who Should Read This Manual? 		Up
Check for Revisions 		Next
Conventions


Conventions

Unless otherwise noted, command syntax, code, and examples use the following conventions:
CASE | Commands and reserved words typically appear in uppercase letters. Unless the manual states otherwise, you can enter these items using uppercase, lowercase, or both. For example, you can type MYPROG, myprog, or MYprog.
Bold | Words appearing in bold include the following: menu names, dialog box names, commands, options, buttons, statements, etc.
Monospaced font | Monospaced font is reserved for words you enter, such as command syntax.
[ ] | Square brackets enclose optional information, as in [log_name]. If information is not enclosed in square brackets, it is required.
| | A vertical bar indicates a choice of information to enter, as in [file name | @file name].
< > | Angle brackets enclose multiple choices for a required item, as in /D=<5|6|7>.
variable | Words appearing in italics are variables that you must replace with appropriate values, as in file name.
. . . | An ellipsis following information indicates you can repeat the information more than one time, as in [parameter . . . ].
::= | The symbol ::= means one item is defined in terms of another. For example, a::=b means the item a is defined in terms of b.

Prev
Manual Organization 		Up
Check for Revisions 		Next
Status Codes


Status Codes

A Reference to Pervasive.SQL Status Codes

This chapter describes the status codes and messages generated by any of the components of Pervasive.SQL.

Status codes are not the same as numbered messages (see Chapter 2—Messages). Messages are returned to end users by utilities or specific components and generally begin with a prefix and a number. For example: MKDE–16: There is insufficient memory to load the MicroKernel Database Engine .

Status codes are returned to an application making a Pervasive.SQL interface call. The application determines whether or not to display the status code to the user. Applications will often display status codes in addition to helpful messages about a problem that has occurred, but the application developer determines this. Many utilities provided with Pervasive.SQL use transactional and relational access interfaces, and they may therefore return status codes as well as utility-specific messages.

Some messages include references to status codes.

The status codes appear in numeric order. The table below lists the numeric ranges for each type of code.
Table 1-1 Status Code Ranges
Range | Type of Code
-9100 to -9000 | Utilities Status Codes
-5040 to -1000 | SQL Relational Database Engine Status Codes
-199 to -100 | Informative Status Codes
0 | Successful Interface Completion Status Code
1 to 199 | MicroKernel Database Engine Status Codes
1000 to 1999 | MicroKernel Status Codes for Windows and DOS Workstations
2000 to 2099 | Btrieve Requester Status Codes
2200 to 2299 | XLT Status Codes
2300 to 2399 | Named Database Status Codes
3000 to 3099 | MicroKernel Router Status Codes
3100 to 3199 | Network Services Layer Status Codes
4000 to 4099 | Database Utilities Status Codes
5000 to 5999 | Encryption Status Codes
6000 to 6009 | Data Dictionary Status Codes
7000 to 7050 | Distributed Tuning Interface Status Codes
7063 to 7121 | License Administrator Status Codes
8000 to 8499 | Component Management Status Codes
8500 to 8589 | ECAS Interface Status Codes
8590 to 8599 | W3DBSMGR Status Codes
10000 to 10100 | SQL Connection Manager Codes

 Note
This chapter may refer to utilities, products, or platforms that are not part of your product distribution.

Prev
Conventions
Check for Revisions 		Next
-9100 to -9000


-9100 to -9000

Utilities Status Codes

This section lists status codes returned by the Pervasive.SQL utilities. Should you encounter an error code in the range -9100 to -9000 that is not listed in this section, record the steps taken to get the particular error you received and notify Technical Support at Pervasive Software.

-9000: The index key numbers in the Btrieve file do not match index key numbers defined in the DDF

This status code can appear when you are using Table Designer. If you save your table design with Table Designer in linked mode, the index key numbers in the Btrieve data file will be renumbered. Your application may not be able to access its data. Index keys defined in DDFs are numbered sequentially starting with zero. Index keys used in a Btrieve file may be any unique positive number chosen by the application developer.

An alternative to creating index keys with Table Designer is to create them with an SQL statement. The SQL statement assigns the next available index key number rather than renumbering the keys. An example helps clarify this.

Suppose you have the following index keys defined. The keys match by column type.
Index Keys in Btrieve Data File | Index Keys in DDF
0 2 | 0 1

If you were to add another index key with Table Designer in linked mode, the following would result:
Index Keys in Btrieve Data File | Index Keys in DDF
0 1 2 | 0 1 2

The keys in the Btreive data file are renumbered.

If you were to add another index key with an SQL statement, the following would result:
Index Keys in Btrieve Data File | Index Keys in DDF
0 2 3 | 0 1 2

The newly added key is assigned number 3 in the Btrieve data file since key number 2 is already used.

Note that unlinked mode also renumbers index keys. For example, suppose you have keys 0 and 2 in your Btrieve data file, and key 0 in your DDFs. If you add another index key in unlinked mode, the DDFs keys get renumbered to 1 and 3. Use SQL statements instead of Table Designer if you want to avoid renumbering index keys.

-9003: The Btrieve file has index keys defined but no index keys are defined in the DDF

This status code can appear when you are using Table Designer. If you save your table design with Table Designer in linked mode, the index key numbers in the Btrieve data file will be renumbered. Your application may not be able to access its data. Index keys used by SRDE are numbered sequentially starting with zero.

To prevent the index key numbers in the Btrieve data file from being renumbered, switch Table Designer to unlinked mode, then save your table design. Unlinked mode affects only the DDF files and not the Btrieve data files. See To change Table Designer mode in Pervasive.SQL User's Guide.

Note that unlinked mode renumbers index keys in the DDFs. For example, suppose you have keys 0 and 2 in your Btrieve data file, and you add two keys in unlinked mode. The DDFs keys get renumbered 1 and 3. Use SQL statements instead of Table Designer if you want to avoid renumbering index keys.

-9004: The DDF has index keys defined but no index keys exist in the Btrieve file

This status code can appear when you are using Table Designer. If you save your table design with Table Designer in linked mode, your application will still be able to access its data. You may notice a performance difference because your Btrieve application will have index pages.

Prev
Status Codes 		Up
Check for Revisions 		Next
-5040 to -1000


-5040 to -1000

SQL Relational Database Engine Status Codes

This section lists status codes returned by the SQL Relational Database Engine (SRDE). Should you encounter an error code that is not listed in this section, be sure to record the steps taken to get the particular error you received and notify Technical Support at Pervasive Software.

-1003: Invalid API parameter

A parameter was passed to an invalid internal API.

-1011: Out of memory

This status code may be returned in one of the following situations:

  • The engine tried to allocate memory and was unsuccessful. Free up some resources and try again.

Reduce the size of Cache Allocation Size and/or Max MicroKernel Memory Usage configuration settings; or exit other applications on the computer.

-1020: No more file handles

While trying to open a file, a handle was not returned. Close some of your open programs and files and try again.

-1024: File share violation

There was an attempt to open a file that is read only or the specified user does not have the proper rights to open the file. Record the steps taken to get this error and notify Technical Support at Pervasive Software.

-1026: Record size limit exceeded

The record length was larger than the maximum allowed and some data has been truncated. Record the steps taken to get this error and notify Technical Support at Pervasive Software.

-1032: File access denied

There was an attempt to open a file that is read only or the specified user does not have the proper rights to open the file. Record the steps taken to get this error and notify Technical Support at Pervasive Software.

-1040: Too many columns defined

The maximum number of columns that can be defined is 1600 in a select statement; and 1536 elsewhere. Reduce the number of columns to within a valid range and try again.

-1113: Too many active sessions

For Pervasive.SQL 8 and higher versions, the number of sessions allowed is allocated dynamically.

  • Add additional memory, or close other applications on the computer where the database engine is installed, and try again.
  • For NetWare servers: the number of active sessions has reached the maximum allowed (4,906) and cannot be increased.
  • For Windows NT servers: the number of active sessions has reached the upper limit of your memory and cannot be increased.

-1206: Non-db file or corrupted db

The file specified is not a valid database name or the database is corrupt.

-1207: Database exclusively locked

There was an attempt to access a database that has been exclusively locked by another user. Wait until the user removes the exclusive lock before continuing.

-1302: Table is exclusively locked

There was an attempt to access a table that has been exclusively locked by another user. Wait until the user removes the exclusive lock before continuing.

-1303: Table already exists

The name you specified for a table already exists in the dictionary. Select another name or remove the current table definition before trying again.

-1304: Table is in use, cannot perform operation

The requested operation cannot be performed because another user is accessing or modifying the table. Try the operation again.

-1305: No such table or object

The table or object your tried to access does not exist. Check for the correct name and path and try again.

-1309: No DDLs without exclusive lock

You must perform an exclusive lock on the desired database before using DDL statements.

-1403: Duplicate index exists

You have attempted to define the same index more than once in this definition. Rewrite the statement so the index is defined only once.

In some cases, you may be re-issuing a create index statement because you cannot tell if your first statement succeeded. If you receive this error code under such conditions, then you can proceed on the assumption that your first create index operation was successful.

-1404: No such index

You tried to access an index that does not exist. Check the name and path and try again.

-1504: Null not valid

Null is not a valid parameter in the operation performed.

-1507: No such column

The column specified does not exist. Specify a correct column name.

-1508: Field is already defined

The field specified for this table has already been defined.

-1513: Index column type not supported

You cannot create an index on column types BIT, LONGVARCHAR, or LONGVARBINARY. You must create the index using a different column type.

-1603: Currency not on a record

A query required a temporary table and there was no unique row identifier (index) to correlate the temporary table to the result set. Adding an index to the order by or group by column will often resolve this problem.

-1605: Illegal duplicate key

This status code is returned in the following situations:

  • An entry was made into one of the system tables to satisfy a request from the SRDE level to create a database element with the same name (column, table, constraint). You may receive this error if you just created a column or index, but you are not sure if it was created or not. If you receive this error under such conditions, then you can proceed on the assumption that your initial creation attempt was successful.
  • You attempted to add a unique index to a column which already contains non-unique values.

-1809: Permission denied

The user does not have the appropriate rights for that action. Check the user permissions and try again. If this problem persists, check with your system administrator.

-1810: You are not authorized to perform this operation

The user does not have the appropriate rights for that action. Check the user permissions and try again. If this problem persists, check with your system administrator.

-1902: Unable to logon. An invalid Username/Password may have been specified

An invalid username or password may have been specified. Check your password and try again. If you continue to have problems, check with your system administrator.

-1903: Invalid account name

Either a user with the specified user name or a group with the specified group name does not exist. Check your user/group name and try again. If you continue to have problems, check with your system administrator.

-1905: Invalid password

The password specified was not correct. Check your password and try again. If you continue to have problems, check with your system administrator.

-1907: Access denied

The user does not have the proper permissions to access the file.

-3014: Trigger already exists

You are trying to create a trigger, but a trigger with the specified name already exists. Either use a different name, or drop the existing trigger before creating the new one.

-3015: Procedure already exists

You are trying to create a stored procedure, but a stored procedure with the specified name already exists. Either use a different name, or drop the existing stored procedure before creating the new one.

-3016: The fixed-portion size of a record exceeds 65535 bytes

The total size of the fixed-length portion of a record has exceeded 65535 bytes. The total size of the fixed-length portion of any data record may not exceed 65535 bytes. The fixed-length portion of any data record is made up of the following:

  • all the columns that have a fixed sized (all columns except for LONGVARCHAR and LONGVARBINARY)
  • one byte for each column that allows null values
  • 8 bytes for each variable-length column (column of type LONGVARCHAR or LONGVARBINARY).

Status code -3016 is returned if you attempt to create a table that exceeds this limit, or if you attempt modifications that would cause a table to exceed the limit.

To determine the size in bytes of the fixed-length portion of a record before you attempt to create a new table, you can use the following calculation:

(sum of the fixed-length column sizes in bytes) + (number of nullable columns) + ( 8 * number of variable-length columns) = record size in bytes

If you want to determine the size of the fixed-length portion of the record for an existing data file, you can use the BUTIL -STAT command to display a report that includes this information.

-3017: Invalid path/filename

The path/filename for the data file is too long.

-3018: Invalid data type conversion to an identity column

An attempt was made to alter a data type to an identity column.

-3019: Cannot drop a system table

An attempt was made to drop a system table.

-3020: Invalid USING path/filename

The path/filename that you have specified is invalid. Specify a simple, relative path between 1-64 characters.

-3021: Invalid IN DICTIONARY

IN DICTIONARY is not allowed on bound databases.

-3022: Invalid BLOB/CLOB data type in legacy table that contains NOTE/LVAR

A NOTE/LVAR column cannot coexist with a LONGVARCHAR/LONGVARBINARY. NOTE/LVAR must first be altered to a LONGVARCHAR/LONGVARBINARY.

-3023: Data type mismatch

Data conversion failed because data cannot be converted due to data type mismatch or data overflow. This error may occur if, for example, you attempt to alter a column of type DOUBLE to type FLOAT.

-3024: String or binary data truncation error

An attempt was made to convert a char/binary data to a char/binary column that has fewer bytes.

-3025: Arithmetic overflow error

An attempt was made to convert a number to a numeric column that has less precision.

-3026: Invalid NULL conversion

You cannot convert the value NULL into a not nullable column.

-3027: Invalid foreign key constraint name

The foreign key constraint name that you have specified is invalid. Specify a name between 1-20 characters, using numerals and letters only. It must start with a letter.

-3028: Invalid password

The password that you have specified is invalid. Specify a password between 1-8 characters. Numerals and letters only.

-3029: Invalid group or user name

The group or user name that you have specified is invalid. Specify a group or user name between 1-30 characters. Numerals and letters only. Must start with a letter.

-3030: Invalid procedure or trigger name

The procedure or trigger name that you have specified is invalid. Specify a name between 1-30 characters. Numerals and letters only. Must start with a letter.

-3031: MKC library cannot be loaded

The attempt to load MKC library failed. Ensure that the following file is located in the proper directory and is the correct version for your product:

  • Windows: MKC.DLL is located in the pvsw\bin directory.
  • NetWare: MKC.NLM is located in the SYS:SYSTEM directory.
  • Linux: libmkc.* is located in /usr/local/psql/lib directory.

-3032: Column in use by primary key

An attempt was made to delete all indexes referencing a column. An index was encountered that is used in the primary key.

-3033: Column in use by foreign key

An attempt was made to delete all indexes referencing a column. An index was encountered that is used in the foreign key.

-3034: Type cannot be null

The requested operation cannot be performed on a column definition that is nullable.

-3035: Length of the foreign key is incompatible

You cannot define a foreign key if the column it references has a different type or attribute.

-3036: Scale of the foreign key is incompatible

You cannot define a foreign key if the column it references has a different type or attribute.

-3037: Precision of the foreign key is incompatible

You cannot define a foreign key if the column it references has a different type or attribute.

-3038: Data Type of the foreign key is incompatible

You cannot define a foreign key if the column it references has a different data type.

-3039: Trigger dependency

You cannot drop the referenced table because a trigger refers to it.

-3040: Group already exists

A group with the specified group name already exists. Use a different group name. If you continue to have problems, check with your system administrator.

If you just tried to create the specified group, but you tried again because you are not sure if it was created, this error indicates that the group was in fact created with the first attempt.

-3041: User already exists

A user with the specified user name already exists. Use a different user name. If you continue to have problems, check with your system administrator.

If you just tried to create the specified user, but you tried again because you are not sure if it was created, this error indicates that the user was in fact created with the first attempt.

-3043: Table referenced by foreign key

Cannot drop the table because it is referenced by a foreign key.

-3044: Too many levels of trigger recursion

A trigger cannot be recursively called more than 30 times.

-3045: Index in use by foreign key

Cannot drop the index because it is referred to by a foreign key.

-3046: Integrity Constraint Violation

Nullable columns are not allowed in this operation.

-3047: RI no matching primary key

You tried to create a foreign key before defining a primary key. Define a primary key before continuing.

-3048: Invalid page size

The page size specified is invalid. Specify a page size that is a multiple of 512 and lies in the range 512-4,096 bytes (4,096 is the default).

-3049: Invalid free space threshold

The free space specified is not valid. Specify a free space percentage of 5, 10, 20, or 30 percent.

-3050: Invalid page number

The page number specified is not valid. Specify a page number between 1-65,535.

-3051: The dictionary is in use

The dictionary you are trying to access is already locked by another user. Wait until that user has unlocked the dictionary and try again.

-3052: Dictionary already exists

A dictionary with the specified name already exists in that directory. Use a different dictionary name or path.

-3053: RI table does not exist

There was an attempt to define referential integrity upon a table that does not exist. Check the table name and try again.

-3054: Duplicate savepoint name error

The specified savepoint name already exists.

-3055: Only one Alternate Collating Sequence per index

There can be only one ACS on a given index.

-3056: Add Nullable column in legacy table

Cannot create true null column in a legacy table.

-3057: Conflicting collation

There are attributes of the Column Collating Sequence that conflict with the column definition.

-3058: Drop last column

Cannot drop the last column of a table. A table must contain at least one column.

-3059: Database could not find dictionary files

The dictionary files for the specified database could not be found. Make sure the dictionary files exist and are in the proper directory.

-3060: Constraint already exists

The specified constraint name already exists.

-3061: Invalid constraint name

While creating a column constraint name, the constraint name was too long, null, or had an invalid character.

-3062: Database has no security

You tried to set security privileges on a database that was not marked secure. First, enable security on the database.

-3063: Database already secured

You cannot secure a database that has already been secured.

-3064: Alter legacy table

Cannot perform an alter table on a legacy table.

-3065: Invalid login

Either an invalid user name was used or the password failed. Make sure you are using the proper login information. If you continue to have problems, check with your system administrator.

-3066: Group not found

A group with the specified group name does not exist. Specify a valid group name. If you continue to have problems, check with your system administrator.

-3067: Group not empty

A group may not be deleted if there are still valid users in that group. Remove any user names before deleting the group.

-3068: Not allowed to define synonym for Public

Public is a default group and you are not allowed to change or add a synonym for the Public group.

-3069: Not allowed to drop Public

Public is a default group and cannot be dropped from the list of groups.

-3070: Not allowed to drop Administrator

Administrator is a default user and cannot be dropped from the list of users.

-3071: Cannot revoke synonym privileges

You cannot revoke privileges to a synonym; you must revoke privileges to the group the synonym refers to.

-3072: Cannot grant synonym privileges

You cannot grant privileges to a synonym; you must grant privileges to the group to which the synonym refers.

-3073: Privileges cannot be revoked from Administrator

Administrator is a default user and you cannot revoke privileges from the Administrator user name.

-3075: Conversion rename error

While converting a database, a file could not be renamed.

-3076: Conversion delete error

While converting a database, a file could not be deleted.

-3077: Bad index name

The index name is either too long or null.

-3078: Bad column name

The column name is either too long or null.

-3079: Bad table name

The table name is either too long or null.

-3080: Data not bound

You cannot bind a database that is already bound. A database can be bound only once.

-3081: Wrong DDF bind information

The binding information does not match the information specified in the Data Dictionary Files.

-3082: DDF already bound

You cannot bind a Data Dictionary File that is already bound.

-3083: DDF not bound

You cannot unbind a Data Dictionary File that is not bound.

-3084: Shared DDF

You cannot bind a database that uses shared Data Dictionary Files.

-3085: Shared data file

You cannot bind a database that uses shared data files.

-3086: Index in use by primary key

You cannot drop the index because it is referenced by a primary key.

-3087: Primary key already exists

The table already has a primary key defined. You must delete the existing primary key and recreate it.

-3088: Incompatible file version

The file specified uses data file format v6.x or before and must be migrated to the current version of data file format before it can be used. Use Rebuild utility to migrate file versions.

-3089: Inconsistent multipath

A foreign key cannot reference the table it is in.

-3090: Delete connected cycle

While defining a foreign key, there was a foreign key delete rule violation.

-3091: Self referencing delete not cascade

You must have a delete cascade defined in the foreign key to be able to do a self-referencing delete.

-3092: RI synchronization

The binding information in the Data Dictionary File and data files does not match.

-3093: Trigger RI conflict

If a delete trigger exists on the table, a delete cascade in a foreign key is not allowed.

-3094: Invalid delete rule

Delete name rules or attributes are not valid.

-3095: Invalid update rule

Update name rules or attributes are not valid.

-3096: Object in use

Cannot delete a stored procedure, trigger or view while in use.

-3097: Invalid collate

The collating sequence has a bad name, cannot be used, or may be corrupt.

-3098: Number out of range

The range for the specified number is invalid. Check the range for the option specified and enter a correct number.

-3099: Foreign key invalid database name

While creating a foreign key, the database name specified is either too long or it is null.

-3358: Not allowed to unbind database and change data locations at the same time

See 2342: Not allowed to unbind database and change data locations at the same time .

-3359: Not allowed to bind database and change data locations at the same time

See 2341: Not allowed to bind database and change data locations at the same time .

-3360: Not allowed to create data dictionary and unbind database at the same time

See 2340: Not allowed to create data dictionary and unbind database at the same time .

-3362: Not allowed to change the dictionary location and create dictionary files at the same time

See 2338: Not allowed to change the dictionary location and create dictionary files at the same time .

-3363: Not allowed to change data dictionary location and unbind database at the same time

See 2337: Not allowed to change data dictionary location and unbind database at the same time .

-3364: Not allowed to change data dictionary location and bind database at the same time

See 2336: Not allowed to change data dictionary location and bind database at the same time .

-3365: Not allowed to change data locations and change name at the same time

See 2335: Not allowed to change data locations and change name at the same time .

-3366: Not allowed to create a data dictionary files and change name at the same time

See 2334: Not allowed to create a data dictionary files and change name at the same time .

-3367: Not allowed to unbind database and change name at the same time

See 2333: Not allowed to unbind database and change name at the same time .

-3368: Not allowed to bind database and change name at the same time

See 2332: Not allowed to bind database and change name at the same time .

-3369: Not allowed to change data dictionary location and change name at the same time

See 2331: Not allowed to change data dictionary location and change name at the same time .

-3370: Data file for a table is bound, but does not need to be bound

See 2330: Data file for a table is bound, but does not need to be bound .

-3371: Data file for a table is not bound

See 2329: Data file for a table is not bound .

-3374: Data dictionary files are bound, but do not need to be bound

See 2326: Data dictionary files are bound, but do not need to be bound .

-3375: Data dictionary files are already bound

See 2325: Data dictionary files are already bound .

-3376: Data dictionary files are not bound

See 2324: Data dictionary files are not bound .

-3383: Cannot create DDF files for the bound database

See 2316: Cannot create DDF files for the bound database .

-3385: Cannot create DBNAMES.CFG file

See 2314: Cannot create DBNAMES.CFG file .

-3386: The bound database cannot share data dictionary files

See 2313: The bound database cannot share data dictionary files .

-3387: The bound database cannot share table data files

See 2312: The bound database cannot share table data files .

-3390: The database is in use

See 2309: The database is in use .

-3391: The specified RI flag is invalid

See 2308: The specified RI flag is invalid .

-3392: Cannot open DBNAMES.CFG file

See 2307: Cannot open DBNAMES.CFG file .

-3393: DBNAMES.CFG could not be updated

See 2306: DBNAMES.CFG could not be updated .

-3394: The specified path for data dictionary or data file locations is invalid

See 2305: The specified path for data dictionary or data file locations is invalid .

-3395: The database type is invalid

See 2304: The database type is invalid .

-3396: The database name must be unique; the specified database name already exists

See 2303: The database name must be unique; the specified database name already exists .

-3397: Invalid buffer length

See 2302: Invalid buffer length .

-3398: The database name is invalid

See 2301: The database name is invalid .

-3399: No more database names are defined

See 2300: No more database names are defined .

-3401: Invalid column-level GRANT statement

See 8098: Invalid column-level GRANT statement .

-3473: The Pervasive Network Services Layer was unable to resolve the given filename into a valid path

See 3126: The Pervasive Network Services Layer was unable to resolve the given filename into a valid path .

-3474: The Pervasive Network Services Layer was unable to resolve the Novell Directory Services name into a NetWare server name

See 3125: The Pervasive Network Services Layer was unable to resolve the Novell Directory Services name into a NetWare server name .

-3475: Pervasive Network Services Layer task table is full

See 3124: Pervasive Network Services Layer task table is full .

-3480: No authentication context is available

See 3119: No authentication context is available .

-3484: Pervasive Network Services Layer encountered a transport failure

See 3115: Pervasive Network Services Layer encountered a transport failure .

-3485: The routing table of the Pervasive Network Services Layer is full

See 3114: The routing table of the Pervasive Network Services Layer is full .

-3487: Failure during receive from the target server

See 3112: Failure during receive from the target server .

-3488: Failure during send to the target server

See 3111: Failure during send to the target server .

-3489: The network layer is not connected

See 3110: The network layer is not connected .

-3491: The Pervasive Network Services Layer detected an invalid session

See 3108: The Pervasive Network Services Layer detected an invalid session .

-3492: The Pervasive Network Services Layer is out of memory

See 3107: The Pervasive Network Services Layer is out of memory .

-3493: The Pervasive Network Services Layer encountered a connection failure

See 3106: The Pervasive Network Services Layer encountered a connection failure .

-3494: No available transport protocol for the Pervasive Network Services Layer

See 3105: No available transport protocol for the Pervasive Network Services Layer .

-3495: The Pervasive Network Services Layer encountered a permission error

See 3104: The Pervasive Network Services Layer encountered a permission error .

-3496: Server name not found by Pervasive Network Services Layer

See 3103: Server name not found by Pervasive Network Services Layer .

-3776: The task table of the MicroKernel router is full

See 3023: The task table of the MicroKernel router is full .

-3777: The MicroKernel router could not send the request to the remote engine because the specified data buffer length resulted in a data packet object that is too large

See 3022: The MicroKernel router could not send the request to the remote engine because the specified data buffer length resulted in a data packet object that is too large .

-3778: The MicroKernel router received a badly formatted data packet

See 3021: The MicroKernel router received a badly formatted data packet .

-3779: An error occurred while loading the MicroKernel

See 3020: An error occurred while loading the MicroKernel .

-3780: The MicroKernel router encountered a semaphore error

See 3019: The MicroKernel router encountered a semaphore error .

-3781: The file is already closed

See 3018: The file is already closed .

-3782: Data buffer of the local engine is too small

See 3017: Data buffer of the local engine is too small .

-3783: The MicroKernel router encountered an internal error

See 3016: The MicroKernel router encountered an internal error .

-3784: The MicroKernel router encountered an initialization error

See 3015: The MicroKernel router encountered an initialization error .

-3785: The MicroKernel router cannot find an engine

See 3014: The MicroKernel router cannot find an engine .

-3786: The remote engine is inaccessible to the MicroKernel router because the networking component is not loaded

See 3013: The remote engine is inaccessible to the MicroKernel router because the networking component is not loaded .

-3787: Local engine is not accessible to the MicroKernel router

See 3012: Local engine is not accessible to the MicroKernel router .

-3788: Thunk not possible – the Win32 MicroKernel router could not be found or is incompatible

See 3011: Thunk not possible – the Win32 MicroKernel router could not be found or is incompatible .

-3789: NetWare API DLLs are not loaded

See 3010: NetWare API DLLs are not loaded .

-3790: NETinterface.DLL is not loaded

See 3009: NETinterface.DLL is not loaded .

-3791: Invalid configuration for MicroKernel router

See 3008: Invalid configuration for MicroKernel router .

-3793: The MicroKernel router detected an invalid session

See 3006: The MicroKernel router detected an invalid session .

-3794: The MicroKernel router encountered an operating system error

See 3005: The MicroKernel router encountered an operating system error .

-3795: The MicroKernel is not responding to the MicroKernel router

See 3004: The MicroKernel is not responding to the MicroKernel router .

-3796: The MicroKernel router detected an incompatible network component

See 3003: The MicroKernel router detected an incompatible network component .

-3797: The MicroKernel router resource DLL is unavailable

See 3002: The MicroKernel router resource DLL is unavailable .

-3798: Local access is unavailable to the MicroKernel router

See 3001: Local access is unavailable to the MicroKernel router .

-3799: The MicroKernel router encountered a memory allocation error

See 3000: The MicroKernel router encountered a memory allocation error .

-4837: The client table is full.

See 162: The client table is full. .

-4838: The maximum number of user count licenses has been reached

See 161: The maximum number of user count licenses has been reached .

-4850: SQL Trigger

See 149: SQL Trigger .

-4851: A roll forward error occurred

See 148: A roll forward error occurred .

-4852: The log segment is missing

See 147: The log segment is missing .

-4853: Duplicate sys key

See 146: Duplicate system key .

-4856: The MicroKernel cannot allow unauthorized access to files in a secure MicroKernel database

See 143: The MicroKernel cannot allow unauthorized access to files in a secure MicroKernel database .

-4860: The MicroKernel has detected an unacceptable value in the key number

See 139: The MicroKernel has detected an unacceptable value in the key number .

-4861: The NULL indicator position is invalid

See 138: The NULL indicator position is invalid .

-4863: The MicroKernel cannot find the specified Alternate Collating Sequence in the file

See 136: The MicroKernel cannot find the specified Alternate Collating Sequence in the file .

-4864: The specified ISR table is corrupt or otherwise invalid

See 135: The specified ISR table is corrupt or otherwise invalid .

-4865: The MicroKernel cannot read the International Sorting Rule

See 134: The MicroKernel cannot read the International Sorting Rule .

-4866: More than 5 concurrent users attempted to access the same data file

See 133: More than 5 concurrent users attempted to access the same data file .

-4867: The file has reached its size limit

See 132: The file has reached its size limit .

-4869: The MicroKernel ran out of system locks

See 130: The MicroKernel ran out of system locks .

-4884: The file is owned by another Microkernel engine acting as a Gateway

See 116: The file is owned by another Microkernel engine acting as a Gateway .

-4885: The MicroKernel cannot access the archival logging dump file

See 115: The MicroKernel cannot access the archival logging dump file .

-4886: The archival log for the specified file is invalid

See 114: The archival log for the specified file is invalid .

-4887: The MicroKernel cannot find the archival log for the specified file

See 113: The MicroKernel cannot find the archival log for the specified file .

-4888: The specified file is in use by another client

See 112: The specified file is in use by another client .

-4889: The specified filename was not found in the archival logging configuration file

See 111: The specified filename was not found in the archival logging configuration file .

-4890: The MicroKernel cannot access the archival logging configuration file

See 110: The MicroKernel cannot access the archival logging configuration file .

-4891: An unknown error was encountered either creating or accessing a semaphore

See 109: An unknown error was encountered either creating or accessing a semaphore .

-4892: The application attempted to perform a chunk operation on a pre-v6.0 file

See 107: The application attempted to perform a chunk operation on a pre-v6.0 file .

-4893: The MicroKernel cannot perform a Get Next Chunk operation

See 106: The MicroKernel cannot perform a Get Next Chunk operation .

-4894: The file cannot be created with Variable-tail Allocation Tables (VATs)

See 105: The file cannot be created with Variable-tail Allocation Tables (VATs) .

-4895: The MicroKernel does not recognize the locale

See 104: The MicroKernel does not recognize the locale .

-4896: The chunk offset is too big

See 103: The chunk offset is too big .

-4897: Insufficient stack space is available

See 102: Insufficient stack space is available .

-4898: Insufficient operating system memory is available

See 101: Insufficient operating system memory is available .

-4899: No cache buffers are available

See 100: No cache buffers are available .

-4900: The Btrieve Requester is unable to access the NetWare Runtime server

See 99: The Btrieve Requester is unable to access the NetWare Runtime server .

-4901: Internal transaction error

See 98: The MicroKernel detected an internal transaction error .

-4902: The data buffer is too small

See 97: The data buffer is too small .

-4903: A communications environment error occurred

See 96: A communications environment error occurred .

-4904: The session is no longer valid

See 95: The session is no longer valid .

-4905: The application encountered a permission error

See 94: The application encountered a permission error .

-4906: The record lock types are incompatible

See 93: The record lock types are incompatible .

-4907: The transaction table is full

See 92: The transaction table is full .

-4908: The application encountered a server error

See 91: The application encountered a server error .

-4909: The redirected device table is full

See 90: The redirected device table is full .

-4910: A name error occurred

See 89: A name error occurred .

-4911: The application encountered an incompatible mode error

See 88: The application encountered an incompatible mode error .

-4912: The handle table is full

See 87: The handle table is full .

-4913: The file table is full

See 86: The file table is full .

-4914: File is locked

See 85: The file is locked .

-4915: Record is locked

See 84: The record or page is locked .

-4916: The MicroKernel attempted to update or delete a record that was read outside the transaction

See 83: The MicroKernel attempted to update or delete a record that was read outside the transaction .

-4917: The MicroKernel lost positioning

See 82: The MicroKernel lost positioning .

-4918: The MicroKernel encountered a lock error

See 81: The MicroKernel encountered a lock error .

-4919: The MicroKernel encountered a record-level conflict

See 80: The MicroKernel encountered a record-level conflict .

-4920: A programming error occurred

See 79: A programming error occurred .

-4921: The MicroKernel detected a deadlock condition

See 78: The MicroKernel detected a deadlock condition .

-4922: The application encountered a wait error

See 77: The application encountered a wait error .

-4923: There is a conflict on the referenced file

See 76: There is a conflict on the referenced file .

-4925: The MicroKernel aborted the transaction

See 74: The MicroKernel aborted the transaction .

-4926: The RI definition is out of sync

See 73: The RI definition is out of sync .

-4927: The MicroKernel cannot open the RI referenced file

See 72: The MicroKernel cannot open the RI referenced file .

-4928: There is a violation of the RI definitions

See 71: There is a violation of the RI definitions .

-4930: The Delete operation specified a file that is damaged

See 69: The Delete operation specified a file that is damaged .

-4931 The MicroKernel cannot perform the RI Delete Cascade operation

See 68: The MicroKernel cannot perform the RI Delete Cascade operation .

-4932: The MicroKernel cannot open the SQL data dictionary files

See 67: The MicroKernel cannot open the SQL data dictionary files .

-4933: The maximum number of open databases has been exceeded

See 66: The maximum number of open databases has been exceeded .

-4934: The field offset is incorrect

See 65: The field offset is incorrect .

-4935: The filter limit has been reached

See 64: The filter limit has been reached .

-4936: The data buffer parameter specified on an Insert Extended operation is invalid

See 63: The data buffer parameter specified on an Insert Extended operation is invalid .

-4937: The descriptor is incorrect

See 62: The descriptor is incorrect .

-4938: The work space is too small

See 61: The work space is too small .

-4939: The specified reject count has been reached

See 60: The specified reject count has been reached .

-4940: The specified file already exists

See 59: The specified file already exists .

-4941: The compression buffer length is too short

See 58: The compression buffer length is too short .

-4942: An expanded memory error occurred

See 57: An expanded memory error occurred .

-4943: An index is incomplete

See 56: An index is incomplete .

-4944: The application specified an invalid attribute for an AUTOINCREMENT key

See 55: The application specified an invalid attribute for an AUTOINCREMENT key .

-4945: The variable-length portion of the record is corrupt

See 54: The variable-length portion of the record is corrupt .

-4946: The language interface version is invalid

See 53: The language interface version is invalid .

-4947: An error occurred while writing to the cache

See 52: An error occurred while writing to the cache .

-4948: The owner name is invalid

See 51: The owner name is invalid .

-4949: The file owner is already set

See 50: The file owner is already set .

-4950: The extended key type is invalid

See 49: The extended key type is invalid .

-4951: The alternate collating sequence definition is invalid

See 48: The alternate collating sequence definition is invalid .

-4952: The number of files opened exceeds the maximum allowed

See 47: The number of files opened exceeds the maximum allowed .

-4953: Access to the requested file is denied

See 46: Access to the requested file is denied .

-4954: The specified key flags are invalid

See 45: The specified key flags are invalid .

-4955: The specified key path is invalid

See 44: The specified key path is invalid .

-4956: The specified record address is invalid

See 43: The specified record address is invalid .

-4957: A file previously opened in Accelerated mode was not closed

See 42: A file previously opened in Accelerated mode was not closed .

-4958: The MicroKernel does not allow the attempted operation

See 41: The MicroKernel does not allow the attempted operation .

-4959: The file access request exceeds the maximum number of files allowed

See 40: The file access request exceeds the maximum number of files allowed .

-4960: A Begin Transaction operation must precede an End/Abort Transaction operation

See 39: A Begin Transaction operation must precede an End/Abort Transaction operation .

-4961: The MicroKernel encountered a transaction control file I/O error

See 38: The MicroKernel encountered a transaction control file I/O error .

-4962: Another transaction is active

See 37: Another transaction is active .

-4964: The application encountered a directory error

See 35: The application encountered a directory error .

-4965: The specified extension name is invalid

See 34: The specified extension name is invalid .

-4966: The MicroKernel cannot unload

See 33: The MicroKernel cannot unload .

-4967: The file cannot be extended

See 32: The file cannot be extended .

-4968: The file is already extended

See 31: The file is already extended .

-4969: The file specified is not a MicroKernel file

See 30: The file specified is not a MicroKernel file .

-4970: The key length is invalid

See 29: The key length is invalid .

-4971: The record length is invalid

See 28: The record length is invalid .

-4972: The key position is invalid

See 27: The key position is invalid .

-4973: The number of keys specified is invalid

See 26: The number of keys specified is invalid .

-4974: The application cannot create the specified file

See 25: The application cannot create the specified file .

-4975: The page size or data buffer size is invalid

See 24: The page size or data buffer size is invalid .

-4976: The position block parameter is not 128 bytes long

See 23: The position block parameter is not 128 bytes long .

-4977: The data buffer parameter is too short

See 22: The data buffer parameter is too short .

-4978: The key buffer parameter is too short

See 21: The key buffer parameter is too short .

-4979: The MicroKernel or Btrieve Requester is inactive

See 20: The MicroKernel or Btrieve Requester is inactive .

-4980: The application encountered an unrecoverable error

See 19: The application encountered an unrecoverable error .

-4981: The disk is full

See 18: The disk is full .

-4983: The application encountered an expansion error

See 16: The application encountered an expansion error .

-4984: The application encountered an I/O error during pre-imaging

See 15: The application encountered an I/O error during pre-imaging .

-4985: The MicroKernel cannot create or open the pre-image file

See 14: The MicroKernel cannot create or open the pre-image file .

-4986: The MicroKernel could not open the extension file for an extended file

See 13: The MicroKernel could not open the extension file for an extended file .

-4987: The MicroKernel cannot find the specified file

See 12: The MicroKernel cannot find the specified file .

-4988: The specified filename is invalid

See 11: The specified filename is invalid .

-4989: The key field is not modifiable

See 10: The key field is not modifiable .

-4990: The operation encountered the end-of-file

See 9: The operation encountered the end-of-file .

-4991: The current positioning is invalid

See 8: The current positioning is invalid .

-4992: The key number has changed

See 7: The key number has changed .

-4993: The key number parameter is invalid

See 6: The key number parameter is invalid .

-4994: The record has a key field containing a duplicate value

You attempted to create a stored procedure with the same name as an existing stored procedure. Follow these steps to recover:

  1. Change the name of the stored procedure. (Note: Sometimes when you create a procedure with a SQL statement, you may not get a message from PCC confirming that the statement was successful.If you receive this error under such circumstances, you may proceed on the assumption that your create statement was successful.)
  2. Run the statement again.
  3. Run a SELECT *from X$proc# statement to get a list of the defined stored procedures. From this list, you can determine whether or not the procedure was actually created.

Also see 5: The record has a key field containing a duplicate key value

-4995: The application cannot find the key value

See 4: The application cannot find the key value .

-4996: The file is not open

See 3: The file is not open .

-4997: The application encountered an I/O error

See 2: The application encountered an I/O error .

-4998: The operation parameter is invalid

See 1: The operation parameter is invalid .

-5202: Record is locked

An attempt was made to access a record that is locked by another user. Wait until the record is unlocked and try again.

-5204: Table is not open

The MicroKernel was unable to open the table. Make sure you have the proper access rights and table privileges.

-5208: Invalid date

The format used for the date is incorrect. Check for the correct ODBC date format and try again.

-5219: Translation failed

The ODBC driver failed to translate the data between the data source and the application. Check if the application is using SQLSetConnectOption to override the default translation dll.

-5220: Invalid procedure name

The specified procedure name does not exist. Check the name of the procedure called and try again.

-5221: Invalid predicate name

The ODBC driver does not support this predicate. Consult the SQL Engine Reference for valid predicates.

-5222: Invalid Code Page value

The code page value in the ODBC configuration file is invalid. Refer to the Advanced Operations Guide for valid configuration settings.

Prev
-9100 to -9000 		Up
Check for Revisions 		Next
-199 to -100


-199 to -100

Informative Status Codes

This section lists the informative status codes that the MicroKernel can return. The MicroKernel returns these codes as negative values.

–101: The SET statement completed successfully

The following statements return this status code when they execute successfully:
Table 1-2 SET Statements
SET SECURITY | SET OWNER | SET VARIABLE | SET TRUENULLCREATE
SET ROWCOUNT | SET TIME ZONE | SET DECIMALSEPARATORCOMMA |

The MicroKernel made the requested change. However, if a SET OWNER statement was issued during a transaction, the change does not take effect until the user begins a new transaction.

–102: The INSERT statement completed successfully

The MicroKernel added the specified rows to the table(s).

–103: The UPDATE statement completed successfully

The MicroKernel made the specified changes to the table(s).

–104: The DELETE statement completed successfully

The MicroKernel deleted the specified rows from the table(s).

–105: The CREATE statement completed successfully

The following statements return this status code when they execute successfully:
Table 1-3 CREATE Statments
CREATE PROCEDURE | CREATE TABLE
CREATE GROUP | CREATE TRIGGER
CREATE INDEX | CREATE VIEW

The MicroKernel successfully added the group, index, stored procedure, table, trigger, or view to the data dictionary.

–106: The ALTER TABLE statement completed successfully

The MicroKernel successfully made the requested change to the table dictionary definition. If a column has been altered (including a primary key or foreign key) without specifying the IN DICTIONARY keyword, the MicroKernel also changed the data file.

-107: The DROP statement completed successfully.

The following statements return this status code when successfully executed:
Table 1-4 DROP Statements
DROP PROCEDURE | DROP TABLE
DROP GROUP | DROP TRIGGER
DROP INDEX | DROP VIEW

The MicroKernel successfully removed the group, index, stored procedure, table, trigger, or view from the dictionary. (Dropping a table also deletes the data file for that table.)

–108: The statement contains unresolved substitution variables and cannot be executed

The current SQL statement contains substitution variables and cannot be executed until values are supplied for each variable. If your application allows substitution variables, refer to the documentation included with the application to determine how to use them.

–109: The view contains no more records

The beginning or the end of the view has been reached.

–110: The GRANT statement completed successfully

The MicroKernel assigned the specified rights to the user or group.

–111: The REVOKE statement completed successfully

The MicroKernel revoked the specified rights from the user or group.

–112: The START TRANSACTION statement completed successfully

The MicroKernel has begun a transaction. All subsequent statements that you issue are part of this transaction until you issue either a COMMIT WORK or a ROLLBACK WORK statement. For a savepoint, the SAVEPOINT label remains in effect until you explicitly release or roll back to that label, or until the end of any outer transaction within which the savepoint is nested.

–113: The COMMIT WORK statement completed successfully

The MicroKernel committed the changes made by your transaction to the data tables. You can no longer undo the changes with a ROLLBACK WORK statement. For a RELEASE SAVEPOINT statement, any changes made since the savepoint was declared can no longer be rolled back separately. They can only be committed or rolled back as part of an outer transaction.

–114: The ROLLBACK WORK statement completed successfully

The MicroKernel reversed the changes you made during the transaction except for any changes you made with operations that are not affected by transaction processing. If you perform one of the following operations within a transaction, the MicroKernel completes the operation, but you cannot roll back the results:

  • Operations that create or change dictionary definitions. Therefore, you cannot roll back the results of the following statements: ALTER TABLE, CREATE GROUP, CREATE INDEX, CREATE PROCEDURE, CREATE TABLE, CREATE TRIGGER, and CREATE VIEW.
  • Operations that remove dictionary definitions. Therefore, you cannot roll back the results of the following statements: DROP GROUP, DROP INDEX, DROP PROCEDURE, DROP TABLE, DROP TRIGGER, and DROP VIEW.
  • Operations that grant or revoke security rights. Therefore, you cannot roll back the results of the following statements: GRANT and REVOKE.

For a ROLLBACK TO SAVEPOINT statement, any changes made since the savepoint was declared are rolled back.

–115: The MicroKernel successfully recalled the stored SQL statement

This status code is obsolete in the MicroKernel versions 4.0 and later, except when using v3.01 Compatibility mode.

–116: The MicroKernel successfully executed the stored SQL statement

This status code is obsolete in the MicroKernel versions 4.0 and later, except when using v3.01 Compatibility mode. In the MicroKernel v4.0 and later, stored procedures are used instead of stored statements.

The MicroKernel executed the stored statement that you submitted for execution.

–118: The DECLARE statement completed successfully

The following statements return this status code when they execute successfully:
Table 1-5 DECLARE Statements
DECLARE CURSOR | DECLARE VARIABLE
DECLARE CONDITION |

If you issued a DECLARE statement, the MicroKernel successfully created the cursor, variable, or condition you defined.

–119: The SET assignment statement completed successfully

The SET variable = expression statement returns this status code upon successful completion.

–120: The OPEN statement completed successfully

The OPEN CURSOR statement returns this status code upon successful completion.

–121: The CLOSE statement completed successfully

The CLOSE CURSOR statement returns this status code upon successful completion.

–122: The FETCH statement completed successfully

The FETCH statement returns this status code upon successful completion.

–123: The positioned UPDATE statement completed successfully

The UPDATE [table_reference] SET set_clause WHERE CURRENT OF statement returns this status code upon successful completion.

–124: The positioned DELETE statement completed successfully

The DELETE [FROM table_reference] WHERE CURRENT OF cursor_name statement returns this status code upon successful completion.

–125: The CALL stored procedure statement completed successfully

The CALL statement returns this status code upon successful completion. This status code indicates the successful completion condition for the stored procedure.

Prev
-5040 to -1000 		Up
Check for Revisions 		Next
0


0

Successful Interface Completion Status Code

Any interface call can return the following status code.

0: The interface completed successfully

This status code is returned for any interface call that completes successfully. If an operation is not successful, a nonzero status code is returned.

Prev
-199 to -100 		Up
Check for Revisions 		Next
1 to 199


1 to 199

MicroKernel Database Engine Status Codes

This section describes status codes that the MicroKernel returns.

1: The operation parameter is invalid

The specified operation does not exist or is not valid.

You may receive this error if you are running a general-release version of the V8 client software against a pre-release version of the V8 database engine. If this is the case, you must uninstall your database engine and install the general release version.

2: The application encountered an I/O error

This status code typically indicates a corrupt file, an error while reading from or writing to the disk. One of the following has occurred:

  • The file is damaged, and you must recover it. Refer to the Advanced Operations Guide for more information on recovering files.
  • In NetWare, at least one MicroKernel data file is flagged as Shareable. All MicroKernel data files should be flagged as Non-Shareable. The MicroKernel is the only user that accesses the files (on behalf of many database users). As the only user, the MicroKernel can control the integrity of the data files. If you flag your MicroKernel data files as Shareable, data corruption can occur.
  • For pre-v6.0 data files, there is a large pre-image file inside a transaction, and there is not enough disk space for a write to the pre-image file.
  • For pre-v6.0 data files, there is one pre-image file for multiple data files. For example, if you name the data files CUSTOMER.ONE and CUSTOMER.TWO, both files have pre-image files named CUSTOMER.PRE.
  • For pre-v6.0 data files that are larger than 768 MB, there is a conflict among locking mechanisms. The file has not been corrupted. Your application can retry the operation until the conflict is resolved (when the competing application releases the lock your application requires).
  • A pre-v6.0 Btrieve engine attempted to open a v6.x or later MicroKernel file.
  • With Btrieve for Windows NT Server Edition v6.15.445, 32 bit Windows application may return Status 2 or "MKDE Terminated with Service Specific Error 0" after running an application for an extended period of time.
  • There was a conflict with the assignment of token handles and permissions. You may receive status 2 or corruption on very busy SMP boxes, when a user is deleted from the Btrieve Monitor and the user immediately reopens the files. There is an FTF for Pervasive.SQL v.7.0 Windows NT and for Service Pack 3 for Pervasive.SQL 2000i Windows NT. This issue has been fixed in Pervasive.SQL V8 and later releases.

Note
Please see our Pervasive.SQL Knowledge Base for new and updated articles on troubleshooting this status code. You can access the Knowledge Base at: http://support.pervasive.com/eSupport/.

3: The file is not open

The operation cannot execute because the file is not open. The application must perform a successful Open operation before the MicroKernel can process any other operations. The MicroKernel also returns this status code if the application passed an invalid position block for the file, or if the application passed a position block with a client ID other than the client ID used to open the file.

Note
Please see our Pervasive.SQL Knowledge Base for new and updated articles on troubleshooting this status code. You can access the Knowledge Base at: http://support.pervasive.com/eSupport/.

4: The application cannot find the key value

The MicroKernel cannot find the specified key value in the index path.

  • When you receive this status code on an Update or Delete operation, it usually means that the file is damaged, and you must recreate it. Occasionally, a corrupt key can cause this status code. Drop the key, then add it again.
  • The MicroKernel returns this status code when an application performs a Get Equal operation to search on field type char. It is caused by a mismatch of two fields at the char level. To resolve, fill the KeyBuffer with the same fill char type as the field.

5: The record has a key field containing a duplicate key value

The MicroKernel cannot add or update a record because the record has a key field that contains a duplicate key value for an index that does not allow duplicate values. The MicroKernel also returns this status code when it cannot create an index that does not allow duplicate key values because a duplicate key value already exists.

6: The key number parameter is invalid

The value stored in the key number parameter is not valid for the file being accessed. The key number must correspond to one of the keys defined for the file. Valid key numbers are 0 through 118.

7: The key number has changed

The key number parameter changed before a Get Next, Get Next Extended, Get Previous, or Get Previous Extended operation. The operation requires the same key number parameter as the previous operation, because the MicroKernel uses positioning information relative to the previous key number.

In a related situation, the MicroKernel returns this status code when an application performs a Delete or Update operation immediately following a Get operation. If the application changes the value of the key number in the Delete or Update operation (from the value used with the preceding Get operation), the MicroKernel deletes or updates the record as requested and does not return this status code, at least not at this point. However, the MicroKernel does return this status code on the very first Get Next, Get Next Extended, Get Previous, or Get Previous Extended operation performed after the deletion or update, even if that Get operation uses the same key value the application passed to the Delete or Update operation.

If you need to change key numbers between consecutive Get Next, Get Next Extended, Get Previous, or Get Previous Extended operations (or in Delete or Update operations as described in the preceding paragraph), use a Get Position operation followed by a Get Direct/Record operation to reestablish positioning for the new index path.

8: The current positioning is invalid

You must establish the current position in order to update or delete a record. Perform a Get or Step operation to establish the current position. The MicroKernel also returns this status code if the application passed an invalid position block for the file.

9: The operation encountered the end-of-file

The MicroKernel returns this status code in the following situations:

  • The operation encountered an end-of-file boundary or tried to read past a file boundary (end-of-file or start-of-file).
  • In a Get Next Extended, Get Previous Extended, Step Next Extended, or Step Previous Extended operation, the number of records satisfying the filtering condition is less than the number of specified records to be returned, and the reject count or filter limit has not been reached.
  • When reading a file in ascending order according to an index path, the MicroKernel has already returned the last record in that index path. When reading a file in descending order according to an index path, the MicroKernel has already returned the first record in the index path.
  • When using the Get By Percentage operation, either the value supplied for the percentage is too high—it exceeds 10,000 decimal (0x2710)—or the file contains no records.
  • When using the Get operation using ActiveX Data Control, this error will occur only after the application is compiled and deployed. This error will not occur at design time during development. The error results from a missing MSDADC.DLL on the deployment machine. Make sure to include this file (MSDADC.DLL) in your installation script. This file is a Microsoft MDAC (Microsoft Data Access Component) file.

Note
Please see our Pervasive.SQL Knowledge Base for new and updated articles on Btrieve ActiveX Controls. You can access the Knowledge Base at: http://support.pervasive.com/eSupport/.

10: The key field is not modifiable

During an Update operation, the application attempted to modify a key field that is cannot be modified by definition.

11: The specified filename is invalid

The MicroKernel returns this status code in the following situations:

  • The specified filename does not conform to file naming conventions or the pathname is invalid. Make sure the filename or pathname is valid for the environment.
  • If operating in the client/server environment:
    • The application attempted to open a file that has .^^^ as its extension. This extension is reserved for the MicroKernel to use during continuous operation. (Only server engines can use continuous operation.)
    • The data buffer for a Begin or End continuous operation is not set up correctly.
    • You attempted to load a remote file when your client configuration settings Client 4 Access 4 Use Local MicroKernel Engine and Client 4 Access 4 Use Remote MicroKernel Engine incorrectly set to On and Off, respectively. To resolve this condition, at the client workstation, open Pervasive Control Center from Start 4 Programs 4 Pervasive.SQL V8. Within Control Center, double-click Configuration, then double-click Client and Access. Set Use Remote MicroKernel Engine to On. For more information about Configuration settings, refer to Advanced Operations Guide.
    • You attempted to open a local file with a Workgroup engine that isn't the designated Gateway engine for the file. Go to the directory where the file you attempted to open resides. Check to see if the ~pvsw~.loc in that directory is flagged read only. If it is, change it to read-write.
  • If you are using the dynamic locator file with your Workgroup engine:
    • Make sure the name of the second-level locator file specified in your first-level locator file does not have the same name as an existing directory. Also, make sure they are all on the same drive.
    • Make sure the second-level locator file specified in your first-level locator file can be accessed by the engine.
    • Make sure all the Workgroup engines sharing the dynamic locator feature have the exact same drive mapping to the server location where the data files reside.
  • If you are accessing files on a DOS client:
    • A NET START FULL for the Windows for Workgroups workstation was not used when it was booted into DOS. Use a NET START FULL to get a full redirector in the DOS client mode. BREQNT.EXE requires a full redirection. At the DOS prompt type "net ver" <Enter>. Here is the list of required components for a DOS workstation to connect to a Windows NT server:
      LSL.COM LAN Card Driver
      IPXODI.COM
      IFSHLP.SYS
      NET START FULL

      These can be loaded high, using emm386. NET START FULL will load in upper memory. NETX is required ONLY if you are connecting to a NetWare server.
  • You attempted to open a file with a long filename on NSS volumes. The MicroKernel queries the volumes using OS calls and then loads the appropriate drivers for the associated name spaces it find for the volumes. In this case, the MicroKernel was being loaded before mounting the volumes so it did not find the requirement for long filename support by the NSS volumes.
    • Issue the MGRstart or Bstart command after loading the volumes. An example would be:
      LOAD NSS
      MOUNT ALL
      SYS:ETC\INITSYS.NCF
      MGRSTART or BSTART
  • If you are working in the Microsoft Terminal Server environment:
    • Approximately 5 users can work in a Windows application on 2 different Terminal Servers that are connected to a primary Windows NT 4.0 server. If you have attempted to run on top of this limit, you will receive status codes 11 and 35. For the recovery solution for this instance, refer to Microsoft Knowledgebase Article 190162, "Terminal Server and the 2048 Open File Limitation."

12: The MicroKernel cannot find the specified file

  • Check that the file exists and that you specified the correct file.
  • Check the key buffer parameter to make sure the pathname is terminated with a blank or a binary zero.
  • When accessing a file on a server, ensure that you have FILE SCAN rights to the directory in which the file resides. Occasionally, a corrupt key can cause this status code. Drop the key, then add it again.
  • In Novell NetWare 4.x environments, check for files with the hidden file attribute at the Operating System level and remove the hidden file attribute.

    This does not occur with NetWare 5.

  • An ODBC connection may receive this code on NetWare 4.x with the Pervasive.SQL Workgroup Engine. This status code did not appear until Pervasive.SQL 2000 Service Pack 2a. It is caused by Netware 4.x reporting long directory in a different format than NetWare 3.x, NetWare 5.x, or the Win32 Environment.

    Novell has a fix for this problem in a file named Mixmod6.exe. Search for file at Novell's web site (http://www.novell.com).

  • This error code may also be returned when the file DBNames.CFG has been removed (for example, by the Pervasive.SQL cleanup utility) and old Data Source Names (DSNs) which reference that file are not removed from the ODBC configuration. You attempted to open a local file with a Workgroup engine that isn't the designated Gateway engine for the file. Go to the directory where the file you attempted to open resides. Check to see if the ~pvsw~.loc in that directory is flagged read only. If it is, change it to read-write.
  • You may have a Status 12 returned and see X$FILE.DDF for the file name in your DDFs.
    • If the file.ddf is examined with a Btrieve utility, the location name for the dictionary files will be x$file.ddf, x$field.ddf, x$index.ddf, instead of the standard file.ddf, field.ddf, index.ddf. An unsupported DDF Creation utility called DDL Services (DDLSVCS.DLL) created the DDFs. DDL Services has a known bug that causes the system table to be populated with incorrect data. To resolve this error, recreate the DDFs using a newer tool (SQL Data Manager/Pervasive Control Center).
  • You may get Status 12 when a file with a filename or path with embedded spaces is opened on Windows 9x, Windows NT or Windows 2000. For long NetWare file names, support is available only in the MicroKernel and not in NLM utilities such as BUTIL.NLM. Btrieve data files can be accessed using long names but long names cannot be used for other files. For example, in the NLM command:

    BUTIL -CREATE <outputFile> <descriptionFile>

    Since MKDE manipulates the <outputFile> Btrieve data file, it can have a long name. However, the <descriptionFile> can only have a short name (such as BUTIL.NLM) since it does not accept long names. The solution is to enable the client configuration option, Application characteristics 4 Embedded Spaces.

To Enable Embedded Spaces in Pervasive.SQL 2000i or later:

  1. Click Start 4 Programs 4 Pervasive.SQL V8 4 Control Center.
  2. Expand Pervasive.SQL V8 Engines and expand the desired database.
  3. Expand Configuration, then expand Client, and click on Application Characteristics.
  4. In the right hand frame, double-click on Embedded Spaces.
  5. Select On.
  6. Exit the configuration utility and restart the engines for the new settings to take effect.

13: The MicroKernel could not open the extension file for an extended file

The MicroKernel could not open the extension file for an extended file that the application tried to open. An extended file can consist of a base file and up to 31 extension files. Extension files must remain in the same volume and directory as their base files. The MicroKernel returns this status code if you delete, move, or rename the extension files.

14: The MicroKernel cannot create or open the pre-image file

The MicroKernel uses pre-image files only for pre-v6.0 data files.

The MicroKernel returns this status code in one of the following situations:

  • The MicroKernel cannot create a new pre-image file because the disk directory is full. The MicroKernel must be able to create a pre-image file.
  • The MicroKernel cannot open the pre-image file to restore file integrity. If the pre-image file is erased or damaged, the MicroKernel cannot restore the file integrity. Refer to Advanced Operations Guide for more information about recovering damaged files.
  • The workstation MicroKernel cannot assign a handle to the pre-image file because the MicroKernel was not started by a user with access rights to the pre-image file.
  • The file structure of a pre-image file created by this MicroKernel is different from the file structure of a pre-image file created by a v5.x MicroKernel. If you have an extraneous .PRE file in v5.x format, the MicroKernel returns this status code when you try to open the data file to which the .PRE file belongs.

15: The application encountered an I/O error during pre-imaging

The MicroKernel uses pre-image files only for pre-v6.0 data files.

  • The pre-image file is damaged and the integrity of the data file cannot be ensured. Refer to Advanced Operations Guide for more information about recovering damaged files.
  • The disk is full. Erase any unnecessary files.

16: The application encountered an expansion error

This status code is obsolete in MicroKernel versions 6.0 and later.

The MicroKernel encountered an error while writing the directory structure to disk prior to creating the expanded file partition. Either the MicroKernel cannot close the file, or a new page was added to the file and the MicroKernel cannot close and reopen the file to update the directory structure. Check for a disk hardware failure.

18: The disk is full

The MicroKernel can return this status code in the following situations:

  • The disk is full and the MicroKernel cannot expand the file to accommodate additional records. Erase any unnecessary files.
  • There is not enough space to append a new page to the data file.
  • The pre-image file is out of disk space. If your files are in pre-v6.0 format and you are in a transaction, the pre-image file size increases for the duration of the transaction. If you receive this status code, either reduce the number of operations in the transaction, or obtain more disk space.
  • For files located on a NetWare server, the NetWare owner name for the file is no longer valid, and your application tried to insert or update records in the file, thus causing the file to expand. In this case, the MicroKernel returns this status code when it needs to add a page to the file, regardless of how much disk space is available. To check for an owner name, use the NetWare utility NDIR. To add an owner name, use either FILER (a NetWare text utility) or the NetWare Administrator graphical utility.
  • In some environments, you can restrict the amount of disk space available to each user. This status code indicates that the application attempted to expand a data file beyond the amount of disk space allocated to the file owner.
  • You tried to read or modify a file which was not closed properly after a disk full error. Make sure that every application using the file at the time of the disk full error closed the file successfully.
  • If a client connected to a Pervasive.SQL server encounters this status code, other clients performing read-only operations from the same disk may also receive a non-zero status.

19: The application encountered an unrecoverable error

To ensure file integrity, recover the file as described in Pervasive.SQL User's Guide.

20: The MicroKernel or Btrieve Requester is inactive

Note
For an expanded list of possible recovery solutions, consult the Pervasive.SQL Knowledge Base at http://support.pervasive.com/eSupport.

  • If you are running an application in a client/server environment:
    • Make sure the Btrieve requester is loaded.
    • Verify that the IPX/SPX or TCP/IP protocol is properly installed at the client machine and that no two machines on the network have the same Internal Network Number.
    • Make sure at least one of the client configuration options, Access 4 Use Local MicroKernel Engine or Access 4 Use Remote MicroKernel Engine is enabled. If your environment includes both a server engine and Workgroup engines, you should have both settings enabled.
  • If you are running an application in a workstation/workgroup environment, make sure the MicroKernel is loaded.
  • If you are running an application in a client/server environment and also need to access files located on a local drive:
    • Make sure the Btrieve Requester is loaded.
    • Make sure both of the client configuration options, Access 4 Use Local MicroKernel Engine or Access 4 Use Remote MicroKernel Engine are enabled.
    • Make sure a local MicroKernel is available and loaded.
  • If you are operating in a DOS server environment:

    Pervasive.SQL V8 installs BTRBOX95 by default. As long as this is installed no other requester can be used.

    • If you want to use BREQNT, BREQUEST, or BREQTCP, you must remove BTRBOX95 and make sure the proper requesters are loaded. Refer to Getting Started with Pervasive.SQL for more information.
    • If you want to use BTRBOX95:
    • Change directories to \pvsw\clients\dos\windosbox and run the setup utility. This loads the appropriate file for clients running Windows 9x or Windows NT. The setup program creates and places a README.TXT file in the \pvsw\W32DOXBOX directory.
    • After installation, reboot the client.
    • For Windows NT users: open a command prompt and run a DOS Btrieve application.
    • For Windows 9x users:
  • Run the BTRBOX95.exe. A minimized dialog box appears, indicating that BTRBOX95 support is active. If you close this dialog box, it will unload BTRBOX95. You only need to run BTRBOX95.exe once even though you have multiple DOS sessions open.
  • Open a command prompt and run your DOS Btrieve application.
  • If you are operating in a NetWare environment:
    • Make sure the Microkernel and (if applicable) the Btrieve Requester are loaded before generating any requests.
    • Make sure the appropriate communication modules are loaded at the server.
  • If you are operating in a Windows NT server environment:
    • Make sure the MicroKernel is started before generating any requests.
    • Make sure the Windows NT DLLs are in your path.
    • Make sure the appropriate communications modules are loaded at the server.

21: The key buffer parameter is too short

The key buffer parameter is not long enough to accommodate the key field for the requested index path. Verify that the length of the key buffer equals the defined length of the key specified in the key number parameter.

22: The data buffer parameter is too short

  • The data buffer parameter specified by the application was not large enough to accommodate either the minimum length of the record for an Insert or Update operation, or the entire record length for a Get or Step operation. Also, the data buffer may not be large enough to accommodate the length of data required for operations such as Create, Create Index, Stat, Get By Percentage, Find Percentage, or Version.
    • For Get or Step operations, the MicroKernel returns as much data as it can and this status code, indicating that it cannot return the entire record.
    • For an Insert operation, the MicroKernel does not insert the record if the data buffer is shorter than the fixed-length portion of the record.
    • For an Update operation, if the data buffer is too short to contain the fixed-length portion of a record, the MicroKernel does not update the record.
    • For the Create, Stat, and Create Index operations, the data buffer is not long enough to contain all the file specifications, the key specifications, and (if specified) the Alternate Collating Sequence (ACS) definition.
    • For the Get by Percentage or Find Percentage operation, the data buffer length is less than 4 bytes.
    • For the Version operation, the data buffer length is less than 5 bytes.
    • The data buffer parameter is too short when access table with more than 60 field using ActiveX. Download the latest ActiveX controls from the Pervasive web site (http://www.pervasive.com/developerzone/access_methods/activex.asp)
  • A corrupt file may be indicated if the file allows variable-length records and you receive this status code on a Get or Step operation. In such a corrupt file, you can receive Status Code 54 when you use Get or Step operations to read other records. Recover the file according to the instructions in Pervasive.SQL User's Guide.

23: The position block parameter is not 128 bytes long

This status code is obsolete in Btrieve language interface versions 6.0 and later.

The position block parameter must be exactly 128 bytes long.

24: The page size or data buffer size is invalid

The MicroKernel returns this status code in one of the following situations:

  • The page size you specified when creating a file is invalid. The page size must be a multiple of 512 bytes and cannot exceed 4096 bytes.
  • During a Create operation, the page size is the first file specification the MicroKernel checks. If you receive this status code at this point, it can indicate an invalid data buffer parameter.

25: The application cannot create the specified file

The MicroKernel returns this status code in one of the following situations:

  • If an application attempted to create a data file, the disk directory or the disk itself may be full.
  • If an application tried to create a file over an existing file, the existing file is open or the operating system will not allow the operation for another reason (such as when a file is flagged transactional in NetWare).
  • In an attempt to create a Btrieve file over existing Btrieve file, this status will be returned. The keybuffer on the Btrieve create operation API (opcode 14) is set properly to create a file over an existing file.
    • This problem may be caused by Antivirus software (such as Innoculan)

Note
This happens when the Operating system returns an unusual status code to the engine. Normally, the engine expects either a success or the file already exists. In one situation, the error code was being returned because the file handle that the engine was using was not functional; however, the OS call that the engine makes is supposed to return a file handle.

One solution is to disable the Antivirus software. Contact the third party vendor for additional information on configuring the Antivirus software to eliminate scanning specific data files.

26: The number of keys specified is invalid

The number of keys specified for the page size is invalid. The number of key segments must be within the following limits:
Table 1-6 Maximum Number of Key Segments
Page Size | 512 | 1024 | 1536 | 2048 | 2560 | 3072 | 3584 | 4096
Maximum Number Key Segments | 8 | 23 | 24 | 54 | 54 | 54 | 54 | 119

If the MicroKernel is configured to create files in v5.x format, the maximum number of key segments is 8 for files using 512 byte page sizes; the maximum number of key segments for all other v5.x files is 24.

For a key-only file, this status code is also returned if the number of keys specified is not one, or the available linked keys is not zero (only one key is allowed for a key-only file.)

Pervasive.SQL V8 nullable columns: Because each indexed nullable column with true null support requires an index consisting of 2 segments, you cannot have more than 59 indexed nullable columns in a table (or indexed nullable true null fields in a Btrieve file). This limit is smaller for smaller page sizes (1/2 the values noted above, rounded down). Any file created with Pervasive.SQL, with file create mode set to 7.x or later, and TRUENULLCREATE set to the default value of On, has true null support. Files created using an earlier file format, or with Pervasive.SQL 7, or with TRUENULLCREATE set to Off, do not have true null support and do not have this limitation.

27: The key position is invalid

The specified key field position is less than 1 or exceeds the defined record length for the file. Either the key position is greater than the record length or the key position plus the key length exceeds the record length.

28: The record length is invalid

The physical record length, which is the logical record length specified when creating the file plus any additional overhead for duplicate keys, reserved duplicate pointers, variable record pointers, and blank trunctation information must be less than or equal to the page size minus 10 bytes (8 bytes if creating files in version 5 file format), and must be greater than or equal to 4 bytes.

For key-only files, the maximum record length is 253 bytes (255 bytes if creating files in version 5 file format).

For more information about calculating the physical record length, see Pervasive.SQL Programmer's Guide.

29: The key length is invalid

The MicroKernel returns this status code in one of the following situations:

  • You have not specified a key length that is greater than 0 but does not exceed 255 bytes. The length of a key segment must agree with its key type if the key type implies a length (for example, an integer key must have a length evenly divisible by two). Each key page in the file must be large enough to hold at least eight keys. If the page size is too small to accommodate eight occurrences of the specified key length (plus overhead), you must increase the file page size or decrease the key length.
  • An additional byte of storage space is needed for the null indicator for the column. This error occurs through a SQL CREATE INDEX statement, or through the creation of a SQL PRIMARY KEY or FOREIGN KEY, if the index, or key, references a null CHAR column of 255 characters (or VARCHAR of 254). This additional byte causes the actual length of the index to be one byte longer, or 256 bytes. To resolve the error, reduce the size of the column or create the column as NOT NULL and try again. For a foreign key, if you decrease the size of the column, you must decrease both the referencing column and the referenced column.
  • You have tried to create a Btrieve file with more than one index. This may occur in the Btrieve v6.15 Windows95/NT environment. The problem is reproducible developing 32-bit application using Microsoft Visual Basic and is caused by long variables aligned on even word boundaries. The solution is to not use the long variable in the KeySpec type. Use a four (4) byte string instead of a long variable in the type definition. Then convert the string into a long.

30: The file specified is not a MicroKernel file

This status code is returned in one of the following situations:

  • The MicroKernel did not create the file, or a pre-v3.x MicroKernel created it.
  • While using an earlier version of Btrieve, you opened a file created by a later version that has a format incompatible with the earlier version.
  • The first page of the file may be damaged. Use a backup copy of your data file. If you receive this status code and you suspect that the header page of the source file is damaged, recover the file as described in Advanced Operations Guide.
  • You have attempted to access a valid Btrieve file. This status code is returned when old engines access newer file formats. A likely scenario is that data created by a new server engine is later used by an earlier Workgroup engine. Status 30 can be reported if the file format is newer than the MicroKernel engine attempting to open it. Particularly, accessing a 7.x file with a 6.x engine causes this error.

    NOTE: Previously, accessing a 6.x file with a 5.x engine returned Status 2: "the application encountered an I/O error".

31: The file is already extended

This status code is obsolete in MicroKernel versions 6.0 and later.

An application tried to extend a file that had already been extended; you can only extend a file once.

32: The file cannot be extended

The MicroKernel must create an extension file to accommodate a file which is growing larger than the operating system file size limit. However the MicroKernel encounters an error from the operating system when it tries to create and open the new extension file. Possible causes for receiving this status code include the following: the directory is full, the disk is full, or the MicroKernel has not been granted sufficient rights by the operating system.

33: The MicroKernel cannot unload

In the DOS environment, The MicroKernel returns this status code for the following reasons:

  • You attempted to unload the MicroKernel when you have loaded another terminate and stay resident (TSR) program after you loaded the MicroKernel. Unload the other TSR before unloading the MicroKernel.
  • You attempted to unload the MicroKernel from a 32-bit application that uses the BSTUB interface with the DOS/4G extender.

34: The specified extension name is invalid

This status code is obsolete in MicroKernel versions 6.0 and later.

An application specified an invalid filename for the extended partition. Check the validity of the filename.

35: The application encountered a directory error

Either a Get Directory operation specified a drive that does not exist, or a Set Directory operation specified an invalid pathname. Check the validity of both the drive and the pathname.

37: Another transaction is active

The application issued a Begin Transaction (19 or 1019) operation while another transaction was active by the same user or task; the active transaction can be nested or non-nested. This status code often indicates a problem in nested transactions within your application.

38: The MicroKernel encountered a transaction control file I/O error

This status code is obsolete in MicroKernel versions 7.0 and later.

The MicroKernel tried to write to the transaction control file. Possible causes for receiving this status code are that the disk is full, the disk is write protected, the transaction control file (BTRIEVE.TRN) that is created when you load the MicroKernel has been deleted, or the transaction control file is flagged read-only or is corrupt.

39: A Begin Transaction operation must precede an End/Abort Transaction operation

The application issued an End Transaction (20),or Abort Transaction (21) operation without a corresponding Begin Transaction (19 or 1019) operation. Make sure that each End or Abort Transaction operation in your program is executed only after a successful Begin Transaction operation.

40: The file access request exceeds the maximum number of files allowed

This status code is obsolete in MicroKernel versions 6.0 and later.

The application tried to access more than the maximum number of files allowed within a transaction. You set the maximum number of different files that you can access during a logical transaction when you configure the MicroKernel.

41: The MicroKernel does not allow the attempted operation

The MicroKernel returns this status code for the following reasons:

  • The application tried to perform an operation that is not allowed under these operating conditions. The MicroKernel does not allow some operations under certain operating conditions. For example, the MicroKernel returns this status code if the application attempts to perform a Step operation on a key-only file.
  • If using a server engine, the key number parameter of a continuous operation MicroKernel call is not valid.

The MicroKernel prohibits certain operations during transactions because they have too great an effect on the file or on performance. These operations include Set Owner, Clear Owner, Create Index, and Drop Index.

42: A file previously opened in Accelerated mode was not closed

This status code is obsolete in MicroKernel versions 6.0 and later.

The MicroKernel returns this status code for the following reasons:

  • Either the application tried to open a v5.x data file that was previously accessed in Accelerated mode by a v5.x MicroKernel and never successfully closed, or the application tried to open a file for which a v6.0 or later MicroKernel encountered an unrecoverable error during a Set or Clear Owner operation. The file integrity cannot be ensured. Refer to Advanced Operations Guide for information about recovering damaged files.
  • Your application tried to open a file in MicroKernel v5.x format using a v5.x MicroKernel; however, that same file was previously accessed by a v6.0 or later MicroKernel, which failed to close the file successfully and left a pre-image file on the disk. Version 5.x MicroKernels cannot read pre-image files created in v6.0 or later format.

43: The specified record address is invalid

The MicroKernel returns this status code for the following reasons:

  • The record address specified for a Get Direct operation is invalid. Either the address is outside the file boundaries, or it is not on a record boundary within or on a data page, or the record at the specified address has been deleted. For a Get Direct operation, specify the 4-byte address obtained by a Get Position operation.
  • If the records' file is in v5.x format, this status code can indicate a file access conflict. For example, task 1 has a file locked in an exclusive transaction. Task 2 is reading records from the same file and tries to update a record that the transaction inserted. If task 2 reads the record and then task 1 aborts the transaction, task 2 receives this status code when issuing the Update operation.
  • For a Find Percentage operation that is seeking a percentage based on a record's physical location within the file, the specified record address is invalid.
  • The file may be corrupt, and you must recover it. Refer to Advanced Operations Guide for information about recovering damaged files.

44: The specified key path is invalid

The application tried to use the Get Direct/Record operation to establish positioning on an index path for a key whose value is null in the corresponding record. The MicroKernel cannot establish positioning based on a null key value.

45: The specified key flags are invalid

The key flags specification on a Create operation is inconsistent. If a key has multiple segments, the duplicate, modifiable, and null attributes should be the same for each segment in the key. Also, you cannot use the null or manual key attributes in a key-only file. The MicroKernel also returns this status code if the application attempted to specify a different Alternate Collating Sequence (ACS) for two or more segments of a segmented key.

46: Access to the requested file is denied

The MicroKernel returns this status code for the following reasons:

  • The application opened a file in Read-only mode and tried to perform a Write operation on that file.
  • The application attempted to perform a Write operation on a file that is flagged read-only by the operating system.
  • When the application opened the file, it did not correctly specify the owner name required for updates.
  • (Workgroup engine only) If a Workgroup engine user or task opens a file that a client machine has opened using a server MicroKernel, the MicroKernel returns this status code if the Workgroup engine user attempts to write to the file.

47: The number of files opened exceeds the maximum allowed

This status code is obsolete in MicroKernel versions 6.0 and later.

Pre-v6.0 workstation MicroKernels return this status code when the number of files opened in Accelerated mode exceeded the number of buffers available in the MicroKernel cache. When a file is opened in Accelerated mode, the MicroKernel reserves one of its cache buffers for the file. It always reserves five empty buffers for index manipulation. Reconfigure Btrieve with both a smaller /P configuration option (to allocate more buffers) and a larger /M option (to increase the cache allocation).

48: The alternate collating sequence definition is invalid

The MicroKernel returns this status code for the following reasons:

  • The first byte of an Alternate Collating Sequence (ACS) definition (the identification byte) does not contain the hexadecimal value AC (for user-defined ACSs), AD (for locale-specific ACSs), or AE (for international sorting rules support). Make sure that the first byte contains the appropriate value.
  • You set the Create File Version option to v5.x, and you attempted to create a file that contains a key with a locale-specific ACS. Pre-v6.0 files do not support locale-specific ACSs.

49: The extended key type is invalid

The MicroKernel returns this status code for the following reasons:

  • You tried to create a file or an index with an invalid extended key type.
  • You tried to assign an Alternate Collating Sequence (ACS) to a BINARY key or key segment. You can assign an ACS only to a STRING, LSTRING, WSTRING, WZSTRING, or ZSTRING key type.
  • You defined an index requiring an ACS, but no ACS definition exists either in the file or in the key definition passed in the data buffer.
  • You attempted to create a key segment with both the Case Insensitivity and the ACS flags set, and the MicroKernel is configured to create files in v5.x format. This combination is invalid for v5.x files.
  • You set the Create File Version value to v5.x, and you attempted to create a file with a NUMERICSA or NUMERICSTS key. Pre-v6.x files do not support these key types.

    OR

  • You set the Create File Version value to v6.x, and you attempted to use one of the new Pervasive.SQL V7 data types, such as CURRENCY or TIMESTAMP. Pre-v7.x files do not support these key types. Increase the setting for this component.

To change the Create File Version setting:

  1. Click Start 4 Programs 4 Pervasive.SQL V8 4 Control Center.
  2. Expand Pervasive.SQL V8 Engines and expand the desired database.
  3. Expand Configuration, then expand Server, and click on Compatibility.
  4. In the right hand frame, double-click on Create File Version.
  5. Adjust Current with a higher file version.
  6. Exit Configuration and restart the engines for the new settings to take effect.

50: The file owner is already set

The application tried to perform a Set Owner operation on a file that already has an owner. Use the Clear Owner operation to remove the previous owner before specifying a new one.

51: The owner name is invalid

The MicroKernel returns this status code for the following reasons:

  • If the application received this status code from a Set Owner operation, the owner names specified in the key buffer and data buffer do not match.
  • If this status code occurred during an Open operation or a DROP TABLE statement, the application attempted to open a file that has an owner name assigned to it. The application must specify the correct owner name in the data buffer. Ensure that the owner name is null-terminated in the data buffer and that the data buffer length is set long enough to include the owner name plus the null terminator.

52: An error occurred while writing to the cache

This status code is obsolete in MicroKernel versions 6.0 and later.

While trying to make a cache buffer available, the MicroKernel attempted to write data to a disk from a file that was previously opened in Accelerated mode. The operating system returned an I/O error during the write. This generally indicates a hardware memory problem. Unload and reload Btrieve before you continue.

53: The language interface version is invalid

An application tried to access a file containing variable-length records with a language interface from Btrieve v3.15 or earlier.

54: The variable-length portion of the record is corrupt

During a Get or Step operation, the MicroKernel could not read all or part of the variable-length portion of a record. The MicroKernel returns as much data as possible to the application. This status code usually indicates that one or more pages used to store variable-length records are corrupt. Check the data buffer length the MicroKernel returns to see how much of the record was returned. Recover the damaged file as described in Pervasive.SQL User's Guide.

55: The application specified an invalid attribute for an AUTOINCREMENT key

The data field indexed by an AUTOINCREMENT key can be part of a different segmented key only if the key number of the AUTOINCREMENT key is less than the key number of the new segmented key and the new data type flag referencing the field is not AUTOINCREMENT

56: An index is incomplete

An index can be damaged if a Create Index operation (31) or a Drop Index operation (32) is interrupted before it runs to completion. Perform a Drop Index operation to completely remove the damaged index from the file, then rebuild the index with the Create Index operation, if desired.

57: An expanded memory error occurred

This status code is obsolete in MicroKernel versions 6.0 and later.

Btrieve for DOS returns this status code if it receives an error from the Expanded Memory Manager. This status code usually means that the MicroKernel was unable to save or restore the memory mapping register context, indicating an incompatibility with another application that uses expanded memory.

58: The compression buffer length is too short

This status code is obsolete in Pervasive.SQL 2000i and later versions.

59: The specified file already exists

During a Create operation, the application specified -1 in the key number parameter and the name of an existing file in the key buffer parameter. To overwrite the existing file, remove the -1 from the key number parameter. To preserve the existing file, alter the filename specified in the key buffer parameter.

60: The specified reject count has been reached

The MicroKernel rejected the number of records specified by the reject count before a Get Next Extended, Get Previous Extended, Step Next Extended, or Step Previous Extended operation found the requested number of records that satisfy the filtering condition. Check the first two bytes returned in the data buffer for the number of records that were retrieved.

61: The work space is too small

The Get Next Extended, Get Previous Extended, Step Next Extended, and Step Previous Extended operations use a buffer as work space. This status code indicates that the work space (set by default to 16 KB) is not large enough to hold the filtering data buffer structure and the largest record to be received. You will receive Status Code 0 if the work space is large enough to hold the filter/extraction expression and enough of the record to include all of the fields to be filtered or extracted.

62: The descriptor is incorrect

This status code is returned in the following situations:

  • The descriptor (data buffer structure), which is passed for a Get Next Extended, Get Previous Extended, Step Next Extended, or Step Previous Extended operation, is incorrect. The descriptor length (the first two bytes of the data buffer) on the extended operation call must be the exact length of the descriptor. This requirement does not apply to the data buffer length option, which can still be declared longer than necessary.
  • On a Stat Extended operation, the signature field in the data buffer is not set to 0x74537845, the subfunction field is not set to 0x00000001, or the namespace field is not set to 0x00000000.
  • On a Get Direct/Chunk or Update Chunk operation, the descriptor structure in the data buffer is incorrect, or is inconsistent either internally or with respect to the data buffer length.
  • ActiveX control's buffers are not cleared and reallocated. Use the Init method to clear and reallocate the control's buffers before the use of any extended operations in the code. In addition, if you are using AutoMode, it is necessary to establish logical position (GetLast, GetFirst, GetEqual, etc.) before making the call to Init.

63: The data buffer parameter specified on an Insert Extended operation is invalid

An Insert Extended operation provided an invalid buffer. Either the buffer length is less than 5 bytes, or the number of records specified is 0. Correct the buffer length or the number of records.

64: The filter limit has been reached

The MicroKernel returns this status code for the following reasons:

  • During a Get Next Extended, Get Previous Extended, Step Next Extended, or Step Previous Extended operation, a rejected record was reached; no other record can satisfy the given filtering condition, going in the direction that the operation specified. This is applicable only if the first segment of the key that the key number specified is also used as the first term of the filtering field.
  • The number of records to be retrieved is greater than the number of records present in the file that satisfy the filter condition. This option is specified in the data buffer of the extended operation.

65: The field offset is incorrect

The field offset in the extractor of a Get Next Extended, Get Previous Extended, Step Next Extended, or Step Previous Extended operation is invalid based on the length of the retrieved record. Make sure that the field offset is a valid value (from 0 through the record length minus 1).

66: The maximum number of open databases has been exceeded

This status code is obsolete in Pervasive.SQL 2000i and later versions.

The MicroKernel tried to open files bound to too many MicroKernel databases. To avoid receiving this status code, you must set a higher value for the number of databases that the MicroKernel can open.

Refer to the Advanced Operations Guide for more information about bound files.

67: The MicroKernel cannot open the SQL data dictionary files

The MicroKernel returns this status code for the following reasons:

  • An application attempted to use a data file that is bound to a the MicroKernel database, but the MicroKernel could not open one of the MicroKernel data dictionary files (FILE.DDF or, if the file has RI definitions, RELATE.DDF) or the configuration file (DBNAMES.CFG).
  • You attempted to create a file with the Replace option, and a bound MicroKernel data file with the same name and location already exists. However, the MicroKernel could not open the MicroKernel data dictionary file FILE.DDF, or the configuration file (DBNAMES.CFG).

If the data file has RI definitions, the DBNAMES.CFG file must be in the location specified in the DBNames Configuration Location option in the server configuration settings. Also, ensure that FILE.DDF and RELATE.DDF (if the file has RI definitions) are in the locations specified by the Working Directory option in the server configuration settings.

68: The MicroKernel cannot perform the RI Delete Cascade operation

The MicroKernel cannot enforce the Delete Cascade rule on a file under RI control because the record that the application attempted to delete has more than 16 levels of descendants. Delete records from the lower levels, and then try again to delete the record that the application was attempting to delete initially. Refer to Advanced Operations Guide for more information about RI.

69: The Delete operation specified a file that is damaged

The application encountered an error while the MicroKernel was attempting to enforce the Delete Cascade rule in response to a Delete operation. This status code indicates that the related file has been damaged and must be recreated. Refer to Advanced Operations Guide for more information about RI and the Delete Cascade rule.

71: There is a violation of the RI definitions

  • If you attempted an Insert operation on a file under RI control, a foreign key value in the record to be inserted does not have a corresponding primary key in the referenced file.
  • If you are performing an Update operation, there are two possible causes for this status code:
    • You attempted to change the value of a primary key.
    • You attempted to change the value of a foreign key to a value that does not exist for the defined primary key.
  • If you attempted a Delete operation, the restrict rule is enforced, and a primary key value in the record you are trying to delete references a foreign key in the referenced file. Refer to Advanced Operations Guide for more information about RI.

72: The MicroKernel cannot open the RI referenced file

The referenced file cannot be found at the location specified by FILE.DDF and DBNAMES.CFG. Be sure that the referenced file is in one of the data file locations that the DBNAMES.CFG file specifies for the named database.

  • If the DBNAMES.CFG file is defined on a server, verify that the file location does not contain a drive letter.
  • If the DBNAMES.CFG file is defined for a Workgroup engine, make sure that the drive letters are the same (and map to the same locations) as specified in DBNAMES.CFG.

Refer to Advanced Operations Guide for more information about RI.

73: The RI definition is out of sync

The MicroKernel returns this status code for the following reasons:

  • You tried to open a data file that is bound to a MicroKernel database, and the database to which the file is bound was not found in the DBNAMES.CFG file.
  • You tried to open a data file with RI (Referential Integrity) definitions that are bound to a MicroKernel database, and the table to which the file is bound was not found in the database FILE.DDF file, or the table location and filename do not match the file location and filename as configured in the DBNAMES.CFG or FILE.DDF file.
  • You attempted to modify a bound file, and the RI definition for that file disagrees with the definition in the RELATE.DDF file.
  • You attempted an Insert, Delete, or Update operation that would change a foreign key, if the file related to this file is out of sync (an attempt to open or modify the related file would have returned this same status code).
  • You attempted to create a file with the Replace option, and a bound MicroKernel data file with the same name and location already exists. However, the MicroKernel detected that the existing bound file was out of sync (that is, an attempt to open the existing file would have returned this same status code).

Note
The same named database cannot exist on two servers on the same network. So, if the intent is to move the dictionaries to another server on the same network, one way would be to delete the named database on the old server before creating the same named database on the new server.

Check the RI constraints on your database. For information about how to do this, refer to Pervasive.SQL User's Guide.

74: The MicroKernel aborted the transaction

This status code is obsolete in MicroKernel versions 6.0 and later.

This is an informative status code. A NetWare-based MicroKernel replaced an End Transaction operation with an Abort Transaction operation after detecting an error for a Transaction Tracking System (TTS) file inside the transaction. The MicroKernel then executed the Abort Transaction operation.

76: There is a conflict on the referenced file

An application attempted to perform an Update, Insert, or Delete operation on an RI-controlled file that references another file. The application cannot open the referenced file for RI checking because it is already open in Exclusive mode. Wait until the referenced file is closed or is opened in a mode other than Exclusive, and then retry the operation. Refer to Advanced Operations Guide for more information about RI.

77: The application encountered a wait error

This status code is obsolete in MicroKernel versions 7.0 and later.

This is an informative status code. You must retry the operation yourself; the MicroKernel does not automatically retry the operation. A client/server MicroKernel returns this status code in one of the following situations:

  • The application specified a wait lock bias for an operation, but another user has locked the requested resource.
  • The application is currently processing a wait transaction and tried to access a file that another user has locked.

When you are using the Btrieve Requester to access the MicroKernel, the Requester waits and retries if a requested resource is locked. When a server-based application is accessing the MicroKernel and the requested resource is locked, a wait is also required. In this case, the MicroKernel is expected to perform the wait. Because this would occupy the MicroKernel and lock out other users who might be trying to release the requested resource, the MicroKernel does not perform the wait. Instead, it returns this status code, and the server-based application must retry later.

78: The MicroKernel detected a deadlock condition

The application should clear all resources by aborting, ending the transaction, or releasing all record locks before proceeding. This breaks the deadlock, allowing other applications to access the resources for which they are waiting.

79: A programming error occurred

This status code is obsolete in MicroKernel versions 7.0 and later.

There is a malfunction that the MicroKernel cannot specifically detect or from which the MicroKernel cannot recover. Retry the operation. If the error persists, there may be system corruption; try to clear the system by rebooting, and then try the operation again.

80: The MicroKernel encountered a record-level conflict

The MicroKernel did not perform the Update or Delete operation because of a record-level conflict. For example, station A reads a record, station B reads the same record and updates it, and then station A attempts to update the record. The application should reread the record prior to resending an Update or Delete operation. Alternatively, the application can employ record locks to avoid conflicts.

In key-only files, you receive this status code if the record is moved in the file b-tree after being read and before being updated or deleted. A record can move as a result of other records being inserted, updated, or deleted.

81: The MicroKernel encountered a lock error

The MicroKernel returns this status code in one of the following situations:

  • The application tried to unlock a record that is locked with a multiple record lock, but the record position stored in the data buffer does not correspond to any record locked in the associated file.
  • The application tried to unlock a single-record lock with a multiple-record lock or vice-versa.

82: The MicroKernel lost positioning

When performing a Get Next or Get Previous operation on a key with duplicates, the application tried to retrieve a record that was deleted or whose key value was modified by another application. Use a Get Equal or a Get Direct/Record operation to re-establish positioning. (See Status Code 44: The specified key path is invalid for a related positioning problem.)

83: The MicroKernel attempted to update or delete a record that was read outside the transaction

This status code is obsolete in MicroKernel versions 7.0 and later.

The application tried to update or delete a record within a transaction, but it did not read the record within the transaction. The application must read the record within the transaction before attempting to modify the data.

84: The record or page is locked

  • An Insert, Update, or Delete operation attempted to lock an index page to insert or delete a key value. Have your application check for this status code and retry the operation if the status code is returned.
  • When using a NetWare server engine, you can receive this status code when running an application on a Win95 client if the NetWare operating system runs out of record locks. To solve this, increase the "maximum record locks per connection" and, if necessary, the "maximum record locks" (system wide limit) on the NetWare server.
  • The application tried one of the following:
    • Applied a no-wait lock on a record that is currently locked by another application
    • Tried to access a file in a no-wait transaction while another application holds one or more active record locks in that file
    • Tried to update or delete a record locked by another application.

      The application can use either of the following recovery methods:

    • Retry the operation until it is successful. This can be the simplest and quickest solution for a network with light to moderate use.

Note
Applications should limit the number of retry attempts when status 84 is received inside a concurrent transaction. Otherwise, the application might enter a deadlock situation with another transaction. If status 84 is still received after a few retries, abort the transaction and then attempt the transaction again.

    • Use the wait option (+100/+300) instead of the no-wait option (in versions that support the wait option).

85: The file is locked

The MicroKernel returns this status code in one of the following situations:

  • The workstation MicroKernel has a file open, and client machine that has the Requester loaded tries to open the same file via the server MicroKernel. The server MicroKernel cannot open the file because it cannot obtain exclusive access. The client machine that has the Requester loaded receives this status code.
  • In a multi-engine file sharing (MEFS) engine environment (such as with Btrieve 6.15), the MicroKernel can return this status code on an Open, Insert, Update, or Delete operation for a file under heavy usage by multiple users or tasks. The MicroKernel must momentarily have exclusive access to the file during these operations, and it retries the operation several times before returning this status code. In this case, the application can reissue the operation. In addition, you can reconfigure the workstation MicroKernel with a lower Operation Bundle Limit and Initiation Time Limit to reduce the amount of time the MicroKernel keeps a lock on the file. Refer to the Advanced Operations Guide for more information on how to do this.
  • While one user has a file locked in an exclusive transaction, another user attempts to lock all or part of that file.
  • When opened by a MicroKernel, a file is in transition into Continuous Operation mode. Retrying eventually works.
  • When opened by a MicroKernel, two data files have the same filename but different extensions (for example, INVOICE.HDR and INVOICE.DET). One file is open and in Continuous Operation mode, causing the MicroKernel to generate a delta file (for example, INVOICE.^^^). The MicroKernel returns this status code when you attempt to open the second file. For this reason, we recommend naming your files with completely different names, not just reusing the same name with different extensions.
  • When opened by a Windows NT server MicroKernel using Microsoft File and Print Services for NetWare on behalf of a Win16 Windows client, the file was also opened simultaneously by a Win32 Windows NT or Windows 9x machine. This causes the server MicroKernel to open the same physical file using two different paths.
  • Without any pattern of occurrence, you may receive a status 85 when the file is closed because Anti-Virus software opens and locks the file to scan causing the next database operation to fail. To resolve, set the Anti-Virus software to not scan Pervasive SQL data files. Consult your Anti-Virus software manual for instructions on how to exclude files.

86: The file table is full

This status code is obsolete in the current version of Pervasive.SQL. The engine now dynamically manages the number of files that the MicroKernel can open.

87: The handle table is full

This status code is obsolete in Pervasive.SQL 2000i and later versions. The handle table is managed dynamically by the engine.

You have either attempted to open more handles than the MicroKernel is configured to support, or the MicroKernel attempted to open more files than the operating system allows.

  • To configure your operating system to allow more handles, refer to your operating system documentation.

It is helpful to know the following details regarding the MicroKernel requirements for handles from the operating system. When the same file is opened multiple times, the MicroKernel uses only one operating system handle. However, if the file is in v6.x or later format and the file is shared via MEFS mode, the MicroKernel opens a second handle for the associated .LCK file.

If the file is in v5.x format, the MicroKernel might request a second handle, for the .PRE file. Also, if the file (in any format) is placed in Continuous Operation mode, the MicroKernel requests another handle for the delta file. If the file is extended, the MicroKernel requests an operating system handle for each of the extension files.

  • In the Btrieve v6.15 DOS or Microsoft Windows NT 4.0 environments, you may received this status code when opening the 16th file in a DOS application running under Windows NT. There may two solutions:
    • Btrieve File handle configuration may be set incorrectly in BTI.CFG. Check BTI.CFG for file handle setting (/h: and /f:) and increase those values.
    • Check the file= setting in CONFIG.NT. This file is in the WINNT\SYSTEM32 directory and raise the values.

NOTE: default value is 20.

88: The application encountered an incompatible mode error

The MicroKernel returns this status code in one of the following situations:

  • If an application opens a file in Exclusive mode, all other applications receive this status code when they try to open the same file in any mode.
  • If an application opens a file in any mode other than Exclusive, all other applications receive this status code when they try to open the same file in Exclusive mode.
  • While using the MicroKernel Continuous Operation mode:
    • You attempted to remove a file from continuous operation, but the file is not in continuous operation mode.
    • You attempted to remove a file from continuous operation, but a different client placed the file into continuous operation.
    • You attempted to include two files in continuous operation that have the same name but different extensions.
    • You attempted to include a file in continuous operation, but the file is already in continuous operation.
    • The files were previously in continuous operation and the server crashed. Now, when you attempt to take the files out of continuous operation, a Status Code 88 is returned.

In the last case described above, once the server has gone down, the Btrieve engine does not know which files were in continuous operation. Status Code 88 is returned because of this condition.

In order for you to take the files out of continuous operation, you must open the files before trying to end continuous operation mode. When the file is reopened, the Btrieve engine detects that the continuous ops flag is set and looks for the delta file. At that point, the delta file roll-in occurs.

To initiate the roll-in of an existing delta file, the associated data file must be opened. You can open the file with a utility such as the function executor or the application that uses the file. If the application that uses the file repeatedly opens and closes the file, you are advised to open the file with the function executor. This recommendation is made because the delta roll-in is a low priority task. The roll-in was designed in this fashion so that the file can still be used while the roll-in is occurring. If the application closes the file and the roll-in has not finished, the roll-in is initiated again when the file is re-opened. As a low priority task, the roll-in process may take some time. Once the engine completes the roll-in, it deletes the delta file.

89: A name error occurred

This status code is obsolete in MicroKernel versions 5.0 and later.

BSERVER was loaded before you specified the short name to which the device was redirected. You must specify all short names that you want to share with the NET SHARE command before you start BSERVER.

90: The redirected device table is full

This status code is obsolete in MicroKernel versions 6.0 and later.

The DOS Requester redirection table or server routing table is full. This occurs if you attach to additional servers or map additional drives after loading the Requester. Reload the Requester, specifying a larger value for either the Number of File Servers (/S) option or the Number of Mapped Drives (/R) option. This status code also occurs if you detach from a server and attach to a different server. Once a client has attached to a server, the Requester does not remove its name from the server routing table.

For a list of all available BRequest commands, type /? at the command line.

91: The application encountered a server error

Note
Please see our Pervasive.SQL Knowledge Base for new and updated articles on troubleshooting this status code. You can access the Knowledge Base at: http://support.pervasive.com/eSupport/.

The MicroKernel returns this status code in one of the following situations:

  • The Requester cannot establish a session with the server. Either the client/server MicroKernel is not loaded or the server is not active.
  • The SPX drivers are not installed or are outdated.
  • The MicroKernel has reached the maximum limit for the number of sessions it can open at one time. To avoid receiving this status code, increase the value for the Number of Sessions configuration option. Beginning with Pervasive.SQL 8, the MicroKernel dynamically manages the number of sessions, and it cannot be manually increased or decreased.
  • An application specified a path for a file and did not include the volume name in the path.
  • The MicroKernel Router has not been loaded, and the following situation has occurred: an application that uses both the MicroKernel Router and the MicroKernel to make remote calls (and which therefore includes the server and volume name when performing an Open operation) has attempted to open a remote file. Because the MicroKernel Router does not interpret the server name, the MicroKernel attempts to do so but cannot.
  • A communication or network addressing problem exists in your network environment, so the MicroKernel requests never reach their destination server address. Ensure that your client and server network components are up to date and certified for your network environment.
  • There is a conflict using the DOS BREQNT requester with the SPX protocol. To resolve this error:
    1. Change directories to \pvsw\clients\dos\windosbox and run the setup utility. This loads the appropriate file for clients running Windows 9x or Windows NT. The setup program creates and places a README.TXT file in the \pvsw\W32DOXBOX directory.
    2. After installation, reboot the client.
    3. For Windows NT users: open a command prompt and run a DOS Btrieve application.
    4. For Windows 9x users:
  • Run the BTRBOX95.exe. A minimized dialog box appears, indicating that BTRBOX95 support is active. If you close this dialog box, it will unload BTRBOX95. You only need to run BTRBOX95.exe once even though you have multiple DOS sessions open.
  • Open a command prompt and run your DOS Btrieve application.
  • For NetWare servers only:
    • The Maximum Packet Receive Size configuration option is inappropriate for your environment. For example, the setting should be 1500 for an Ethernet LAN or 4096 for a Token-Ring LAN.

To adjust the Maximum Packet Receive Size:

  1. Open the sys:system/BTI.CFG file.
  2. Locate the Btreive Communications Manager option.
  3. Ensure that the Maximum Packet Receive Size value is appropriate for your environment.

NetWare users may also receive this status code in the following situations:

    • The user count limit has been exceeded. Either close a session or upgrade your user count. For more information about purchasing and installing additive user counts, refer to Pervasive.SQL User's Guide.
    • Ensure that the NDS network number is the same as the Internal Network Number viewed by BINDER.EXE output.
    • You ran BUTIL.NLM to roll forward a file using a log filename other than the default, and your BLOG.CFG file did not contain a correct entry such as "\dir\file.ext=vol:\dir\log.ext".

92: The transaction table is full

This status code is obsolete in MicroKernel versions 7.0 and later.

The application exceeded the maximum number of active transactions. Use the configuration utility to specify a higher value for the Number of Transactions configuration option.

93: The record lock types are incompatible

The application tried to mix single-record locks (+100/+200) and multiple-record locks (+300/+400) in the same file at the same time. You must release all locks of one type before you can execute a lock of the other type.

94: The application encountered a permission error

The MicroKernel returns this status code in the following situations:

  • The application tried to open or create a file in a directory without the proper privileges. The MicroKernel does not override the network privileges assigned to users.
  • The designated server is in the server routing table, but your particular client is not logged into that server.
  • The system data source name (DSN) on the server has an error in the pathname to the data files.
  • A NetWare application tried to access a file using NetWare Runtime support with the given username. Specifically, one of the following situations exists regarding the supplied username:
    • The user is not a valid user on the NetWare Runtime server.
    • The user does not have the appropriate rights to access the file.
    • The username is ADMIN or SUPERVISOR. For security reasons, the MicroKernel does not enable you to use ADMIN or SUPERVISOR as a username when enabling NetWare Runtime support.
    • User is logged in to NetWare server with grace login (i.e., password has expired and a set number of grace logins are left). Change the user's password to a valid password (no grace login) and reconnect to the server with the valid password.
  • When using the Win32 Requester from a Windows NT/9x client machine to a NetWare server, you must use the same username for logging in to both the client machine and the NetWare server. You cannot be logged in to NetWare as SUPERVISOR or ADMINISTRATOR.
  • When using the Win32 Requester from a Windows NT/9x client machine using NetWare emulation to a Windows NT server, the server cannot use Microsoft File and Print Services for NetWare. This causes the requester to attempt authentication as though the server were a NetWare Runtime server.
  • It is recommended that you keep the default client configuration setting Access 4 Use Remote MicroKernel Engine = Yes on FPNW servers running Pervasive.SQL. You may receive a Status Code 94 if you change this setting to No when you are running the Btrieve Interface locally on the FPNW server and are using a local FPNW drive mapping or local FPNW UNC path.
  • You may also receive this status if you have Client for NetWare Networks installed on a Windows only network where no NetWare servers present. Remove the Client for NetWare Networks from the Windows 95 workstation.

95: The session is no longer valid

Note
Please see our Pervasive.SQL Knowledge Base for new and updated articles on troubleshooting this status code. You can access the Knowledge Base at: http://support.pervasive.com/eSupport/.

The server MicroKernel returns this status code for one of the following reasons:

  • The previously established session is no longer active due to an error at the client machine, at the server, or on the network. Verify that the client machine is still attached to the server, and then unload and reload the Btrieve Requester.

If you are using the SPX protocol:

  • The server MicroKernel has reached the maximum number of SPX sessions. Use the Monitor utility to check this statistic. To avoid receiving this status code, add more memory. The number of sessions is managed dynamically up to available memory.
  • This may be a time delay problem if the client machine does not receive a response back from the server in an appropriate time frame or after an appropriate number of retries. Refer to your network configuration documentation for information about increasing timeout and retry parameters. This is often necessary in a WAN environment or a LAN configuration with heavy network traffic.
  • For NetWare servers:
    • Verify that the Maximum Packet Receive Size configuration option is appropriate for your environment. For example, the setting should be 1500 for an Ethernet LAN.

To adjust the Maximum Packet Receive Size:

  1. Open the sys:system/BTI.CFG file.
  2. Locate the Btreive Communications Manager option.
  3. Ensure that the Maximum Packet Receive Size value is appropriate for your environment.
    • Ensure that the SPX timeout parameters are set as follows in both the client machine NET.CFG file and the server SPXCONFG.NLM file:
      SPX VERIFY TIMEOUT=54
SPX LISTEN TIMEOUT=108
SPX ABORT TIMEOUT=540

        These three values must have a 1:2:10 ratio. You can increase these values to at most three times the default. If you continue to receive this status code after increasing these values, the problem is most likely not related to these settings.
  4. For Windows NT servers, verify that the Maximum Packet Size registry setting is 576 decimal or 240h:
  5. The path to the MaxPktSize registry setting is:
    HKEY_LOCAL_MACHINE\System\currentControlSet\
    Services\NwInkIPX\NetConfig\MaxPktSize.

    If you continue to receive this status code after increasing the network timeout parameters, this status code usually indicates a problem with network communications. Verify that you have up to date network cards and drivers; for example, incompatible LAN card drivers can also cause this status code to occur. Consult your LAN administrator for network communication troubleshooting.

  6. After installing Windows NT Service Pack 3 or 4, SPX requesters may fail and return this status code (95), Status 97, or Status 91. Refer to the Microsoft Knowledgebase article 170517 for more information regarding this cause.
  7. Choose Start 4 Run.
  8. Type Regedit and click OK. The Registry Editor opens.
  9. Make the following CHANGES to the server's registry using Regedit:

    HKEY_Local_Machine4System4CurrentControlSet4Services4NwLnkIpx4<Network Card>4MaxPktSize = 240 Hex.

    HKEY_Local_Machine4System4CurrentControlSet |
    Services4NwLnkIpx4<Network Card>4NetworkNumber = <Non-Zero Value>

  10. ADD the following registry entry:

    HKEY_Local_Machine4System4CurrentControlSet |
    Services4LanManServer4Parameters4MinClientBufferSize regdword = 500 decimal.

96: A communications environment error occurred

The MicroKernel returns this status code for the following reasons:

  • You tried to attach to the MicroKernel on a server, but the SPX connection table or the MicroKernel client table is full. To avoid receiving this error, add more memory. Both of these resources are managed dynamically up to available memory.
  • An application that calls the MicroKernel can return this status code if the DBNAMES.CFG file contains a named database definition specifying a data location on a different server.
  • You may also receive this status code in an environment with multiple servers with Btrieve running on them. When doing a Begin Transaction using BREQUEST 6.15, the requester checks its list of all known attached Btrieve file servers. Then it attempts to create an SPX session so that it can check the server to see if it is configured for transactions. This implies that all the servers have to be configured for at least the same number of remote sessions as well as being configured for the same number of transactions.

97: The data buffer is too small

The application either tried to read or write a record that is longer than the current allowed settings for the MicroKernel or the Btrieve Requester, as follows:

  • For an Update, Insert, or Create operation, the application receives this status code if the data buffer length it specifies for the record exceeds the message buffer length.
  • For a Get, Step, or Stat operation, the application receives this status code if the message buffer is shorter than the length of the data the MicroKernel would return, regardless of the data buffer length specified in the application.
  • For a Get Chunk or Update Chunk operation, the total size of the retrieved or updated chunk exceeds the message buffer length.

To increase the Communication Buffer Size:

  1. Click Start 4 Programs 4 Pervasive.SQL V8 4 Control Center.
  2. Expand Pervasive.SQL V8 Engines and expand the desired database.
  3. Expand Configuration, then expand Server, and click on Communication Buffer Size.
  4. In the right hand frame, double-click on Communication Buffer Size.
  5. Increase Current. (Note: The maximum value is 65153KB.)
  6. Exit the configuration utility and restart the engines for the new settings to take effect.
  7. DOS Requesters only: Reload the Btrieve Requester and specify a higher value for the message buffer size. This is done using the
    /D parameter which is documented in Getting Started with Pervasive.SQL.
  8. For Windows NT servers, verify that the Maximum Packet Size registry setting is 576 decimal or 240h. The path to the MaxPktSize registry setting is HKEY_LOCAL_MACHINE\System\currentControlSet\
    Services\NwInkIPX\NetConfig\MaxPktSize.

For more information about configuring the message buffer size, refer to Advanced Operations Guide.

98: The MicroKernel detected an internal transaction error

For MicroKernel v6.0 and earlier: a NetWare-based MicroKernel detected an error while executing the operation on a NetWare Transaction Tracking System (TTS) file. The application can perform only an Abort Transaction operation at this point.

99: The Btrieve Requester is unable to access the NetWare Runtime server

This status codes is returned in the following situations:

  • You enabled NetWare Runtime server support and the Requester either detected no existing connection or could not find a valid login username. SUPERVISOR and ADMIN are not valid usernames, even if supplied with the correct password. If the Requester cannot find a login username other than SUPERVISOR or ADMIN, there is no valid name to pass.
  • You tried to access a server with the NetWare Runtime server support option disabled and you do not have an existing connection to that server.
  • When accessing Windows NT 4.0 Server from a client machine, you may receive this status code if the user moved from a NetWare server to a Windows NT Server. To resolve, remove the "SatEntry" (referencing the NetWare Server) in BTI.ini (for 16-bit applications) and/or the Registry (for 32-bit applications) under Communications Requester.

NOTE: The "SatEntry" is a line that resembles "SatEntry1=xxxxxxx-01,2,3"

100: No cache buffers are available

This indicates that the MicroKernel has used all the cache buffers it allocated at load time.

You may encounter this Status Code if your application uses a large number of write operations (insert, update, and delete) in a user transaction. The current implementation of the MKDE requires all modified pages to reside in cache until the transaction completes.

NOTE: On a machine with limited available memory, you may not be able to successfully complete very large transactions with thousands of write operations.

If you are a developer, you can modify your application to commit transactions more frequently, so that fewer modified pages remain in cache. The more common approach to this problem is to increase Cache Allocation in the configuration options and then reload the MicroKernel.

Starting with Pervasive.SQL 8, Cache Allocation can be managed dynamically by the MicroKernel. If this is your case and you are still receiving Status Code 100, you must add more memory.

To increase Cache Allocation:

  1. Click Start 4 Programs 4 Pervasive.SQL V8 4 Control Center.
  2. Expand Pervasive.SQL V8 Engines and expand the desired database.
  3. Expand Configuration, then expand Server, and click on Performance Tuning.
  4. In the right hand frame, double-click on Cache Allocation Size.
  5. Increase Current by entering bytes of memory to allocate cache. Note: The default is dynamic.
  6. Exit the configuration utility and restart the engines for the new settings to take effect.

101: Insufficient operating system memory is available

This indicates that there is not enough operating system memory available to perform the requested operation. To fix this problem, perform one or more of the following:

  • Go to Performance tuning in the server configuration and decrease the value for the Cache Allocation configuration option.
  • Add memory to the server.

102: Insufficient stack space is available

This indicates that the MicroKernel has run out of stack space. To increase the amount of stack space available to your application, re-link the application, setting the stack size to a higher value. The MicroKernel returns this status code only to Windows-based applications that call WBTRCALL.DLL, or applications that call the Btrieve interface on the local server.

103: The chunk offset is too big

The MicroKernel returns this status code in one of the following situations:

  • A Get Direct/Chunk operation specified an offset beyond the end of the record, either explicitly or using the next-in-record bias to the subfunction value. Unless the MicroKernel returns this status code while processing the first chunk, the operation was partially successful. Check the data buffer length parameter immediately after the call to see how much data was retrieved (and therefore how many chunks).
  • An Update Chunk operation specified an offset that is more than one byte beyond the end of the record. This status code indicates that the MicroKernel has made no changes to the record.
  • An Update Chunk operation with an Append subfunction causes a record length to exceed its operating system file size limit. The MicroKernel has made no changes to the record.

104: The MicroKernel does not recognize the locale

During a Create or Create Index operation, the operating system was not able to return a collation table for the country ID and code page specified. Ensure that the application specified the locale's country ID and code page correctly and that the operating system is configured to support the country ID and code page.

105: The file cannot be created with Variable-tail Allocation Tables (VATs)

An application tried to create a file with Variable-tail Allocation Tables (VATs) but without variable-length records (a precondition for files to use VATs). This status code applies to key-only files as well as to regular data files.

106: The MicroKernel cannot perform a Get Next Chunk operation

An application called the Get Direct/Chunk operation to retrieve a chunk from a record and used the next-in-record bias on the descriptor subfunction. However, after the application established its positioning in the record (and prior to this call), the target record was deleted.

107: The application attempted to perform a chunk operation on a pre-v6.0 file

An application tried to use either a Get Direct/Chunk operation or an Update Chunk operation on a file in pre-v6.0 format.

109: An unknown error was encountered either creating or accessing a semaphore

The Windows NT platform of the workstation MicroKernel attempted an operation using incompatible versions of the DLLs. Shut down the MicroKernel and make sure that you are using the most recent versions of the DLLs.

110: The MicroKernel cannot access the archival logging configuration file

The archival logging configuration file (BLOG.CFG) contains entries for the data files on the drive for which you want to perform archival logging. The MicroKernel returns this status code for the following reasons:

  • The MicroKernel cannot find the BLOG.CFG file. Ensure that the file is in the \BLOG directory in a real root directory of the physical drive that contains data files you want to log. (That is, do not use a mapped root directory.) If your files are on multiple volumes, you must create a \BLOG directory on each volume.
  • The MicroKernel cannot open the BLOG.CFG file. Either the file is locked or it does not exist.
  • The MicroKernel cannot read the BLOG.CFG file. Either the file does not use the correct format or it is corrupt. Refer to Advanced Operations Guide for information about the format of the BLOG.CFG file.

111: The specified filename was not found in the archival logging configuration file

The MicroKernel cannot find the specified file in the BLOG.CFG file. The file must be specified in the BLOG.CFG file on the same physical drive. By default, the MicroKernel names the archival log file the same as the logged file, but with a .LOG extension. However, you can specify a different filename for the archival log file in the BLOG.CFG file. Ensure that the BLOG.CFG file indicates the correct filename for the archival log and ensure that the archival log file exists.

112: The specified file is in use by another client

Before the MicroKernel can perform a roll forward, the file must be in the same state it was in when it was last backed up. If another client changes the file, you must restore the file again before rolling forward.

113: The MicroKernel cannot find the archival log for the specified file

The MicroKernel cannot find the archival log file associated with the specified file. By default, the MicroKernel names the archival log file the same as the logged file, but with a .LOG extension. However, you can specify a different filename for the archival log file in the BLOG.CFG file. Ensure that the BLOG.CFG file indicates the correct filename for the archival log and ensure that the archival log file exists.

114: The archival log for the specified file is invalid

The archival log associated with the specified file is not a valid archival log file. By default, the MicroKernel names the archival log file the same as the logged file, but with a .LOG extension. However, you can specify a different filename for the archival log file in the BLOG.CFG file. Ensure that the BLOG.CFG file indicates the correct filename for the archival log and ensure that the archival log file exists.

115: The MicroKernel cannot access the archival logging dump file

The MicroKernel cannot access the archival logging dump file for one of the following reasons:

  • The filename indicated for dumping entries in an archival log is not a valid filename. Be sure this filename does not contain a volume specification. The dump file is created on the same volume as the log file.
  • The caller does not have access rights to the dump file.
  • The MicroKernel cannot open the file because another user has opened the file using an exclusive operating system lock.

116: The file is owned by another Microkernel engine acting as a Gateway

The MicroKernel cannot contact the engine running on the gateway computer even though it can read the locator file. This might occur the following reasons:

  • The name of the gateway computer cannot be resolved. To solve this problem, try one of the following:
    • Ensure that the gateway computer is registered with your name resolution service, such as DNS.
    • If you are not using a name resolution service, you must provide name resolution manually. Locate the file named HOSTS on your current machine. Add a line in this file associating the TCP/IP address of the gateway computer with the network name of that computer. For example, if the gateway computer is named "mycomp" and its IP address is 125.1.4.245, then you should add the following line to the file:
      125.1.4.245 mycomp
  • When the two computers are separated by a router so they can both see the server, but cannot see one another. Try the following:
    1. Use the Gateway Locator utility to identify the owner of the gateway.
    2. Use Pervasive System Analyser (PSA) to test the network connection to that computer.
  • You may have attempted to open a file with two different Workgroup engines that are mapped to the files using different share names. The MicroKernel attempts to correct this, but cannot do so in all cases. Make sure each computer is mapping to the same share name.

130: The MicroKernel ran out of system locks

This status code is obsolete in MicroKernel versions 6.15 and later.

This status code can indicate a temporary condition in which no system locks are currently available. The following are example cases:

  • A single client is performing a very large transaction, in which thousands of records are being modified.
  • Many clients are performing large transactions concurrently.

A client can receive this status code whether or not it is in a transaction. In some cases, a client can simply retry the failed operation. If other clients have released system locks in the interim, the retried operation may succeed. If a client in a transaction receives this status code, end or abort the transaction. If the transaction is very large, consider breaking it into multiple, smaller transactions. You can also use the Setup utility to lower the number of system locks devoted to explicit locking. To do so, lower the values assigned to the Number of Locks and/or Number of Sessions configuration options.

132: The file has reached its size limit

The MicroKernel returns this status code in one of the following situations:

  • The file size reached its maximum limit, 64 GB for 4,096 byte page size, 32 GB for 2,048 byte page size, or 8 GB for 512 byte page size.
  • An operation attempted to allocate more than 16,777,216 pages to a data file.
  • A data file has remained in continuous operation for a lengthy period of time, causing its delta file to exceed the operating system limit.
  • A pre-v6.15 data file has reached the operating system file size limit.

If the file uses a file size smaller than 4,096 bytes, you can rebuild the file using Rebuild utility and set the page size to 4,096 bytes, to take advantage of the larger file size limit.

133: More than 5 concurrent users attempted to access the same data file

This status code is obsolete for all versions of Pervasive.SQL 7 and later. In the Pervasive.SQL 2000i SDK for a workstation environment, you attempted to access a data file with more than five MicroKernels at the same time. The Pervasive.SQL 2000i SDK for a Workgroup environment limits the number of concurrent users of a file to five engines.

134: The MicroKernel cannot read the International Sorting Rule

The MicroKernel returns this status code for the following reasons:

  • The ISR is not found in the COLLATE.CFG file.
  • The COLLATE.CFG file is missing or corrupt.
  • The MicroKernel cannot read the ISR from the COLLATE.CFG file.

135: The specified ISR table is corrupt or otherwise invalid

The MicroKernel found a readable COLLATE.CFG file, but the specific International Sorting Rule table is invalid.

136: The MicroKernel cannot find the specified Alternate Collating Sequence in the file

The MicroKernel returns this status code in the following situations:

  • You tried to create an index that uses an Alternate Collating Sequence (ACS), but the MicroKernel cannot locate an ACS with the specified name in the file.
  • You called a Step Next Extended, Get Next Extended, Step Previous Extended, or Get Previous Extended operation and specified an ACS name, but the MicroKernel cannot locate an ACS with the specified name in the file.

138: The NULL indicator position is invalid

  • In order to ensure accessibility to your data from all of the Pervasive.SQL access methods, the NULL indicator segment (NIS) must appear immediately before the data segment that the NIS indicates.
  • A NIS cannot be indicated by another NIS.

139: The MicroKernel has detected an unacceptable value in the key number

Certain operations either use, or reserve the use of, the key number parameter as a subfunction number, rather than as a means to specify a file index to be used with the operation. (Note: This is also done in the GetEqual operation). This status code is returned if an application does not specify a valid subfunction number (via the key number parameter) to one of these operations:

  • You issued a Begin Transaction operation with an invalid key number.
  • You issued an End Transaction operation with an invalid key number.
  • You issued an Abort Transaction operation with an invalid key number.
  • You issued a Start Extended operation with an invalid key number.

143: The MicroKernel cannot allow unauthorized access to files in a secure MicroKernel database

  • You attempted to open a data file bound to a MicroKernel database that has security enabled. The MicroKernel does not allow access to such files, except through the MicroKernel.
  • The MicroKernel also returns this status code if you are not using the MicroKernel and all of the following are true:
    • You attempt to create a file with the Replace option.
    • A bound MicroKernel data file with the same name and location already exists.
    • The database to which the existing file is bound has security enabled.

146: Duplicate system key

The same key number was generated by two different threads generating system keys.

147: The log segment is missing

The MicroKernel cannot find a log segment that is necessary for rolling at least one file forward.

148: A roll forward error occurred

The MicroKernel encountered an error while rolling a file forward. Depending on the operating system, the MicroKernel reports an error message as follows:

  • The NetWare MicroKernel displays the message on the server system console and writes the message to the Pervasive Event Log (PVSW.LOG), which resides in SYS:\SYSTEM.
  • The Windows 95 and Windows NT workstation MicroKernel displays the message in the console message window and writes the message to the Pervasive Event Log (PVSW.LOG), which is located in the WINDOWS\SYSTEM or WINNT\SYSTEM32 directory.
  • The Windows NT server MicroKernel does not display a message, but writes the message to the Pervasive Event Log (PVSW.LOG) in the WINNT\SYSTEM32 directory.

149: SQL Trigger

While using the Btrieve API to alter database tables or entries, the system encountered SQL restrictions placed on the database by the SQL layer.

160: Invalid parameters passed to MicroKernel

The MicroKernel detected a corrupt parameter used by the SRB (Service Reply Block) due to one of the following:

  • Network glitch occurring in the process of transporting the SRB across the network, somehow damaging the parameters in the SRB.
  • The most likely cause for this error is a mismatch between legacy Scalable SQL components on your system and Pervasive.SQL components.

To resolve this problem, reinstall Pervasive.SQL to restore consistency among the installed components. If you still encounter the problem after reinstalling and rebooting, contact Technical Support.

161: The maximum number of user count licenses has been reached

You attempted to open another session when you were at the limit of your user count license. Either close a session or upgrade your user count.

This status code is also returned after a trial or temporary license has expired. If all users receive this error and no one is able to access the database engine, then most likely you have been using a temporary license key and you must now apply a regular license key. Please contact your reseller or Pervasive Software to purchase a regular license.

For more information about purchasing and installing additive user counts, refer to Getting Started with Pervasive.SQL. You can use Monitor to determine which users currently have connections to Pervasive.SQL. For information about Monitor, refer to Advanced Operations Guide.

162: The client table is full.

This status code is obsolete in Pervasive.SQL 2000i and later versions. The related configuration setting is managed dynamically by the engine.

You may receive this status code due to one of the following:

  • You have run out of memory.
  • Your number of Active Clients has exceeded 64K.

163: The NULL indicator cannot be the last segment

The NULL indicator segment (NIS) cannot be the last segment of the key descriptor.

169: Protocol mismatch between client cache and remote engine

This status code indicates that your client software is not up-to-date with your remote database engine. You should only receive this status code if you are running V8 pre-release client software against a V8 general-release remote engine.

The solution for this issue is to uninstall your client software and install the latest V8 client.

170: Database login required

Authentication to the database failed due to a wrong or missing username.

171: Database login failed

Authentication to the database failed due to a wrong or missing password.

172: Database name not found

Specify a valid database name for the machine.

173: Already logged in

A Btrieve login request failed because the client is already logged into the specified database.

174: Logout failed

A logout can fail if you are not logged in to a database or there are remaining open file handles to the database when the logout is attempted.

175: Wrong database URI format

The URI connection string was formatted incorrectly. The first five bytes should be "btrv:".

176: File and table name not specified in URI

An Open or Create was issued using a URI connection string that contained neither a file name nor a table name.

177: Table not in database

An Open was issued using a URI connection string that contained no file name, and a table name that does not exist in FILE.DDF.

178: Directory not in database

An Open was issued using a URI connection string that contained a full path file name that references a directory that does not exist as one of the data directories for the database.

Add the directory to the database using the Maintain Named Databases dialog in the Pervasive Control Center (Windows) or the dbmaint utility (Linux).

Prev
0 		Up
Check for Revisions 		Next
1000 to 1999


1000 to 1999

MicroKernel Status Codes for Windows and DOS Workstations

The workstation MicroKernel engine returns the following status codes in Windows and DOS environments.

1001: The lock parameter is out of range

This status code is obsolete in MicroKernel versions 7.0 and later.

Version 6.x MicroKernels return this status code when the value specified for the Number of Locks configuration option is out of range. Pre-v6.0 MicroKernels return this status code when the value specified for the Multiple Locks configuration option is out of range.

1002: A memory allocation error occurred

Make sure that the workstation has enough memory to load all the programs it requires. For workstation versions of the MicroKernel, or client requesters, the insufficient memory may apply to conventional memory, expanded memory, or both.

1003: An invalid memory size parameter was specified

This status code is received when the value for Cache Allocation Size is invalid.

To adjust Cache Allocation Size:

  1. Click Start 4 Programs 4 Pervasive.SQL V8 4 Control Center.
  2. Expand Pervasive.SQL V8 Engines and expand the desired database.
  3. Expand Configuration, then expand Server, and click on Performance Tuning.
  4. In the right hand frame, double-click on Cache Allocation Size.
  5. Enter a valid byte size in Current. (Note: Cache size should not be larger than the sum of the sizes of the files you are using.)
  6. Exit Configuration and restart the engines for the new settings to take effect.

See Advanced Operations Guide for more information.

1006: The pre-image buffer parameter is out of range

In Pervasive.SQL 2000i and later versions, the setting Extended Operation Buffer Size is obsolete. This resource is managed dynamically by the MicroKernel.

The Extended Operation Buffer Size configuration option must be between 0 and 64,000, inclusive.

To adjust Extended Operation Buffer Size:

  1. Click Start 4 Programs 4 Pervasive.SQL V8 4 Control Center.
  2. Expand Pervasive.SQL V8 Engines and expand the desired database.
  3. Expand Configuration, then expand Server, and click on Memory Usage.
  4. In the right hand frame, double-click on Extended Operation Buffer Size.
  5. Enter a value for Current that falls within the named range.
  6. Exit the configuration utility and restart the engines for the new settings to take effect.

The Pre-Image Buffer Size configuration option must be between 1 and 64, inclusive. The pre-image file is used in pre-v6.0 files and by v6.0 and later MicroKernels that are loaded with the Create Files in Pre-v6.x Format configuration option set to Yes. No longer valid in MicroKernel v7.8 or later.

1007: The files parameter is out of range

In Pervasive.SQL 7 and later versions, the Open Files configuration setting is obsolete. This resource is managed dynamically by the MicroKernel.

For pre-v6.0 engines, the Open Files configuration option must be between 1 and 250, inclusive. For v6.0 and later engines, refer to the appropriate version documentation for valid range information.

1008: The initialization parameter is invalid

The specified configuration options contain invalid or unidentifiable values.

1009: The transaction filename parameter is invalid

This status code is obsolete in MicroKernel versions 7.0 and later.

The filename specified for the Transaction filename configuration option is not valid. Ensure that the transaction filename is correct.

1010: An error occurred during the access of the transaction control file

This status code is obsolete in MicroKernel versions 7.0 and later.

The MicroKernel is unable to create, open, read, or write to BTRIEVE.TRN or MicroKernel.TRN. Set the TRNFILE setting in the BTI.INI file to C:\.

1011: The compression buffer parameter is out of range

This status code is obsolete in MicroKernel versions 7.0 and later.

Ensure that Compression Buffer Size option is set to a valid range. Check the target server configuration settings. Refer to Advanced Operations Guide for valid range information.

1012: Invalid /n: option

This status code is obsolete in MicroKernel versions 6.0 and later.

The Maximum Number Of Files In A Transaction configuration option is invalid. Valid values are 0 to 18; the default is 12.

1013: The task list is full

This status code is obsolete in MicroKernel versions 7.0 and later.

In the Windows environment, this status code is returned if the task entry table is full. You can change the value for the Number of Tasks option using the Setup utility.

In the DOS environment, this status code is returned if the BREQUEST or BREQNT requesters are used without the /t parameter when BTRVID calls are present in the application. Reload the requester with a non-zero value for the /t parameter. For more information on the DOS Requester parameters, refer to Getting Started with Pervasive.SQL.

1015: One of the pointer parameters passed to the MicroKernel is invalid

One of the pointer parameters passed into the MicroKernel is invalid. The MicroKernel checks for invalid pointers only if you put the following line under the [BTRIEVE] heading in your initialization file: CHKPARMS=YES. Otherwise, the MicroKernel performs no pointer checking and you will not receive this status code.

1016: The MicroKernel is already initialized

This status code is obsolete in MicroKernel versions 6.0 and later.

You attempted to initialize the MicroKernel when it was already initialized. To reinitialize the MicroKernel, close all files, end/abort all transactions, and issue Btrieve operation 25, using the BTRV interface before calling the initialization function.

1017: The Btrieve Requester is unable to find the resource file WBTRVRES.DLL

WBTRCALL.DLL returns this status code when it cannot find the resource file WBTRVRES.DLL. Place the WBTRVRES.DLL file in the same directory as the WBTRCALL.DLL file.

1018: The application attempted to call the MicroKernel from a Btrieve callback function

The Windows MicroKernel does not allow a task to call the MicroKernel from a Btrieve callback function. You can only use the callback function with Btrieve for Windows.

1019: The MicroKernel cancelled the current Btrieve operation at the request of the application's Btrieve callback function

The MicroKernel callback function of an application returned a nonzero value, indicating that the application wants to terminate the current operation immediately. When the MicroKernel receives such a cancellation request, it attempts to terminate the currently executing operation and ceases to call the callback function for the duration of that operation. The MicroKernel may be unable to cancel the operation. However, if successful in doing so, the MicroKernel returns this status code.

1020: Btrieve Requester Interface communications error

The MicroKernel loader and requester Interface returns this status code when it cannot send a message to the MicroKernel. This occurs when Windows is shutting down or when you terminate the MicroKernel using Ctrl+Alt+Delete. This is an informational status code only. No action is required. Your application continues the shutdown process. You also receive this status code when running an application that prevents Windows from processing messages.

1021: The MicroKernel failed to initialize

  • The MicroKernel could not complete its initialization tasks. Check the MicroKernel console or error log for a message that specifies the problem that prevented the MicroKernel from initializing.
  • The NetWare MicroKernel displays the message on the server system console, and it also writes the message to the Pervasive Event Log (PVSW.LOG), which is located at SYS:SYSTEM.
  • The Win32 workstation MicroKernel displays the message in the console message window and writes the message to the Pervasive Event Log (PVSW.LOG), which is located in the C:\WINDOWS directory.
  • The Windows NT server MicroKernel does not display a message, but writes the message in the Pervasive Event Log (PVSW.LOG), which is located in the C:\WINNT directory.

Correct any problems stated in the console message or error log, then retry the operation. If you are using a NetWare MicroKernel, after you have corrected the problem, you must unload and reload the MicroKernel before you can retry the operation.

On NetWare, use the following solution to address the problem:

  1. Verify that SYS:SYSTEM\MKDE\LOG and PVSW.LOG exist.
  2. Check PVSW.LOG4Messages for module loading errors.
  3. Stop and restart Btrieve and SQL Modules as necessary (Sqlstop, Bstop and then Bstart, Sqlstart on NetWare). Check the added entries generated by starting and stopping the engines to determine any existing error conditions.

Alternatively, manually load the modules in BSTART.NCF and SQLSTART.NCF line by line and observe for loading errors logged in PVSW.LOG.

1022: The MicroKernel is shutting down

The operation cannot be completed because the MicroKernel is shutting down. To correct this problem, allow the engine to completely shut down, and then restart.

Prev
1 to 199 		Up
Check for Revisions 		Next
2000 to 2099


2000 to 2099

Btrieve Requester Status Codes

This section lists the status codes that the Btrieve Requesters generate.

2000: Internal error

The Btrieve requester encountered an internal error. Check the Pervasive Event Log (PVSW.LOG) for more information.

2001: The memory allocation is insufficient

In a DOS environment, reduce the value specified for the /D configuration option.

2003: The Requester does not allow local access to the specified file

The application attempted to access a file stored on a local drive. The configuration of the MicroKernel installed at the client machine does not allow access to local files.

2004: SPX is not installed

Install the NetWare SPX v2.0.

2005: An incorrect version of SPX is installed

Install the NetWare SPX v2.0.

2006: There is no available SPX connection

SPX has already established the maximum number of sessions it can handle. To increase the maximum, edit the NET.CFG file. Refer to your NetWare documentation for more information about NET.CFG.

2007: A pointer parameter is invalid

One of the pointer parameters passed to the MicroKernel is invalid. Check the program to ensure that the pointer parameters are correct.

2008: Router cannot find engine

The MicroKernel Router cannot communicate with the 6.15 engine. This status code is only used with the MicroKernel v4.0.100.

2009: Cannot load MicroKernel Router component

The Btrieve requester cannot load the MicroKernel Router. This can occur if the DLL fails to load or fails to obtain the necessary DLL entry point.

2010: Thunk not possible - the Win32 MicroKernel router could not be found or is incompatible

You receive this status code when the system is configured for thunking and the path is not accessible. This can occur if a necessary system file cannot be found (for example, KERNEL32.DLL). It can also occur if the required system calls (for example, Win32s library) are not available.

2011: Btrieve requester resource DLL not loaded

The resource DLL is either missing or incompatible with the current version of the requester. If this happens, the MicroKernel reverts to its default settings and continues to run.

2012: The Btrieve requester encountered an operating system error

Check the Pervasive Event Log (PVSW.LOG) for more information.

Prev
1000 to 1999 		Up
Check for Revisions 		Next
2200 to 2299


2200 to 2299

XLT Status Codes

This section lists the XLT status codes you can receive.

2200: XLT Winsock Error

This status code is returned when a Windows Socket initialization error occurs.

2201: XLT RPC Error

This status code is returned when the MicroKernel cannot establish a Remote Procedure Call (RPC) to the SQL Relational Database Engine (SRDE).

Prev
2000 to 2099 		Up
Check for Revisions 		Next
2300 to 2399


2300 to 2399

Named Database Status Codes

This section lists the status codes you can receive when using the named database features of the Pervasive.SQL V8 engine.

2300: No more database names are defined

No more database names are defined. If the buffer is large enough to hold multiple database names, you might receive this status code and still have one or more database names returned. The application should check iBufLen to determine the number of names returned.

2301: The database name is invalid

Not a named database. Verify you have entered a valid database name.

2302: Invalid buffer length

The size of the sending buffer is too small and needs to be increased.

2303: The database name must be unique; the specified database name already exists

While creating a database, you specified a database name that already exists in the DBNAMES.CFG file. Specify a different, unique name for the database, or remove the existing database name first.

2304: The database type is invalid

While creating a database, you specified an invalid database type. Specify a database type of either bound or unbound.

2305: The specified path for data dictionary or data file locations is invalid

The path you specified for the bound, named database is invalid or the paths you specified for the data file locations are invalid. Ensure that the entered paths are either UNC paths or local paths (a local path for a NetWare server would be volume:path) and then retry the operation. Paths that contain mapped drive letters are not allowed.

2306: DBNAMES.CFG could not be updated

The path you specified for the bound, named database is invalid or the paths you specified for the data file locations are invalid. Ensure that the specified paths are either UNC or local paths (a local path for a NetWare server would be volume:path) and then retry the operation. Paths that contain mapped drive letters are not allowed.

2307: Cannot open DBNAMES.CFG file

  • If you are trying to access the workstation DBNAMES.CFG file to obtain a list of database names defined for the Workgroup engine, ensure that the DBNAMES.CFG file is in your Windows directory or in the directory specified by the Database Names Directory configuration option. Either the location you have specified in the registry is incorrect or the registry key is corrupt. Use either of the following recovery solutions:
    • Check the location specified in the registry on the local machine under

      HKEY_LOCAL_MACHINE4SOFTWARE4Pervasive Software4Database Names4Version 84Settings4DBNamesDirectory

      NOTE: The DBNames.cfg file should be located in the WINNT directory on Microsoft Windows NT or Windows 2000 or SYS:SYSTEM on a Novell NetWare server.

      OR

    • Check HKEY_LOCAL_MACHINE4SOFTWARE4Pervasive Software4MicroKernel Router4Version 84Settings4Target Engine.

The value should be 0 (for local) or 1 (for server) but in some cases the value is a number like 23785. In this case, status 2307 was returned while trying to create a data source in the ODBC Administrator and specifying a data path to the DDF directory. Deleting the MicroKernel Router key resolved the problem.

2308: The specified RI flag is invalid

While creating a database, you specified a RI flag that is not valid. Specify a database type of either integrity or non-integrity.

2309: The database is in use

You cannot modify the definition of a named database if another user is modifying the definition or if a user is connected to it. You also cannot connect to a named database if someone is modifying its definition.

2312: The bound database cannot share table data files

You cannot bind a data file referenced by a table in a bound, named database to another named database, or to another table in the same named database. For more information about bound databases, refer to Advanced Operations Guide.

2313: The bound database cannot share data dictionary files

The data dictionary files for a bound, named database cannot be referenced by another named database. For more information about bound databases, refer to Advanced Operations Guide.

2314: Cannot create DBNAMES.CFG file

An error occurred while attempting to generate the DBNAMES.CFG. The DBNAMES.CFG is created when the first database on the system is created. If the workstation DBNAMES.CFG file is being generated, ensure that the Windows directory in the Database Names Directory configuration option is a valid directory.

2316: Cannot create DDF files for the bound database

Pervasive.SQL cannot create the database files for the bound database. Ensure that the data dictionary files do not already exist at the specified location. Remove any existing data dictionary files before creating the bound, named database. For more information about bound databases, refer to Advanced Operations Guide.

2324: Data dictionary files are not bound

The data dictionary files for the specified named database are not bound, but should be. This normally indicates a situation in which the data dictionary files have been restored from a backup prior to the database being bound. Make sure that you restore your data dictionary from a backup which is consistent with the bound state of the databases. For more information about bound databases, refer to Advanced Operations Guide.

2325: Data dictionary files are already bound

The data dictionary files for the specified named database are already bound to another database. However, the other named database is not defined to the engine that is trying to bind or unbind the database. Make sure that you only reference the data dictionary files for a bound database from one engine. For more information about bound databases, refer to the Advanced Operations Guide.

2326: Data dictionary files are bound, but do not need to be bound

An unbound, named database was checked. This does not indicate an invalid, or corrupted, named database, but does indicate an inconsistency between the named database definition and the actual state of the database.

This status code often indicates a situation in which the data dictionary files have been restored from a backup that was made when the database was bound. Either restore the data dictionary from a backup that is consistent with the bound state of the database, or bind and then unbind the database. The unbinding of the database removes the binding information from the data dictionary files.

2329: Data file for a table is not bound

The data file for a table in the database is not bound, but should be. This normally indicates a situation in which the data files for the database have been restored from a backup prior to the database being bound. Make sure that you restore your data from a backup that is consistent with the bound state of the database.

2330: Data file for a table is bound, but does not need to be bound

An unbound, named database was checked. This does not indicate an invalid, or corrupted, named database but does indicate an inconsistency between the named database definition and the actual state of the database. This status code often indicates a situation in which the data files for the database was bound. Either restore your data files from a backup that is consistent with the bound state of the database, or bind and then unbind the database.

The unbinding of the database removes the binding information from the data files if the binding information is no longer needed.

2331: Not allowed to change data dictionary location and change name at the same time

These two particular parameters are not allowed to be changed at the same time. Try changing each parameter separately.

2332: Not allowed to bind database and change name at the same time

These two particular parameters are not allowed to be changed at the same time. Try changing each parameter separately.

2333: Not allowed to unbind database and change name at the same time

These two particular parameters are not allowed to be changed at the same time. Try changing each parameter separately.

2334: Not allowed to create a data dictionary files and change name at the same time

These two particular parameters are not allowed to be changed at the same time. Try changing each parameter separately.

2335: Not allowed to change data locations and change name at the same time

These two particular parameters are not allowed to be changed at the same time. Try changing each parameter separately.

2336: Not allowed to change data dictionary location and bind database at the same time

These two particular parameters are not allowed to be changed at the same time. Try changing each parameter separately.

2337: Not allowed to change data dictionary location and unbind database at the same time

These two particular parameters are not allowed to be changed at the same time. Try changing each parameter separately.

2338: Not allowed to change the dictionary location and create dictionary files at the same time

These two particular parameters are not allowed to be changed at the same time. Try changing each parameter separately.

2339: Not allowed to create data dictionary files and bind database at the same time

These two particular parameters are not allowed to be changed at the same time. Try changing each parameter separately.

2340: Not allowed to create data dictionary and unbind database at the same time

These two particular parameters are not allowed to be changed at the same time. Try changing each parameter separately.

2341: Not allowed to bind database and change data locations at the same time

These two particular parameters are not allowed to be changed at the same time. Try changing each parameter separately.

2342: Not allowed to unbind database and change data locations at the same time

These two particular parameters are not allowed to be changed at the same time. Try changing each parameter separately.

2343: Named database general error

Unspecified error.

Prev
2200 to 2299 		Up
Check for Revisions 		Next
3000 to 3099


3000 to 3099

MicroKernel Router Status Codes

This section lists the status codes you can receive from the MicroKernel router, which receives requests from the Btrieve requesters and routes them to the correct version of the MicroKernel.

3000: The MicroKernel router encountered a memory allocation error

The MicroKernel router could not internally allocate memory. Check the Pervasive Event Log (PVSW.LOG) for more information.

3001: Local access is unavailable to the MicroKernel router

A call to the MicroKernel failed. This is most likely the result of an incorrect configuration. For example, if the MicroKernel is unavailable because of configuration settings and the file to be opened is local, then the MicroKernel router returns this status code.

3002: The MicroKernel router resource DLL is unavailable

The MicroKernel resource DLL is either missing or incompatible with the current version of the router. If this happens, the MicroKernel reverts to its default settings and continues to run. Check the Pervasive Event Log (PVSW.LOG) for more information.

3003: The MicroKernel router detected an incompatible network component

The networking services component is not compatible with this version of the MicroKernel router. The most likely cause is that the Networking services DLL has been replaced by an older version. Check the Pervasive Event Log (PVSW.LOG) for more information.

3004: The MicroKernel is not responding to the MicroKernel router

The MicroKernel is not responding to requests from the MicroKernel router. Verify that the MicroKernel is running.

3005: The MicroKernel router encountered an operating system error

The MicroKernel router encountered an unexpected error from the operating system, such as a shared memory failure. Check the Pervasive Event Log (PVSW.LOG) for more information.

3006: The MicroKernel router detected an invalid session

The session information contained in a position block is invalid. This status code occurs for one of the following reasons:

  • The application is trying to use a position block for a file that resides on an engine and for which the connection has been previously terminated via a B_STOP (25) or B_RESET (28) operation.
  • The application is trying to use a position block for a file that resides on a remote server and that encountered an abnormal network error on a previous operation.
  • When using only the NetBIOS protocol with a remote Workgroup engine, the client is sending more bytes than can fit into the engine's network read buffer. Go the machine where the remote Workgroup engine is installed, and try increasing the value of the configuration parameter, Server 4 Communication Buffer Size 4 Read Buffer Size.

3008: Invalid configuration for MicroKernel router

This status code results from an invalid configuration. For example, if both client configuration options, Access 4 Use Local MicroKernel Engine and Access 4 Use Remote MicroKernel Engine are set to Off, the router has no valid path to take. If this situation occurs, set at least one of these options to On, depending on whether you are using a local engine, a remote Server engine, or both.

3009: NETinterface.DLL is not loaded

The MicroKernel router could not find NETAPI.DLL.

3010: NetWare API DLLs are not loaded

The MicroKernel router could not find the NetWare API DLLs.

3011: Thunk not possible – the Win32 MicroKernel router could not be found or is incompatible

This status code is only relevant to the Win16 MicroKernel router. You receive this status code when the Use Thunk option is set to On and the thunk path is not accessible. Possible causes include:

  • The Win32 MicroKernel Router DLL does not exist or is not compatible.
  • The Win32 routines failed to initialize.

Check the Pervasive Event Log (PVSW.LOG) for more information.

3012: Local engine is not accessible to the MicroKernel router

Access to the local engine is not possible because it is not loaded or could not be launched. You can receive this status code if you try to access a local file on a client and you do not have a Workgroup engine installed or if you try to access a local file on a server and the Server engine is not running.

If you have only a server engine installed and your Pervasive Event Log (PVSW.LOG) contains Status Code 3012 warning entries, perform the following steps:

To Turn Off Local Engine support (for clients and workstations only):

  1. Click Start 4 Programs 4 Pervasive.SQL V8 4 Control Center.
  2. Expand Pervasive.SQL V8 Engines and expand the desired database.
  3. Expand Configuration, then expand Client, and click on Access.
  4. In the right hand frame, double-click on Use Local MicroKernel Engine, change the Current value to Off, and click OK.
  5. In the right-hand frame, double-click on Use Remote MicroKernel Engine, change the Current value to On, and click OK.
  6. In the right-hand frame, double-click Target Engine, change Current to Server only, and click OK.
  7. In the left-hand frame, expand Client-16 bit and click on Access.
  8. In the right-hand frame, double-click Use Local MicroKernel Engine, change Current value to Off, and click OK.
  9. Make sure the Use Remote MicroKernel Engine value is set to on and that the remote engine is set to accept remote requests.
  10. Exit the configuration utility and restart the engines for the new settings to take effect.

3013: The remote engine is inaccessible to the MicroKernel router because the networking component is not loaded

Access to the remote engine is not possible because the MicroKernel router could not initialize the networking component. Possible causes include:

  • The client configuration option, Access 4 Use Remote MicroKernel Engine, is incorrectly set to Off. Set it to On to access a remote Server engine.
  • The required networking component could not be found or is not compatible.

3014: The MicroKernel router cannot find an engine

The MicroKernel router could not complete the operation because it did not find an engine (local or remote) that could process the operation. Possible causes include:

  • The target network operating system is not available.
  • The target engine is not available.
  • In a Windows 3.x environment, you are using a shared drive name that contains a space. To resolve the condition, remove the space from the shared drive name. For example, if you connect to a server named "D Drive", change the share name to "D_Drive".

3015: The MicroKernel router encountered an initialization error

An unexpected error occurred during the initialization of the MicroKernel router. Check the Pervasive Event Log (PVSW.LOG) for more information.

3016: The MicroKernel router encountered an internal error

The MicroKernel router encountered an internal error. Check the Pervasive Event Log (PVSW.LOG) for more information.

3017: Data buffer of the local engine is too small

The requester has more data to send the MicroKernel than the MicroKernel buffers can handle. This status code is only relevant to an engine running locally and does not apply to client/server environments. Some possible solutions include:

  • Specify higher values for Communications Buffer Size and MKDE Communication Buffer Size parameters. These can be found using Configuration within Pervasive Control Center. Open the Server folder, then double-click the Communication Buffer Size folder.
  • Use smaller buffers in your operations.

3018: The file is already closed

The MicroKernel router is shut down and is not accepting any more requests.

3019: The MicroKernel router encountered a semaphore error

A semaphore error occurred while trying to establish contact with the local engine. Check the Pervasive Event Log (PVSW.LOG) for more information.

3020: An error occurred while loading the MicroKernel

You receive this status code when an error occurs while loading the MicroKernel or when access to the server and client machine shared memory objects are unavailable. Check the Pervasive Event Log (PVSW.LOG) for more information.

3021: The MicroKernel router received a badly formatted data packet

The MicroKernel router rejected the response from the engine because it was badly formatted.Check the Pervasive Event Log (PVSW.LOG) for more information.

3022: The MicroKernel router could not send the request to the remote engine because the specified data buffer length resulted in a data packet object that is too large

A request to the MicroKernel router specified a data buffer length that resulted in a data packet size greater than 64 KB, which is the maximum. This can occur even if the data buffer length for the request is smaller than 64 KB because the MicroKernel router adds some packet overhead as it forms the data packet. Check the Pervasive Event Log (PVSW.LOG) for more information.

3023: The task table of the MicroKernel router is full

An internal table used by the MicroKernel router to manage tasks is full. This error should only occur in Win16 environments and indicates that a large number of applications are using the Win16 MicroKernel router at the same time.

3025: Cannot load IDS client requester

The MicroKernel router could not load the IDS client requester. The IDS client requester is W3ICRxxx.DLL, where xxx is a revision number (100, 101, etc.). The IDS client requester needs to be located in a directory listed in your PATH environment variable.

3026: Incompatible IDS client requester

The MicroKernel router found an incompatible IDS client requester. The IDS client requester was found, but is a version that cannot be used by the MicroKernel router, or the file is corrupt.

3027: Connection failure to IDS target server

The MicroKernel router could not connect to the IDS target server.

Be sure that IDS is running on the target server. If you are connecting to the IDS target by a host name, ensure that the name is spelled correctly and can be resolved to a TCP/IP address. If you are connecting by a TCP/IP dotted notation address, be sure that the address is correct and accessible from the client.You can use SmartScout as a diagnostic tool.

3028: Login failure to IDS target server

The MicroKernel router could not login to the IDS target server.

Be sure that the user name, password, and database set name used are correct. Some applications may prompt for this information; others may require MicroKernel Router configuration parameters to be set. See Advanced Operations Guide for more information regarding MicroKernel Router configuration parameters.

3029: IDS Not Allowed

This code will be returned if the path indicates an IDS request and either:

  • the key number on the open request indicates 'local only'; OR
  • the configuration setting for Use IDS is set to Off.

3030: Remote access not allowed

This code is returned if the path is remote, the client configuration setting for Use Local MicroKernel Engine has been set to Off, and either:

  • the key number on the open request indicates 'local only'; OR
  • the configuration setting for Use Remote MicroKernel Engine is set to Off.

3031: Linux requester cannot connect to this server

This code is returned if a Pervasive.SQL Linux requester attempts to connect to a Pervasive.SQL 2000 server that has Service Pack 2a or earlier, or a Pervasive.SQL V8 server without Service Pack 1.

  • To use the Linux requester to connect to a Pervasive.SQL 2000 server, you must have a special update that is available at http://www.pervasive.com/support/updates/index.asp
  • To use the Linux requester to connect to a Pervasive.SQL V8 server, you must have Service Pack 1 or higher which is available for download at http://www.pervasive.com/support/updates/index.asp
Prev
2300 to 2399 		Up
Check for Revisions 		Next
3100 to 3199


3100 to 3199

Network Services Layer Status Codes

The following status codes originate from the Pervasive Network Services Layer (PNSL).

3103: Server name not found by Pervasive Network Services Layer

The search for a target server name was unable to resolve an address after searching NDS, bindery, named pipes, and DNS. Some possible causes include:

  • No common communication protocol is available between the server and the client. Check the Supported protocols setting within the Communication protocols option for both the client and server. Make sure there is a common protocol (either SPX or TCP/IP) between the server and the requester.
  • For Windows NT/2000:
    • The MicroKernel engine not running.
    • Server only: Named pipes are used in these two operating systems to resolve server names. The networking at the operating system level was unable to find the target named pipe.
  • For NetWare:
    • The Server Addressing Protocol (SAP) filtered out the server name. SAP is used in NetWare 3.x and can be used in version 4.x. This type of filtering is common in WAN environments.
    • NWCALLS.DLL and/or NWIPXSPX.DLL is missing when using the Win16 client. This is especially likely if the Win32 clients are functioning but the Win16 clients do not. These are NetWare system files that can be obtained from Novell web site (http://www.novell.com).
    • For NetWare using TCP/IP: The server name is not in DNS.
  • For Novell NetWare 4.11 and Microsoft Windows 98 installs of Pervasive.SQL Client:
    • When the Pervasive System Analyzer tries to perform the first communication/functionality test, a status 3103 is returned. This status code may be caused by having no supported protocols set in the Pervasive.SQL client configuration utility. If Microsoft SPX is added as a supported protocol, the installation should complete without error.

3104: The Pervasive Network Services Layer encountered a permission error

For Windows NT only: Permission to access the target named pipe is denied. If you receive this status code:

  • Verify that you have access to the inter-process communication mechanism.
  • Ensure that your passwords are identical if you have the same user name on two systems.

3105: No available transport protocol for the Pervasive Network Services Layer

No transport protocol that is common to both the target server engine and clients is available. For example, this status code could be caused by a client using SPX when the server engine only has TCP/IP available. Check the Supported protocols setting within the Communication protocols option for both the client and server. For more information on Communication protocols, refer to Advanced Operations Guide.

3106: The Pervasive Network Services Layer encountered a connection failure

The Pervasive Network Services Layer was able to establish a transport connection at the client side, but the connection attempt at the target side failed. Some possible causes are:

  • The MicroKernel is not running on the server.
  • The network is overloaded.
  • The connection path is invalid.
  • You have more than one mapped drive to the same server.
  • You are trying to access a Server engine on a Windows NT server, and the Server engine's Access 4 Accept Remote Requests setting is set to Off. You must turn this setting On using the Configuration utility in Pervasive Control Center. See Advanced Operations Guide for more information.

Check the Pervasive Event Log (PVSW.LOG) for more information if you receive this status code.

3107: The Pervasive Network Services Layer is out of memory

The Pervasive Network Services Layer has insufficient memory to continue. Verify that you are not in a low memory condition.

3108: The Pervasive Network Services Layer detected an invalid session

The application attempted to use a network session that was not recognized by the Pervasive Network Services Layer. If the error persists, contact Technical Support at Pervasive Software.

3110: The network layer is not connected

The application attempted to use a network connection that was no longer active. This happens when the session with the Pervasive Network Services Layer is still valid, but was dropped by the network. Stop and restart the application.

3111: Failure during send to the target server

The Pervasive Network Services Layer attempted to send an application request to the target server and encountered a network specific error from the target. Check the Pervasive Event Log (PVSW.LOG) for more information.

You may receive this error when attempting to connect to a Workgroup engine on Windows 95 if the machine has not been upgraded to Winsock 2. If you are not running Winsock 2 on your Windows 95 computer with Workgroup engine installed, you should download the WinSock 2 update from Microsoft: http://www.microsoft.com/windows95/downloads/contents/wuadmintools/s_wunetworkingtools/w95sockets2/default.asp?site=95.

Note
If there is a problem with AutoReconnect, a further status code 3131 will be issued.

3112: Failure during receive from the target server

The Pervasive Network Services Layer attempted to receive data from the target server and encountered a network specific error. Check the Pervasive Event Log (PVSW.LOG) for more information.

You may receive this error when attempting to connect to a Workgroup engine on Windows 95 if the machine has not been upgraded to Winsock 2. If you are not running Winsock 2 on your Windows 95 computer with Workgroup engine installed, you should download the WinSock 2 update from Microsoft: http://www.microsoft.com/windows95/downloads/contents/wuadmintools/s_wunetworkingtools/w95sockets2/default.asp?site=95.

Note
If there is a problem with AutoReconnect, a further status code 3131 will be issued.

You may also receive this error under the following circumstances:

  • When using only the NetBIOS protocol with a remote Workgroup engine, the client is sending more bytes than can fit into the engine's network read buffer. Go the machine where the remote Workgroup engine is installed, and try increasing the value of the configuration parameter, Server 4 Communication Buffer Size 4 Read Buffer Size.

3114: The routing table of the Pervasive Network Services Layer is full

The Pervasive Network Services Layer Server Routing Table is full. This table normally grows dynamically as needed. Verify that you are not in a low memory condition.

3115: Pervasive Network Services Layer encountered a transport failure

The Pervasive Network Services Layer encountered a WinSock (Win32, Win16) error while creating the local transport endpoint on the client side. Check the Pervasive Event Log (PVSW.LOG) for more information.

3119: No authentication context is available

NSL was unable to return the access context on the specified session for the supplied object. There are several reasons why NSL could not obtain the context and it varies depending on the transport type.

  • NamePipe – It is possible that NSL was able to locate the server via DNS, but when it tried to make a Named Pipes call to request authentication of the client, the Named Pipes communications failed. Ensure that Named Pipes is configured correctly for the network for both the client and server. See your operating system documentation for information on Named Pipes configuration.
  • Novell NetWare Client – NSL asks the NetWare Client if this workstation has access to the database on the NetWare server. Ensure the user is configured to access the database file on the server.
  • NetWare – You can configure this operating system to use RunTime Server Support. NSL creates a context using one of the following:
    • the userID and password configured in the NetWare RTSS setting
    • the userID and password already used on this workstation to connect to any server
    • the workstation userID and password.

      If you want to use this mechanism, RTSS must be enabled. See the Advanced Operations Guide for more information on enabling RTSS and userID and password configuration.

  • Windows – you use stored client credentials to authenticate to the server, and there are no credentials stored and value for the Prompt for Client Credentials setting is Off.

    To resolve this condition, use the Configuration utility to change the Prompt for Client Credentials setting to On, or use the pvnetpass utility to store a valid set of client credentials for the server. See Advanced Operations Guide for more information about security. See Pervasive.SQL User's Guide for more information about the pvnetpass utility.

  • Linux – You must configure a username and password for all remote server data access. To resolve this condition, use the pvnetpass utility to specify a username and password for the given server, or create a default username and password for the server using pvnetpass. See Advanced Operations Guide for more information about security. See Pervasive.SQL User's Guide for more information about the pvnetpass utility.

3124: Pervasive Network Services Layer task table is full

For each user of the Network Services Layer, a task entry is created. If the maximum number of tasks has already been reached (512 and not configurable), this error is returned. Close any applications using Pervasive.SQL that are no longer needed.

3125: The Pervasive Network Services Layer was unable to resolve the Novell Directory Services name into a NetWare server name

The Pervasive Network Services Layer was unable to resolve the Novell Directory Services name into a NetWare server name. This occurs on Windows 95/98/ME workstations with the Microsoft Service for Novell Directory Services in cases where the system is unable to load the Windows 95 Requester support modules. Ensure that the Requester Win95 support modules are installed and available, and that NWCALLS.DLL is available on the Windows 95 workstation.

3126: The Pervasive Network Services Layer was unable to resolve the given filename into a valid path

Check that the given filename is a valid file format and path.

3127: Failure during send to the IDS target server

The IDS client requester attempted to send data to the IDS target server and encountered a TCP/IP specific error. Stop and restart the application. If the problem persists, consult your network administrator.

3128: Failure during receive from the IDS target server

The IDS client requester attempted to receive data from the IDS target server and encountered a TCP/IP specific error. Stop and restart the application. If the problem persists, consult your network administrator.

3131: Pervasive Network Services Layer encountered an error while reconnecting

This status code means that AutoReconnect was unsuccessful. The following messages will appear in PVSW.LOG:

    • "3131: Reconnect failed. Client and Server Message IDs out of synchronization." The client and server did not agree on the current context. Because the integrity of the last request cannot be verified, the connection was terminated.
    • "3131: Reconnect not attempted, AutoReconnect not enabled on either client or server." In this case, either the client, server or both has AutoReconnect disabled or your server version does not support AutoReconnect (pre-Pervasive.SQL V8). The reconnection attempt will not be made.
    • "3131: Reconnection attempt timed out." This means that the client was unable to obtain a new connection to the server within the AutoReconnect timeout period.
    • "3131: Reconnection negotiations failed after re-establishing network connection." This means that the client was successful in making a new network connection to the server, but communications failed during the Pervasive AutoReconnect negotiations.

Note
A PVSW.log entry of "0: Reconnect after send/receive failure was successful" indicates a successful connection.

3132: Unsupported Function

This error is returned when the Scalable SQL interface attempts to communicate with the Pervasive.SQL 8 Network Services Layer (NSL).

The legacy Scalable SQL Engine is not supported in any combination with Pervasive.SQL 8 components. If you receive this error, search for and uninstall Scalable SQL (or Pervasive.SQL 7), and/or all if its components.

Prev
3000 to 3099 		Up
Check for Revisions 		Next
4000 to 4099


4000 to 4099

Database Utilities Status Codes

This section lists the status codes you can receive when using the Database Utilities (DBU).

4083: Component not loaded

If you receive this status code while attempting to start the Pervasive.SQL Transactional or Relational Services, you are missing a key file. To resolve this problem, uninstall Pervasive.SQL V8 and reinstall it.

Note
You may get more information about the situation that caused this error by setting the environment variable, PVSW_DISP_LOAD_ERRS=AIF, and running the application again. This enables the Services DLL to display on-screen module load errors. However, this environment variable should only be set to diagnose module load errors. In all other cases, it should not be set.

4086: An internal error occurred. Utilities Requester receive size too small. Verify that the correct components are loaded

This status code may appear when all three communication protocols (TCP/IP, SPX and NetBios) are present. By default, all three of these protocols are enabled. To resolve this error message, disable one of the protocols in the server configuration.

In Pervasive.SQL 8 and later, NetBIOS is not supported by the Server engine.

To Adjust Server Protocols:

  1. Click Start 4 Programs 4 Pervasive.SQL V8 4 Control Center.
  2. Expand Pervasive.SQL V8 Engines and expand the desired database.
  3. Expand Configuration, then expand Server, and click on Communication Protocols.
  4. In the right hand frame, double-click on Supported protocols.
  5. The Supported protocols dialog box opens.
  6. At this point, you can deselect an option as appropriate to your network environment. In most cases, only the first two protocols are needed. Highlight a protocol in the list, then click on the "<" button to remove it from the list.
  7. Click OK.
  8. Close the Pervasive Control Center and stop and restart the engine.
  9. Ensure that each client workstation that access the database server has at least one Supported Protocol in common with the server, or else the clients cannot communicate with the server. At each workstation, check the Configuration setting Client 4 Communication Protocols 4 Supported Protocols.
Prev
3100 to 3199 		Up
Check for Revisions 		Next
5000 to 5999


5000 to 5999

Encryption Status Codes

This section lists status codes you can receive when using the Wire Encyption feature. In Advanced Operations Guide, see Pervasive.SQL Security for more information about the Wire Encryption feature and other Pervasive.SQL security topics.

5000: Client requires encryption

Your client configuration setting for Wire Encryption is set to Always, and the server to which you are trying to connect either has a Wire Encryption setting of Never, or the server has a version of less than 8.50 which does not support the Wire Encryption feature.

To resolve this condition, either change the Wire Encryption setting of the client to If Needed or change the Wire Encryption setting of the server to Always or If Needed.

To change the Wire Encryption setting:

  • On Windows or NetWare, use Pervasive Control Center.
  • On Linux, use the pvclientcfg script.

Note
On any one machine, the Pervasive.SQL server and client share a single Wire Encryption setting.

5001: Server requires encryption

Your client configuration setting for Wire Encryption is set to Never, and the server to which you are trying to connect has a Wire Encryption setting of Always.

To resolve this condition, change the Wire Encryption setting of the client to If Needed or Always.

To change the Wire Encryption setting:

  • On Windows or NetWare, use Pervasive Control Center.
  • On Linux, use the pvclientcfg script.
Prev
4000 to 4099 		Up
Check for Revisions 		Next
6000 to 6050


6000 to 6050

Data Dictionary Status Codes

This section lists the status codes that pertain to the data dictionary files. These codes often relate to errors involving referential integrity.

6000: Orphan Found

This error occurs when you perform a referential integrity test with the Check Database wizard. A foreign key in a related table does not have a match in the primary table. See Checking Consistency and Referential Integrity in Pervasive.SQL User's Guide.

6002: Invalid Column

The column name cannot be used. The name may contain invalid characters or the name may be a duplicate name. See Naming Conventions in the online Pervasive.SQL Programmer's Guide, which is part of the Pervasive.SQL Software Developer's Kit (SDK).

6003: Foreign Key Not Found

The column to which the foreign key is to be associated does not exist in the primary table.

6005: Column Not Nullable

This column cannot be made null. Certain data types, such as identity and small identity, cannot be null. Check the data type of the column. See Data Types in SQL Engine Reference for a list of the Pervasive.SQL data types.

6006: Invalid Data Type

The number for the data type is not within the valid ranges. The current range is 0 to 30. See Data Types in SQL Engine Reference for a list of the Pervasive.SQL data types.

6007: Invalid Index Number

The index number is less than zero. Negative numbers are not allowed as index numbers.

6008: Too Many Segments

The number of index segments is greater than 119. The number of index segments that you may use depends on the file's page size. The maximum number of index segments permitted with a page size of 4,096 bytes is 119. See Choosing a Page Size and Segmentation in the online Pervasive.SQL Programmer's Guide, which is part of the Pervasive.SQL Software Developer's Kit (SDK).

6009: Index Name Duplicate

The index name is already being used a column. Use a unique index name. See Naming Conventions in the online Pervasive.SQL Programmer's Guide, which is part of the Pervasive.SQL Software Developer's Kit (SDK).

Prev
5000 to 5999 		Up
Check for Revisions 		Next
7000 to 7050


7000 to 7050

Distributed Tuning Interface Status Codes

This section lists the status codes you can receive when using the Distributed Tuning Interface. See API Programmer's Reference for more information on this interface.

7001: Invalid connection handle specified

Specify a valid connection handle with the API call.

7002: NULL pointer specified

Specify a valid pointer with the API call.

7003: Buffer was too small

Increase the buffer size. Some APIs report the required size in an out parameter.

7004: A general failure occurred

This error can be returned in the following situations:

  • You do not have the necessary permissions to perform the operation.
  • The engine on the target machine is not started.

7005: Invalid data type specified

Specify a valid data type for the operation.

7006: Setting value is out of range

Check the valid range for the setting in the configuration reference section of Advanced Operations Guide.

7007: At least one selection item is invalid

Check the list of selection items to ensure all are valid selections. You can find the valid values in the configuration reference section of Advanced Operations Guide.

7008: Invalid sequence number

Specify a valid sequence number for the operation.

7009: Data on open files is not available

Data related to open files is not currently available.

7010: Client ID is invalid

The client ID needed for this operation is invalid. Specify a valid client ID.

7011: Insufficient access rights

You have insufficient access rights to perform the operation requested. Many DTI functions require administrative rights on the server. See API Programmer's Reference for more information on rights required for DTI operations.

7012: Named database already exists

The named database you are trying to add already exists. Specify a unique name for the named database.

7013: Named database does not exist

The requested named database does not exist. Specify a valid named database.

7014: DTI not initialized

Before you can use DTI functions, you must first initialize DTI by calling the PvStart() function. Then you can invoke DTI operations. When finished, use PvStop() to terminate the DTI session. See API Programmer's Reference for more information.

7015: File not open

The operation you requested requires an open file.

7016: Dictionary files already exist

Dictionary files for the specified database already exist.

7017: Dictionary path in use

Another process has the dictionary files in use. Close all other running applications and retry the operation.

7018: Invalid DSN name

The DSN you are trying to create contains invalid characters or is too long. DSN names cannot be longer than 20 characters and cannot contain the following symbols: []{}() ?*=!@,;

7019: DSN already exists

The DSN you are trying to create already exists. Specify a different name for the DSN.

7020: Specified DSN does not exist

The DSN you are trying to locate does not exist. Specify a valid DSN name.

7021: Invalid open mode for DSN

Specify a valid open mode. DSN open modes are documented in Advanced Operations Guide.

7022: Component not loaded

A component needed for DTI is not loaded. Try restarting your Pervasive.SQL engines.

7023: The database files cannot be deleted because they are shared with another database

You receive this status when trying to delete a database that shares DDF files with another database.

7024: Invalid Btrieve Security Policy

When creating a database, an invalid Btrieve Security Policy was specified. Specify one of:

  • PSQL_DB_POLICY_CLASSIC
  • PSQL_DB_POLICY_MIXED
  • PSQL_DB_POLICY_DBSEC
Prev
6000 to 6050 		Up
Check for Revisions 		Next
7063 to 7122


7063 to 7122

License Administrator Status Codes

This section lists the status codes you can receive when using the License Administrator.

7064: No license obtained for the product

This means that the Pervasive.SQL client tried to release a license (one user count, in this instance) but the client either had not acquired a license (one user count) from the server or had acquired a license for a different product.

7065: A product has not been obtained

An application attempted to obtain the license (a user count) for a product, for example Pervasive.SQL V8 Server or Pervasive.SQL V8 Workgroup, but no license has been applied for the product. Ensure that a license has been applied for the product before attempting to obtain the license information.

7101: Invalid character in the license string

The license key you attempted to apply contains one or more invalid characters. All alphanumeric characters (upper or lower case) are permitted except for "i" and "o." Lower case letters are automatically converted to upper case.

Correct any invalid characters in the license key and apply the key again.

7102: Illegal license type is defined

The license key an application attempted to apply is not a valid license because the Product Type is invalid. The permissible types are permanent and temporary.

Ensure that you have a valid license key issued by Pervasive Software or by your application vendor if the Pervasive.SQL database engine is embedded in an application.

7108: License key length is too long

The length of the license key you attempted to apply exceeds the maximum length allowed for a key (24 characters). Ensure that the license key contains 24 characters.

7109: No such license exists

The license key you are trying to remove does not exist. The license key may have already been removed.

If you are using the License Administrator GUI to remove the key, press F5 or click Refresh to redisplay the list of applied licenses. Check the refreshed list for the license key you were trying to remove. If the license key still appears to exist, exit then restart License Administrator.

7110: There is at least one temporary license that has already expired, and there are no other than temporary licenses installed on the system

This means that the overall user count is zero, and that all of the installed licenses are temporary ones that have expired. Install one or more valid licenses, temporary or permanent, to increase the user count beyond zero.

7111: Temporary licenses cannot be removed. The license becomes invalid after its expiration date.

You have attempted to remove a temporary license. Temporary licenses cannot be removed; they become invalid after their expiration date. Verify that the license you want to remove is a type that can be removed.

Note that the permanent license provided with Pervasive.SQL Workgroup cannot be removed.

7112: License is already installed

The license key you are attempting to apply has already been applied (installed). You cannot reapply a license once it has been installed unless you remove it first. Temporary licenses cannot be removed.

If you are using the License Administrator GUI to apply the license, press F5 or click Refresh to redisplay the list of applied licenses. Check the refreshed list for the license you were trying to apply. If the license still does not appear in the list, exit then restart License Administrator.

7113: Invalid license key. Verify the provided key.

The license key you attempted to apply is not a valid license. Ensure that you have a valid license key issued by Pervasive Software or by your application vendor if the Pervasive.SQL database engine is embedded in an application.

If you are using the License Administrator GUI to apply the key, repaste or retype the key into the License Key field, then click Apply License Key.

7115: Invalid product ID

The license key you attempted to apply is not a valid license because the name of the Pervasive.SQL product in the key is not Pervasive.SQL V8 Server or Pervasive.SQL V8 Workgroup. Only these two product IDs are supported at this time.

Ensure that you have a valid license key issued by Pervasive Software or by your application vendor if the Pervasive.SQL database engine is embedded in an application.

7117: License key is too long

The length of the license key you attempted to apply exceeds the maximum length allowed for a key (24 characters). Ensure that the license key contains 24 characters.

7118: The server is not running. Unable to show, apply, or remove a license. Verify that the server is running and that network communications are functioning.

License Administrator is unable to connect to the remote server. This could indicate the following:

  • You may have started the License Administrator on a client where a database engine is not installed. Click OK to establish a connection to a server.
  • The server is not running. Follow the steps in Verifying Database Engine is Running in Getting Started with Pervasive.SQL (Server edition) to ensure the server is running.
  • Network communications are preventing connection to the server. Use the ping command to the server to verify that network communications are working.

7119: The local server is not running. Unable to show, apply, or remove a license.

License Administrator is unable to connect to the database engine on the local machine (the machine on which License Administrator is running). Ensure that a database engine is installed and running on the local machine. Follow the steps in Verifying Database Engine is Running in Getting Started with Pervasive.SQL (Server edition) to ensure the database engine is running.

7120: The license is not removable

The license or licenses you are attempting to remove cannot be removed. Temporary licenses cannot be removed; they become invalid after their expiration date.

Verify that the license you want to remove is a type that can be removed. The permanent license provided with Pervasive.SQL Workgroup, for example, cannot be removed.

7122: Your trial license has expired

The temporary, trial, license you are attempting to install has expired, and one of the following is true:

  • no other licenses are installed
  • other licenses are installed but are no longer valid. (All installed temporary licenses, for example, have expired.)

The Pervasive.SQL product cannot be installed without a valid license. Click Continue if you have a valid license to apply. If you need an additional trial period, you may request a new trial license from Pervasive Software.

Prev
7000 to 7050 		Up
Check for Revisions 		Next
8000 to 8499


8000 to 8499

Component Management Status Codes

These status codes originate from the Smart Component Management and Event Logging interface of the MicroKernel.

8001: The Services DLL encountered an error while allocating memory

Memory could not be allocated. Verify that your system resources are not exhausted.

8002: The component ID string was not found

The Services DLL attempted to retrieve an ID from a component, and the component did not have an ID. This status code results from an error in the application.

8003: Thunk path is not accessible to the Services DLL

Smart Component Management cannot find the address of the Win32 interfaces.

8005: Interface not initialized

An interface was not initialized properly. Check the Pervasive Event Log (PVSW.LOG) for more information.

8006: The specified component was not found

Smart Component Management cannot operate on the component because it was not found. Check the Pervasive Event Log (PVSW.LOG) for more information.

You may get more information about the situation that caused this error by setting the environment variable PVSW_DISP_LOAD_ERRS=AIF, and running the application again. This environment variable enables the Services DLL to display on-screen module load errors. However, this environment variable should only be set to diagnose module load errors. In all other cases, it should not be set.

8007: Error retrieving Win32 version information

An error occurred while retrieving the Win32 version information from the operating system. This error should not occur and it indicates a problem with your Windows environment. Contact Pervasive Software Customer Support.

8008: Information mismatch in component ID

An application specified multiple platforms, types or versions in a component ID. Therefore, the Services DLL cannot bind to the correct component.

8009: Required information missing in component ID

A component ID string is missing required information such as:

  • Platform
  • Type
  • Major/minor functional level

8010: Error while opening a file to retrieve component ID

The Services DLL attempted to open a file to retrieve a component ID, and the file did not exist.

8012: Required information for binding rule is missing

Required information is missing, such as:

  • Platform type
  • Major/minor functional level

8013: Error locating a component

An error occurred while opening an operating system directory to search for a component. Check the Pervasive Event Log (PVSW.LOG) for more information.

You may get more information about the situation that caused this error by setting the environment variable PVSW_DISP_LOAD_ERRS=AIF, and running the application again. This environment variable enables the Services DLL to display on-screen module load errors. However, this environment variable should only be set to diagnose module load errors. In all other cases, it should not be set.

8016: Invalid instance specified

This error occurs when an application passes an instance handle to the Services DLL that is invalid.

8017: Invalid version information structure

An application tried to free a version information structure and the Services DLL determines that the version structure is invalid.

8018: Item not found by Services DLL

An application requested that the Services DLL free an item, and the Services DLL determines that the item did not originate from the Services DLL.

8019: Library not accepting interface requests

The Services DLL cannot accept requests. In a multi-threaded application, this can occur when one thread attempts to make a request while other threads are overloading the Services DLL. In this situation, subsequent retries should clear the error.

8020: Error loading component

You receive this status code when one of the following occurs:

  • The Services DLL received an operating system error when trying to load a component. Refer to "Diagnosing Load Errors" in Advanced Operations Guide.
  • A space was used in the Data Source Name (DSN) or Database Name (DBN).
  • During client installation, InstallShield makes a request to the OS asking for the system root\system directory. It then installs the requester DLLs in that directory. It asks twice—once for the 32-bit portion and once for the 16-bit portion. During the 32-bit phase, Citrix or Terminal Server returns \WTSRV\SYSTEM, where the 32-bit dlls get installed and which is shared by all users. During the 16-bit portion, the system root is returned to the installer as WTSRV\PROFILES\<user>\Windows\System, which is where the 16-bit dlls get installed and are only available to the specific user that did the install. Use the following recovery method:
    • Log in as administrator or equivalent and run the Pervasive client setup from Control Panel - Add/Remove Programs. There will be an option to perform this install for "this user" or for "all users". Choose "all users" and all of the requester dlls, both 16 and 32-bit will be installed into the WTSRV\SYSTEM directory.

Note
Pervasive.SQL V8 does not install the requester DLLs into the system directory. By default, all components are installed off of the root into a PVSW directory. From a DOS prompt, type PATH and ensure that the PVSW\BIN directory is included. If it is not, use the Control Panel, System, Environment tab and add the PVSW\BIN directory to the PATH variable. Additionally, the BTI.INI will be installed to the WTSRV directory, which then gets copied to the Profiles\<user>\Windows directory the first time the user executes a 16-bit Windows Btrieve application. Later modifications made to the BTI.INI in the WTSRV directory are not migrated to the users profile directory and it will not be updated.

8022: Component not initialized

While using a multi threaded application, one thread shut down a component and other threads continue trying to use it.

8023: Invalid filename passed to Services DLL

The Services DLL received a filename that does not exist.

8024: Invalid function name

An application asked to import a function that does not exist.

8027: Required attribute missing in component ID

An application program did not specify a required attribute in the component ID.

8030: Return buffer too small for information

An application passed the Services DLL a buffer in which to return information, and that buffer was not large enough to contain the information.

8032: Component ID is invalid

A component ID string was found but it may be invalid because it is too short, too long, or contains invalid characters.

8035: Invalid interface for NetWare platform

An application made a call to an interface that is not supported on the NetWare platform.

8039: Invalid operating system handle specified

An operating system handle to a component ID string was invalid. This can occur when an application erroneously modifies a handle obtained using the GetFileVersionByHandle or the GetFileSizeByHandle functions.

8040: CRC check on component ID failed

A routine CRC check on the component ID failed. This may happen when an application erroneously alters a component ID.

8098: Invalid column-level GRANT statement

You receive this status code when you attempt to make a column-level GRANT statement for a right that is not supported. Only SELECT, INSERT and UPDATE are valid column level rights.

In SQL Engine Reference, see GRANT for more information about valid GRANT syntax.

8099: Only one user can be connected to database when altering security state

You receive this status code when you issue a SET SECURITY statement or attempt to enable or disable security on a database from Pervasive Control Center when more than one user is connected to the database.

To resolve this condition, ensure that only one user is connected to the database and retry the operation.

Prev
7063 to 7122 		Up
Check for Revisions 		Next
8500 to 8589


8500 to 8589

ECAS Interface Status Codes

This section describes the status codes returned by the ECAS (Enhanced Common Address Space) interface. Most of the errors are system errors and cause an entry in the Pervasive event log. In many cases when you receive these errors, there may be some instability in the environment or memory allocation and you will need to restart the machine.

8500: An error occurred during the Smart Components initialization

In its attempt to auto-load the Workgroup engine, the application failed to initialize the smart component library. You may get more information about the situation that caused this error by setting the environment variable PVSW_DISP_LOAD_ERRS=AIF, and running the application again. This setting enables the Services DLL to display on-screen module load errors. However, this environment variable should only be set to diagnose module load errors. In all other cases, it should not be set.

8502: An error occurred when trying to locate W3UPIXYY.DLL

In its attempt to auto-load the Workgroup engine, the application failed to locate or load W3UPIXYY.DLL.

8503: An invalid W3UPIXYY.DLL has been found

In its attempt to auto-load the Workgroup engine, the application discovered an incorrect version of W3UPIXYY.DLL. This problem may have been caused by a corrupt version of W3UPIXYY.DLL.

8504: An error occurred when trying to create system semaphore

In its attempt to auto-load the Workgroup engine, the application failed to create the system semaphore. This problem may have been caused by the operating system running out of resources.

8505: An initialization error occurred when trying to establish a session with the Workgroup engine

In its attempt to auto-load the Workgroup engine, the application failed to establish the session with the Workgroup engine. This is a system error.

Some customers who have only Server engines in their environment have reported frequent pairs of Status Code 8505 and 8517 in the PVSW.LOG file on one or more client workstations. The most likely cause is that your workstation client is configured to connect to a local Workgroup engine when one is not installed.

Note
If you are not certain whether your environment includes Workgroup engines, please check with your administrator. The procedure below disables access to your local Workgroup engine.

To prevent the client from attempting this connection, follow these steps:

  1. Open Pervasive Control Center on the client workstation, then double-click the icon representing the client workstation.
  2. Double-click Configuration, double-click Client, double-click Access.
  3. Double-click Use Local MicroKernel Engine. Set this option to Off.

8506: A fatal error occurred when loading the MicroKernel

In its attempt to auto-load the Workgroup engine, the application failed to load the MicroKernel, W3MKDE.DLL. This may have been caused by a missing W3MKDE.DLL.

8507: No valid session was found

The application lost its session with the Workgroup engine.

8508: An error occurred when attempting to enable Btrieve access

The application failed to enable the Btrieve access method in the Workgroup engine.

8509: A timeout occurred during the initialization of the MicroKernel

The application timed out during the initialization of the MicroKernel. This may have been caused by a bad configuration option or a malfunction of the Workgroup engine.

Check the Pervasive Event Log (PVSW.log) for more information.

8510: A fatal error occurred when loading the Scalable SQL engine

This status code is obsolete in Pervasive.SQL 2000 and later versions.

In its attempt to auto-load the Workgroup engine, the application failed to load the Scalable SQL, W3SSQL.DLL. This may have been caused by a missing W3SSQL.DLL.

8511: An error occurred when attempting to enable SQL access

The application failed to enable the SQL access method in the Workgroup engine.

8512: A timeout occurred during the initialization of the Scalable SQL engine

This status code is obsolete in Pervasive.SQL 2000 and later versions.

The application timed out during the initialization of the Scalable SQL engine. This may have been caused by an invalid configuration option or a malfunction of the Workgroup engine.

8513: An error occurred when disabling Btrieve access

The application failed to disable the Btrieve access method in the Workgroup engine.

8514: An error occurred when unloading the MicroKernel

The application failed to unload the MicroKernel.

8515: An error occurred when disabling SQL access

The application failed to disable the SQL access method.

8516: An error occurred when unloading the Scalable SQL engine

This status code is obsolete in Pervasive.SQL 2000 and later versions.

The application failed to unload Scalable SQL.

8517: An error occurred when closing the session with the Workgroup engine

The application could not close the session with the Workgroup engine.

Some customers who have only Server engines in their environment have reported frequent pairs of Status Code 8505 and 8517 in the PVSW.LOG file on one or more client workstations. The most likely cause is that your workstation client is configured to connect to a local Workgroup engine when one is not installed.

Note
If you are not certain whether your environment includes Workgroup engines, please check with your administrator. The procedure below disables access to your local Workgroup engine.

To prevent the client from attempting this connection, follow these steps:

  1. Open Pervasive Control Center on the client workstation, then double-click the icon representing the client workstation.
  2. Double-click Configuration, double-click Client, double-click Access.
  3. Double-click Use Local MicroKernel Engine. Set this option to Off.

8518: An error occurred when attempting to allocate system memory

The application failed to allocate memory from the system. Possible ways to avoid this include closing all other applications and restarting the engine, decreasing the size of the cache, and changing the engine settings so that a smaller number of files and/or file handles are open.

8519: A fatal error occurred when loading the SRDE

In its attempt to auto-load the SQL Relational Database Engine (SRDE), the application failed to load the file, W3ODBCEI.DLL. This may have been caused by a missing W3ODBCEI.DLL.

8520: A timeout occurred during the initialization of the SRDE module

The application timed out during the initialization of the SQL relational database engine module. This may have been caused by a bad SRDE configuration option or a malfunction of the Workgroup engine.

8521: An error occurred when unloading the SRDE module

The application failed to unload the SRDE module.

Prev
8000 to 8499 		Up
Check for Revisions 		Next
8590 to 8599


8590 to 8599

W3DBSMGR Status Codes

This section describes the status codes returned by the W3DBSMGR component. These errors are in the range 8590 to 8599 and cause an entry in the event log. In many cases when you receive these errors, there may be some instability in the environment or memory allocation and you will need to restart the machine.

8590: An error occurred in the database manager while initializing Smart Components Manager

This error occurs when W3DBSMGR.DLL failed to initialize the smart component library. You may also get more information about the problem that caused this error by setting the environment variable PVSW_DISP_LOAD_ERRS=AIF, and running the application again. This setting enables the Services DLL to display on-screen module load errors. However, this environment variable should only be set to diagnose module load errors. In all other cases, it should not be set.

8591: The database manager is already loaded

In its attempt to initialize, the Workgroup engine detected that another copy of the Pervasive.SQL Workgroup engine is already running in memory. To avoid this error, shut down the program that is already running as specified below:

  • If the program is autoloaded by an application, then terminate the application.
  • If the program is automatically loaded, then shut down the application using the tray icon.

8592: Insufficient memory to load the database manager

This error indicates that the system is out of resources. Close some applications and try again.

8593: An error occurred while the database manager was creating a system thread

This error indicates that the system is out of resources. Close some of the applications and try again.

8594: Engine cannot be restarted

The Workgroup engine has been previously stopped while there were active applications and cannot be restarted. Close all current applications and try again. If you receive this code once more, you will need to restart the computer.

Prev
8500 to 8589 		Up
Check for Revisions 		Next
10000 to 10100


10000 to 10100

SQL Connection Manager Codes

This section lists status codes returned by the SQL Connection Manager.

10000 through 10064: You have been unexpectedly disconnected from the server

Re-start your application, then access the data source again. Contact your system administrator if you continue to have problems.

10065: Connection attempt timed out

The SQL Connection Manager may be inactive or using a different transport protocol from the client.

Verify that the relational service is running. On NetWare, run SQLSTART. On Windows, open the Services control panel and inspect the Pervasive.SQL Relational service.

Verify that the client and server are using the same communication protocols. Open PCC on the client workstation. Within PCC, double-click on the icon representing the workstation. Double-click Configuration. Double-click Client, then Communication Protocols. In the right-hand pane, double-click Supported Protocols. Make sure the list of protocols is the same as that for the server. You can access the Server protocols in PCC by double-clicking the icon in PCC representing the Server engine. Then double-click Configuration and Server, and so on, as above.

Prev
8590 to 8599 		Up
Check for Revisions 		Next
Messages


Messages

A Reference to Pervasive.SQL Messages

This chapter describes the messages that can be returned to Pervasive.SQL users. The messages are listed in alphabetic order by category. Some of the messages listed in this chapter may be generated by utilities that are not part of your Pervasive.SQL distribution.

Messages are not the same as status codes (see Chapter 1—Status Codes.). Messages are returned to end users by utilities or specific components and generally begin with a prefix and a number. For example: MKDE–16: There is insufficient memory to load the MicroKernel Database Engine.

Some messages refer to status codes, as in the following example:

Error Accessing INDEX.DDF. Status = nn

The status code is tied to a particular component, and it varies depending on the nature and source of the error. The value for nn or xx refers to a software-supplied number (for example, a status code, operation code, or number of records) and xxxx refers to a software-supplied name (for example, a filename, a data type or key type, or a command).

The messages are arranged according to the originating component. The table below lists the prefixes for each type of message.
Table 2-1 Message Groups
Prefix | Type of Code
(none) | Generic Messages
BREQUEST | MKDE Requester Messages
BREQUTIL | Requester Utility Messages
BROUTER | Message Router Messages
BSPXCOM | SPX Communications Module Messages
BTCPCOM | TCP/IP Communications Module Messages
BUTIL | Maintenance Utility Messages
MKDE | MicroKernel Database Engine Messages
NWBSRVCM | NetWare Server Communications Manager Messages

Prev
10000 to 10100
Check for Revisions 		Next
(No prefix)


(No prefix)

Generic Messages

The following messages may be returned by more than one utility or component. These messages are not preceded by a component prefix or number.

Bfloat and Float Fields Must Be 4 or 8 Bytes

You have defined a FLOAT or BFLOAT column with a size other than 4 or 8 bytes. Change the column size to 4 or 8 bytes.

First and Second Password Entries Do Not Match, Please Retype

The password you entered the second time is not the same as the first one you specified. Specify and verify your password again.

Incorrect Netware Version

The NetWare version loaded is incompatible with the version of BREQUEST that is loaded. The NetWare shell for NetWare v3.12 or above must be installed at the client machine.

Incorrect Parameter

The SQL or MKDE Requester returns this message if it encounters an error while loading at a DOS client machine. You specified an invalid configuration option. For information about the Configuration utility and specifying the configuration options, refer to Pervasive.SQL Advanced Operations Guide.

Insufficient Memory

The SQL or MKDE Requester returns this message if it encounters an error while loading at a DOS client machine. The Requester cannot allocate enough memory for the configuration options specified. Ensure that the client machine has enough memory to load all the programs you want to run.

Invalid Load File Format. End of Record Marker Not Found

The Maintenance utility (BUTIL) encountered an invalid record terminator in the sequential load file. The Maintenance utility expects a carriage return/line feed at the end of each record in a load file. This error usually occurs because the length specified at the beginning of the sequential record is incorrect.

Load File Referenced Undefined Public Variable. Module xxxx Not Loaded

In the NetWare v3.12 or later environment, a module you attempted to load requires that the correct version of another module be loaded. All Pervasive.SQL utilities require that the following software is loaded:

  • NetWare v3.12 or later, including the AFTER311 NLM. Load AFTER311 from AUTOEXEC.NCF before calling BSTART.
  • Pervasive.SQL
  • MicroKernel Database Engine v7.x and the BSPXCOM NLM

Local Engine Is Already Loaded

The Pervasive.SQL Requester returns this message if it encounters an error while loading at a DOS client machine. A local engine (XQL v2.11 or earlier) is loaded at the machine. You cannot load the older local engine and the newer Requester at the same time.

Must Have DOS 3.1 or Greater

The SQL or MKDE Requester returns this message if it encounters an error while loading at a DOS client machine. The Requesters require DOS v3.1 or later.

NetWare Shell Is Not Installed

The SQL Requester returns this message if the NetWare shell is not installed on the DOS client machine at which you want to load the Requester. You must install the NetWare shell on the client machine before an application can communicate with SQL.

Redirection List Not Large Enough

The SQL Requester returns this message if it encounters an error while loading at a DOS client machine, and it cannot store all the redirected devices in its internal redirection list. Increase the value for the /R configuration option.

SQL Requester Is Already Loaded

The SQL Requester returns this message if you try to load the Requester when it is already loaded at the DOS client machine.

SPX Is Not Loaded

The SQL or Btrieve Requester returns this message if it encounters an error while loading at a DOS client machine. You must load the NetWare SPX communications software before an application can access the server-based version of Pervasive.SQL or the MicroKernel. For more information about installation, refer to Getting Started with Pervasive.SQL.

Prev
Messages 		Up
Check for Revisions 		Next
BREQUEST


BREQUEST

MKDE Requester Messages

The following messages are specific to MKDE Requesters.

BREQUEST–1: The message file xxxx is invalid; BREQUEST cannot be loaded

Install a valid message file so the Requester can be loaded.

BREQUEST–4: The value specified for the Data Message Length (/d) option is invalid

Specify the D option as /D:n, where n is a number between 532 and 57,000. For more information about DOS Requester options, refer to Getting Started with Pervasive.SQL.

BREQUEST–5: The workstation has insufficient memory to load BREQUEST

Unload unnecessary programs or try a smaller value for the /D parameter. For more information about DOS Requester options, refer to Getting Started with Pervasive.SQL.

BREQUEST–7: The MKDE Requester must be loaded before the Client Engine or Requester

The Pervasive.SQL Workgroup engine or Requester is already loaded; the Btrieve Requester for DOS must be loaded first. Unload the Pervasive.SQL Workgroup engine or Requester and then load the Btrieve Requester for DOS.

BREQUEST–8: DOS 3.00 or greater is not loaded; load DOS 3.00 or greater

Load DOS 3.x or later to proceed.

BREQUEST–9: SPX is not available on the workstation

Load SPX.COM on your client machine.

BREQUEST–10: The function SPXInitialize returned an error.

Ensure that the file IPX.COM is loaded.

BREQUEST–11: The IPX socket table is full

The MKDE Requester for DOS returns this message when the IPX socket table is full.

BREQUEST–12: The value specified for the NetWare Runtime Server support (/C) option is invalid

Specify this option in one of these forms:
Table 2-2 NetWare Runtime Server Support /C options
/C:0 | Disables NetWare Runtime server support.
/C:1 | Enables NetWare Runtime server support. To authenticate requests on the NetWare Runtime server, provide a username and password, separating them with commas, as follows: /C:1,username,password

For more information about DOS Requester options, refer to Getting Started with Pervasive.SQL.

BREQUEST–13: The value specified for the Number of Servers (/S) is invalid

Specify the /S option as /S:n, where n is a number between 1 and 8. For more information about DOS Requester options, refer to Getting Started with Pervasive.SQL.

BREQUEST-14: MKDE has been removed from memory

This is an informational message that displays when you use the BREQUEST or BREQNT requester programs with the /u (unload) parameter. See Getting Started with Pervasive.SQL for more information on the command-line parameters of BREQUEST and BREQNT.

BREQUEST-15: MKDE is not loaded

You used the BREQUEST or BREQNT requester programs with the /u parameter that unloads MKDE from memory, and MKDE was not running at the time.

Prev
(No prefix) 		Up
Check for Revisions 		Next
BREQUTIL


BREQUTIL

Requester Utility Messages

This section lists the messages that the SQL and MKDE Requester utilities generate.

BREQUTIL–8: MicroKernel or MKDE Requester is not loaded

You must load the MicroKernel or a MKDE Requester before you can perform a MKDE operation.

BREQUTIL–9: MKDE operation nn was unsuccessful. The number of the applicable MKDE status code is nn

Refer to Chapter 1, Status Codes for a description of Status Code nn, where nn is the number of the status code.

BREQUTIL–16: MicroKernel or MKDE Requester cannot be removed from memory while the MKDE is loaded

If you want to unload the MicroKernel or MKDE Requester, unload the MKDE first.

Prev
BREQUEST 		Up
Check for Revisions 		Next
BROUTER


BROUTER

Message Router Messages

The following messages are specific to the BROUTER Remote Communications Manager.

BROUTER–2: The value specified for a configuration option is invalid

Reload BROUTER.NLM using valid configuration options.

BROUTER–3: An internal error has occurred; the SPXOpenSocket function failed

An internal diagnostic error occurred. The SPXOpenSocket function failed. Another NLM may be using the socket number reserved for BROUTER. If you receive this message, unload all other NLMs and then load BTRIEVE.NLM and BROUTER.NLM. Finally, reload the other NLMs. This process reveals the NLM that is using BROUTER's socket number.

BROUTER–7: The server has insufficient memory to execute BROUTER

Free some memory by unloading NLMs or reconfiguring NLMs to use less memory.

Prev
BREQUTIL 		Up
Check for Revisions 		Next
BSPXCOM


BSPXCOM

SPX Communications Module Messages

The following messages are specific to the Communications Manager on NetWare.

BSPXCOM–2: The server has insufficient memory to execute BSPXCOM.NLM

An error occurred during a memory allocation operation. Free memory by unloading NLMs or reconfiguring NLMs to use less memory. Retry the operation. If the error persists, contact Technical Support at Pervasive Software.

BSPXCOM–3: An internal error has occurred. BSPXCOM detected a semaphore allocation failure

An internal error occurred during a semaphore allocation operation. Retry the operation. If the error persists, contact Technical Support at Pervasive Software.

BSPXCOM–4: The Service Request Block (SRB) function code nn contains invalid data. Check for an incompatible version of the file BSPXCOM.NLM

Ensure that BSPXCOM's version is compatible with the version number of the workstation's MKDE Requester.

BSPXCOM–6: Another NLM is using the socket number reserved for BSPXCOM.NLM

To solve this condition, unload all other NLMs. Load BTRIEVE.NLM and NWBSRVCM.NLM, and then reload the other NLMs. This process reveals the NLM that is using BSPXCOM.NLM's socket number.

BSPXCOM–7: An SPX receive I/O error (nn) has occurred. The connection has been lost

An error occurred during an SPX-level receive operation. Refer to your operating system documentation for the definition of the error number. Retry the operation. If the error persists, contact Technical Support at Pervasive Software.

BSPXCOM–8: An SPX send I/O error (nn) has occurred. The connection has been lost

An error occurred during an SPX-level send operation. Refer to your operating system documentation for the definition of the error number. Retry the operation. If the error persists, contact Technical Support at Pervasive Software.

BSPXCOM–10: Bad connection ID detected on receive. The SPX connection was lost after the initial request began

If this message appears frequently, increase your requester's SPX Timeout parameter, which is controlled with the Configuration utility. Also, check for NLMs that are monopolizing the CPU time.

BSPXCOM–11: Bad connection ID detected on send. The SPX connection was lost after the initial request began

If this message appears frequently, increase your requester's SPX Timeout parameter, which is controlled with the Configuration utility. Also, check for NLMs that are monopolizing the CPU time.

BSPXCOM–12: An error (nn) was detected while trying to establish an SPX session requested by a remote workstation

An error occurred during an SPX-level session establishment operation. Refer to your operating system documentation for the definition of the error number value. Retry the operation. If the error persists, contact Technical Support at Pervasive Software.

BSPXCOM–13: The session was rejected because the session limit was reached. Increase the value specified for the Number of Remote Sessions option

Obsolete in Pervasive.SQL 8 and later versions.

Increase the value specified for the Number of Remote Sessions in the Configuration utility.

BSPXCOM–14: The request for statistics from the Monitor utility was not recognized. Check for an incompatible version of the utility or BSPXCOM.NLM

Ensure that your BSPXCOM.NLM version is compatible with the version number of the Monitor utility.

BSPXCOM–15: An internal error has occurred. BSPXCOM did not recognize the GET_EIM_STATS function

Ensure that the version of BSPXCOM.NLM is compatible with the version number of the Monitor utility.

BSPXCOM–18: A thread initialization error has occurred

An error occurred during BSPXCOM.NLM thread initialization. Refer to the Pervasive Software Event Log (PVSW.LOG) for error messages preceding this one. Correct the problem and retry the operation.

BSPXCOM–19: A BeginThread() error (nn) has occurred

An error occurred during a BeginThread operation. Refer to your operating system documentation for the definition of the error number value. Retry the operation. If the error persists, contact Technical Support at Pervasive Software.

Prev
BROUTER 		Up
Check for Revisions 		Next
BTCPCOM


BTCPCOM

TCP/IP Communications Module Messages

The following messages are specific to the Communication Manager on NetWare.

BTCPCOM-1: The option specified is not a valid option

Specify a valid option.

BTCPCOM-2: The server has insufficient memory to execute BTCPCOM.NLM

An error occurred during a memory allocation operation. Free memory by unloading NLMs or reconfiguring NLMs to use less memory. Retry the operation. If the error persists, contact Technical Support at Pervasive Software.

BTCPCOM-3: An internal error has occurred. BTCPCOM.NLM detected a semaphore allocation failure

An error occurred during a semaphore allocation operation. Retry the operation. If the error persists, contact Technical Support at Pervasive Software.

BTCPCOM-4: The Service Request Block (SRB) function code nn contains invalid data. Check for an incompatible version of the file BTCPCOM.NLM

Ensure that BTCPCOM's version is compatible with the version number of the workstation's MKDE Requester.

BTCPCOM-5: A TCP/IP level receive I/O error nn has occurred. The connection has been lost

An error occurred during a TCP/IP level receive operation. Refer to your operating system documentation for the definition of the error number value. Retry the operation. If the error persists, contact Technical Support at Pervasive Software.

BTCPCOM-6: A TCP/IP level send I/O error nn has occurred. The connection has been lost

An error occurred during a TCP/IP level send operation. Refer to your operating system documentation for the definition of the error number. Retry the operation. If the error persists, contact Technical Support at Pervasive Software.

BTCPCOM-7: A TCP/IP accept error (nn) has occurred

An error occurred during a TCP/IP level accept session establishment operation. Refer to your operating system documentation for the definition of the error number. Retry the operation. If the error persists, contact Technical Support at Pervasive Software.

BTCPCOM-8: The session was rejected because the session limit was reached. Increase the value specified for the Number of Remote Sessions option

Obsolete in Pervasive.SQL 8 and later versions.

Increase the value specified for the Number of Remote Sessions option in the Configuration utility.

BTCPCOM-9: The request for statistics from the Monitor utility was not recognized. Check for an incompatible version of the utility or BTCPCOM.NLM

Ensure that the BTCPCOM.NLM version is compatible with the version number of the Monitor utility.

BTCPCOM-10: An internal error has occurred. BTCPCOM did not recognize the GET_EIM_STATS function

Ensure that the BTCPCOM.NLM version is compatible with the version number of the Monitor utility.

BTCPCOM-12: A TCP/IP select() error (nn) has occurred while trying to establish a session requested by a remote workstation

An error occurred during a TCP/IP-level select session establishment operation. Refer to your operating system documentation for the definition of the error number. Retry the operation again. If the error persists, contact Technical Support at Pervasive Software.

BTCPCOM-13: A thread initialization error has occurred

An error occurred during BTCPCOM.NLM thread initialization. Refer to the Pervasive Software event log (PVSW.LOG) for error messages preceding this one. Correct the problem and retry the operation.

BTCPCOM-15: A TCP/IP socket() error (nn) has occurred

An error occurred during a TCP/IP-level socket operation. Refer to your operating system documentation for the definition of the error value. Retry the operation again. If the error persists, contact Technical Support at Pervasive Software.

BTCPCOM-16: A TCP/IP setsockopt() error (nn) has occurred

An error occurred during a TCP/IP-level setsockopt operation. Refer to your operating system documentation for the definition of the error value. Retry the operation again. If the error persists, contact Technical Support at Pervasive Software.

BTCPCOM-17: A TCP/IP bind() error (nn) has occurred

An error occurred during a TCP/IP-level bind operation. Refer to your operating system documentation for the definition of the error value. Retry the operation again. If the error persists, contact Technical Support at Pervasive Software.

BTCPCOM-18: A TCP/IP listen() error (nn) has occurred

An error occurred during a TCP/IP-level listen operation. Refer to your operating system documentation for the definition of the error value. Retry the operation again. If the error persists, contact Technical Support at Pervasive Software.

BTCPCOM-19: A TCP/IP gethostname() error (nn) has occurred

An error occurred during a TCP/IP-level gethostname operation. Refer to your operating system documentation for the definition of the error value. Retry the operation again. If the error persists, contact Technical Support at Pervasive Software.

BTCPCOM-20: A TCP/IP NWgethostbyname() error (nn) has occurred

An error occurred during a TCP/IP-level NWgethostbyname operation. Refer to your operating system documentation for the definition of the error value. Retry the operation again. If the error persists, contact Technical Support at Pervasive Software.

BTCPCOM-21: A TCP/IP NetDBgethostbyname() error (nn) has occurred

An error occurred during a TCP/IP-level NetDBgethostbyname operation. Refer to your operating system documentation for the definition of the error value. Retry the operation again. If the error persists, contact Technical Support at Pervasive Software.

BTCPCOM-22: A BeginThread() error (nn) has occurred

An error occurred during a BeginThread operation. Refer to your operating system documentation for the definition of the error value. Retry the operation again. If the error persists, contact Technical Support at Pervasive Software.

Prev
BSPXCOM 		Up
Check for Revisions 		Next
BUTIL


BUTIL

Maintenance Utility Messages

The following messages are specific to the Maintenance utility.

BUTIL–1: Message file initialization failed

Only BUTIL.EXE in DOS returns this message. The utility could not find the BUTILDOS.MSG file, which contains messages that the utility uses. Ensure that you installed NetWare Communication Services correctly.

BUTIL–2: Message file initialization failed. BUTIL was unable to access BTIUTILD.MSG

Only BUTIL.EXE in DOS returns this message. The utility could not find the BTIUTILD.MSG file, which contains messages that the utility uses. Ensure that you installed the Transactional engine for DOS correctly.

BUTIL–6: The BUTIL command is invalid

The syntax of the command you entered is incorrect. Verify the syntax before re-entering the command.

BUTIL–8: The command completed, but one or more errors occurred

An error occurred when you executed a command that performed a number of MicroKernel operations. These commands include COPY, LOAD, or CLONE. This message is accompanied by additional messages that can help you identify the problem.

BUTIL–9: The command did not complete due to an unrecoverable error

Verify that the syntax you entered is correct before re-entering the command. This message is accompanied by additional messages that can help you identify the problem.

BUTIL–10: The command line contains a syntax error

The syntax of the command you entered is incorrect. Verify the syntax before re-entering the command.

BUTIL–11: The command line requires the index file

If you specify the BUTIL –INDEX or –SAVE command (modified by the Y parameter) to the Maintenance utility, you must specify the full pathname of an external index file.

BUTIL–12: The command line requires the key number

If you specify the DROP command or the SAVE command (modified by the N parameter) to the Maintenance utility, you must specify the key number of the key you want to drop or by which you want to save the data file.

BUTIL–13: The key size for key of type xxxx is invalid

In a description file, the specified value of the Key Length element for a particular key is incorrect. Ensure that the value of each Key Length element is appropriate for the matching Key Type element.

BUTIL–14: The file that caused the error was <filename>

This is an informative message that identifies the file that caused the error.

BUTIL–15: Error occurred on key segment descriptor xxx of description file

An error occurred when the Maintenance utility attempted to read the key segment descriptor portion of the description file. Ensure that the elements that describe the specified key segment are valid.

BUTIL–16: BUTIL could not open the description file

Before attempting to re-enter the CREATE, INDEX, or SINDEX commands, ensure that the file exists and that you specify the correct full pathname.

BUTIL–18: An error occurred during access of the sequential file

Ensure that the source file is valid.

BUTIL–19: BUTIL could not open the alternate collating sequence file

Ensure that you assigned a valid pathname to the Alternate Collating Sequence filename element in the description file.

BUTIL–20: An error occurred during access of the alternate collating sequence file

Ensure that the information in the alternate collating sequence file is formatted correctly.

BUTIL–21: The file version is earlier than 6.0

The RECOVER command cannot recover data from a Btrieve v5.x file.

BUTIL–23: The /D parameter specified to the Requester was too small for BUTIL to receive the entire record. BUTIL is writing only nn bytes

The Maintenance utility is writing only as many bytes as the value of the /D option allows. If you want the utility to write all the bytes in the record, specify a value for the /D option that is at least as large as the affected record.

BUTIL–25: The /D parameter specified to BUTIL was too small for BUTIL to receive any part of the record

You specified an invalid value for the Requester /D option. Go to the Configuration utility to increase the value specified.

BUTIL–26: The data buffer is too small to hold any part of the record

The MicroKernel cannot return any data in the data buffer because the data buffer is too small to hold it. Go to the Configuration utility to increase the value specified for the Largest Record Size configuration option.

BUTIL–27: An error occurred during the access of the variable page. BUTIL is writing the obtainable portion of the variable page.

An error occurred during the recovery of a file with variable-length records. The file is corrupt.

BUTIL–30: The key position cannot exceed the record length

The range of the specified key position is invalid. The key position you specify on a MKDE call must be within the range of the record's length. For example, for a record that is 100 bytes long, a key position of 50 is within the correct range. However, a key position of 150 is not.

BUTIL–31: The key position plus key length cannot exceed the record length

The range of the key position you specified is invalid. The key position of a key plus its length cannot be larger than the record length. Verify that the key is defined so that its position plus its length does not exceed the record length.

BUTIL–32: The key length must be an even number for key type xxxx

You specified an invalid key length for the key type. Some key types must contain an even number of bytes. Specify a valid Key Length element.

BUTIL–36: The page size must be a multiple of 512, from 512 to 4,096

The page size you specified is not a multiple of 512, from 512 to 4096. Specify an appropriate page size.

BUTIL–37: The record length cannot exceed the page size

The record length you specified is invalid. In the description file, the record length you specified for the Record Length element is larger than the page size you specified for the Page Size element. Specify a record length that is smaller than the page size or increase the page size.

BUTIL–38: The record length must be at least 4 and no greater than 4,096

Specify a record length between 4 and 4096 (inclusive) for Btrieve v5.x, or between 4 and 4088 for Btrieve v6.x and later.

BUTIL–41: The alternate collating sequence cannot be found

The Maintenance utility cannot find the alternate collating sequence file you specified in the definition file. Verify that the alternate collating sequence file exists and that the name is correct in the definition file.

BUTIL–43: The file exists, but the Replace option was not specified

The Maintenance utility did not create a file when you specified the BUTIL –CREATE command because the file already exists. To recreate this file, specify the Replace Existing File element in the description file as Y.

BUTIL–44: The file access error nn occurred for file filename

The Maintenance utility returns the appropriate status code and filename for a file on which a file access error occurred during the beginning or end of continuous operation. The corrective measure depends on the status code received. Refer to Chapter 1, Status Codes for a description of Status Code nn.

BUTIL–45: The number of duplicate keys must be between 1 and 119

Check the value specified for the Duplicate Key element in the description file.

BUTIL–47: BUTIL cannot open the command file

Ensure that the command file exists and that you specified the command file location and filename correctly.

BUTIL–48: The command file is empty

Specify the desired commands in the command file before attempting to use the command file again. In addition, ensure you specified the correct command filename.

BUTIL–49: The command file exceeds 1,000 bytes

A command file cannot contain more than 1,000 bytes. Verify that the command file adheres to this requirement.

BUTIL–50: An internal error caused BUTIL to terminate

The Maintenance utility detected an internal diagnostic error that caused it to terminate.

BUTIL–52: MKDE cannot be stopped when SQL is loaded

Unload the MKDE before attempting to unload the MicroKernel.

BUTIL–53: MKDE error nn occurred for file or command xxxx

The Maintenance utility returns a status code related to a particular file or command. The corrective measure depends on the status code received. Refer to Chapter 1, Status Codes for a description of Status Code nn.

BUTIL–60: The end of the file occurred while BUTIL was expecting keyword xxxx on key segment descriptor nn

Check the syntax of the description file.

BUTIL–61: The end of the file occurred while BUTIL was expecting keyword xxxx

Check the syntax of the description file.

BUTIL–62: BUTIL was expecting keyword xxxx on key segment descriptor nn

Check the syntax of the description file.

BUTIL–63: BUTIL was expecting keyword xxxx

Check the syntax of the description file.

BUTIL–65: BUTIL has loaded no records

Verify that you specified the command correctly and that the input file is in the correct format.

BUTIL–66: BUTIL has loaded nn records so far

The utility loaded the stated number of records since you issued the BUTIL -LOAD command. When you receive this message, the command is still executing.

BUTIL–70: The MKDE error nn occurred on closing a file

The Maintenance utility returns this status code while closing a file. The corrective measure depends on the status code received. Refer to Chapter 1, Status Codes for a description of Status Code nn.

BUTIL–74: MKDE error nn was returned for the Stop Command

This message applies only to the DOS environment. The Maintenance utility returns this status code after you issue the BUTIL –STOP command. The corrective measure depends on the status code received. Refer to Chapter 1, Status Codes for a description of Status Code nn.

BUTIL–76: When BUTIL wrote the Page Allocation Table at page #nn, an error occurred

The Maintenance utility returns this message while salvaging a file if the file is corrupt, or when a hardware error occurs.

BUTIL–77: When BUTIL wrote a mirror copy of the Page Allocation Table at page #nn, an error occurred

The Maintenance utility returns this message while salvaging a file if the file is corrupted, or when a hardware error occurs.

BUTIL–82: Error occurred on file specification of the description file

An error occurred when the Maintenance utility attempted to read the file specification portion of the description file. Ensure that the elements that describe the file specification are valid.

BUTIL–84: BUTIL internal error

The Maintenance utility encountered an internal error, such as an invalid pointer. Try to run the Maintenance utility again.

BUTIL–90: BUTIL could not allocate enough memory

Free some memory at the server by unloading unused applications.

BUTIL–91: BUTIL could not determine the size of the file

Try to recover the file using the BUTIL –RECOVER command.

BUTIL–100: An internal status code nn

The value nn specifies the ID of a status code whose string resource could not be found. If there is no additional information about the status code in this documentation, call Pervasive Technical Support with this information.

BUTIL–101: The list of files that were not processed is: list

The Maintenance utility returns this error during the ROLLFWD operation if the utility encounters a file that cannot be rolled forward. The utility stops rolling forward and lists the remaining files not processed.

If you receive this message in conjunction with the Maintenance utility message number 103, restore the missing log segment and any log segments created after it to the log directory. If you cannot restore all missing log segments, restore as many as possible. Then, perform the ROLLFWD operation and specify the segment_number parameter of the earliest log segment you could restore.

BUTIL–102: A Roll Forward error occurred

An internal error occurred while the MicroKernel was rolling forward files.

BUTIL–103: Log segment number nn is missing

The Maintenance utility returns this error during ROLLFWD operation if you do not specify a segment_number parameter and one of the files to be rolled forward has a Restore Segment Number that indicates a log segment number that the MicroKernel cannot find.

BUTIL–131: BUTIL was unable to create or open the sequential file

The Maintenance utility returns this message when it is unable to create or open the specified file. Check the sequential file to make sure it exists and has the read-only attribute set.

BUTIL–132: The disk volume is full

You must have more disk space to create or enlarge any data files.

BUTIL–134: BUTIL was unable to create or open the new file

Check the file specified for the BUTIL –SAVE or –RECOVER command. The file may already exist.

BUTIL–136: BUTIL was unable to write the new backup file

Verify that you specified the correct path and filename for the backup file. Also, ensure you have enough disk space for the file to be written.

BUTIL–141: File xx has an invalid extension. This extension is reserved for extended unformatted files

Specify a valid extension. For more information, see Pervasive.SQL Advanced Operations Guide.

BUTIL-142: File xx exists

For more information about extended files, see Pervasive.SQL Advanced Operations Guide.

BUTIL-143: File xx exists. This file is a potential extension of file yy. Remove this file and other potential extension files in this directory

For more information about extended files, see Pervasive.SQL Advanced Operations Guide.

BUTIL-144: File xx has reached the size limit. The utility created one or more extension files. The last extension file is yy

For more information about extended files, see Pervasive.SQL Advanced Operations Guide.

BUTIL-145: The utility found file xx. Remove this file before loading data from file yy

For more information about extended files, see Pervasive.SQL Advanced Operations Guide.

BUTIL–146: The source file and output file cannot be the same.

Specify separate source and output files.

BUTIL–147: The utility cannot read record number xx due to MicroKernel error yy. The utility will attempt to read the remaining records from the opposite direction.

Reference the documentation for the specific status code to resolve this condition

BUTIL–148: Program aborted by user

The utility was stopped by the user.

BUTIL–149: The utility cannot create a temporary file in the current directory to process the STAT command.

Make sure that you have write permission in the current directory.

BUTIL–152: There was an error opening file filename

Check the data file attributes, path, and filename.

BUTIL–155: BUTIL cannot open the file filename

Check the path, filename, and file attributes.

BUTIL–156: Failed to login to database. MicroKernel status xx is returned

Reference the documentation for the specific status code to resolve this condition

BUTIL–157: Failed to logout from database. MicroKernel status xx is returned

Reference the documentation for the specific status code to resolve this condition

Prev
BTCPCOM 		Up
Check for Revisions 		Next
MKDE


MKDE

MicroKernel Database Engine Messages

This section lists the messages that the MicroKernel Database Engine generates.

MKDE–12: The value specified for the –option is invalid

Enter the correct value in the BSTART.NCF, BTI.INI, or BTI.CFG file.

MKDE–13: The option specified is not a valid option

Remove the invalid option from the BSTART.NCF, BTI.INI, or BTI.CFG file.

MKDE–16: There is insufficient memory to load the MicroKernel Database Engine

The system has insufficient memory to allow the MicroKernel to load as it is configured. Use the Configuration utility to reconfigure the MicroKernel to use less memory, or unload any unnecessary applications.

MKDE–20: The log file filename cannot be written. Check disk space

If the disk is full, free some space by deleting any unnecessary files. When an error occurs while writing to the transaction log file, the MicroKernel attempts to resume transaction logging after every update to a data file containing system data. Therefore, when the condition causing the error is corrected (for example, when more disk space is made available), the MicroKernel automatically resumes transaction logging.

MKDE–25: The file filename is rolling back

Rolling back is the procedure the MicroKernel uses to restore a file to a consistent state after a system crash. This procedure undoes the most recent changes to the file (changes in the most recent system transaction).

MKDE–51: Program initialization failed; the program was not loaded

This is an informative message that the MicroKernel returns when an error prevents the MicroKernel from loading. Another message accompanies this one and provides more specific information about the nature of the error.

MKDE–57: The file filename cannot be created in the log segment directory xxxx

While initializing, the MicroKernel could not find the specified transaction log segment directory, so it did not load. Ensure that the directory exists and that the MicroKernel has rights to it. (This is not a problem for the NetWare NLM version of the MicroKernel, because it has rights to all directories and files.) Use the Configuration utility to specify the transaction log directory.

MKDE–58: The file filename cannot be opened in the log segment directory xxxx

While initializing, the MicroKernel could not open the specified file in the transaction log segment directory, so it did not load. Ensure that the directory and file exist and that the MicroKernel has rights to it. (This is not a problem for the NetWare NLM version of the MicroKernel, because it has rights to all directories and files.) Another possibility is that someone has opened the file with an exclusive lock. Use the Monitor utility to see if another user has locked the file.

MKDE–59: The log segment file filename cannot be created

The MicroKernel could not create the specified transaction log segment file. Ensure that you have enough disk space and that the MicroKernel has rights to the file. (This is not a problem for the NetWare NLM version of the MicroKernel, because it has rights to all directories and files.) Another possibility is that someone has opened the file with an exclusive lock. Use the Monitor utility to see if another user has locked the file.

This error can occur while the MicroKernel is loading, or later, during normal operations. If it occurs while the MicroKernel is loading, the loading fails and no operations are possible until the problem is corrected. If the error occurs later, during normal operations, there are some additional issues to consider.

If the MicroKernel is already loaded when an error occurs creating the transaction log file, it ceases transaction logging; however, the MicroKernel attempts to resume transaction logging after every update to a data file containing system data. Therefore, when the condition causing the error is corrected (for example, when more disk space is made available), the MicroKernel automatically resumes transaction logging.

MKDE–75: The log file format is invalid

The MicroKernel returns this message when the log segment file format is incompatible. Ensure that the version of the MicroKernel doing the roll forward is the same as the version of the MicroKernel that created the log file.

MKDE–76: An Open operation failed on "xxxx" with MKDE error nn

The MicroKernel returns this message during roll forward operations when a MKDE error occurs. The MicroKernel returns the specified status code for the specified file. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–77: An unexpected MKDE error nn occurred on INSERT to "xxxx"

The MicroKernel returns this message during roll forward operations when an Insert error occurs. The MicroKernel returns the specified status code for the specified file. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–78: An unexpected MKDE error nn occurred on UPDATE in "xxxx"

The MicroKernel returns this message during roll forward operations when an Update error occurs. The MicroKernel returns the specified status code for the specified file. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–79: An unexpected MKDE error nn occurred on DELETE from "xxxx"

The MicroKernel returns this message during roll forward operations when a Delete error occurs. The MicroKernel returns the specified status code for the specified file. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–80: The system is out of memory

The MicroKernel returns this message when the server has insufficient memory to allow the program to operate. Unload any unnecessary applications and retry the roll forward operation.

MKDE–81: An internal error nn occurred

The MicroKernel returns this message when an internal error occurs. Try to perform the operation again.

MKDE–82: An unexpected MKDE error nn occurred on GET EQUAL in "xxxx"

The MicroKernel returns this message during roll forward operations when a Get Equal error occurs. The MicroKernel returns the specified status code for the specified file. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–83: The log file is corrupt

The MicroKernel returns this message when the log segment file is damaged and unreadable. The Log Segment Manager cannot perform roll forward operations using this log segment.

MKDE–84: An error occurred while reading the log file

The MicroKernel returns this message when an error prevents the program from reading the log segment file. The MicroKernel cannot perform roll forward operations using this log segment.

MKDE–85: An unexpected MKDE error nn occurred on CREATE INDEX to filename

The MicroKernel returns this message during roll forward operations when an error occurs on a CREATE INDEX operation for the specified file. You may have a corrupted file, or your log file may be corrupt. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–86: An unexpected MKDE error nn occurred on DROP INDEX to filename

The MicroKernel returns this message during roll forward operations when an error occurs on a DROP INDEX operation for the specified file. You may have a corrupted file, or your log file may be corrupt. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–87: An unexpected MKDE error nn occurred on BEGIN TRANSACTION to filename

The MicroKernel returns this message during roll forward operations when an error occurs on a BEGIN TRANSACTION operation for the specified file. You may have a corrupted file, or your log file may be corrupt. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–88: An unexpected MKDE error nn occurred on END TRANSACTION to filename

The MicroKernel returns this message during roll forward operations when an error occurs on an END TRANSACTION operation for the specified file. You may have a corrupted file, or your log file may be corrupt. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–89: An unexpected MKDE error nn occurred on ABORT TRANSACTION to filename

The MicroKernel returns this message during roll forward operations when an error occurs on an ABORT TRANSACTION operation for the specified file. You may have a corrupted file, or your log file may be corrupt. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–90: An unexpected MKDE error nn occurred on CLOSE to filename

The MicroKernel returns this message during roll forward operations when an error occurs on a CLOSE operation for the specified file. You may have a corrupted file, or your log file may be corrupt. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–91: An unexpected MKDE error nn occurred on GET POSITION to filename

The MicroKernel returns this message during roll forward operations when an error occurs on a GET POSITION operation for the specified file. You may have a corrupted file, or your log file may be corrupt. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–92: An unexpected MKDE error nn occurred on BEGIN TRANSACTION

The MicroKernel returns this message during roll forward operations when an error occurs on a BEGIN TRANSACTION operation. You may have a corrupted file, or your log file may be corrupt. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–93: An unexpected MKDE error nn occurred on END TRANSACTION

The MicroKernel returns this message during roll forward operations when an error occurs on an END TRANSACTION operation. You may have a corrupted file, or your log file may be corrupt. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–94: An unexpected MKDE error nn occurred on ABORT TRANSACTION

The MicroKernel returns this message during roll forward operations when an error occurs on an ABORT TRANSACTION operation. You may have a corrupted file, or your log file may be corrupt. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–98: The log segment file SYS:SYSTEM/MKDE/LOG/0000XXX.LOG cannot be created. There was an error on the console or in the PVSW.LOG

The MicroKernel could not create the specified transaction log segment file. Ensure that you have enough disk space and that the MicroKernel has rights to the file. (This is not a problem for the NetWare NLM version of the MicroKernel, because it has rights to all directories and files.) Another possibility is that someone has opened the file with an exclusive lock. Use the Monitor utility to see if another user has locked the file.

This error can occur while the MicroKernel is loading, or later, during normal operations. If it occurs while the MicroKernel is loading, the loading fails and no operations are possible until the problem is corrected. If the error occurs later, during normal operations, there are some additional issues to consider.

If the MicroKernel is already loaded when an error occurs creating the transaction log file, it ceases transaction logging; however, the MicroKernel attempts to resume transaction logging after every update to a data file containing system data. Therefore, when the condition causing the error is corrected (for example, when more disk space is made available), the MicroKernel automatically resumes transaction logging.

MKDE-103: System Error

The MicroKernel Database Engine returns this message when a system error occurs. See MKDE–2039: System Error: nn.nn.nn for more information.

MKDE–1001: The value specified for Cache Allocation is invalid

Specify a valid value. For more information about valid values, refer to Pervasive.SQL Advanced Operations Guide.

MKDE–1002: The value specified for Longest Compressed Record Size is invalid

This message is obsolete in Pervasive.SQL 2000i and later versions. This setting is managed dynamically by the engine.

MKDE–1003: The value specified for Extended Operation Buffer Size is invalid

This message is obsolete in Pervasive.SQL 2000i and later versions. This setting is managed dynamically by the engine.

MKDE–1004: The value specified for Open Files is invalid

This message is obsolete in Pervasive.SQL 2000i and later versions. This setting is managed dynamically by the engine.

MKDE–1005: The value specified for Operation Bundle Limit is invalid

Specify a valid value. For more information about valid values, refer to the Pervasive.SQL Advanced Operations Guide.

MKDE–1007: The value specified for Number of Handles is invalid

This message is obsolete in Pervasive.SQL 2000i and later versions. This setting is managed dynamically by the engine.

MKDE–1008: The value specified for I/O Threads is invalid

Specify a valid value. For more information about valid values, refer to Pervasive.SQL Advanced Operations Guide.

MKDE–1009: The value specified for Maximum Sort Buffer is invalid

Specify a valid value. For more information about valid values, refer to Pervasive.SQL Advanced Operations Guide.

MKDE–1010: The path specified for Temporary Sorting Files is invalid

Specify a valid path. For more information about valid values, refer to Pervasive.SQL Advanced Operations Guide.

MKDE–1011: Info: The Number of Handles cannot be less than the Number of Open Files

This message is obsolete in Pervasive.SQL 2000i and later versions. These settings are managed dynamically by the engine.

MKDE–1015: The value specified for Maximum Record Size is invalid

This message is obsolete in Pervasive.SQL 2000i and later versions.

MKDE–1017: The value specified for System Transaction Hold Limit is invalid

This message is obsolete in Pervasive.SQL 2000i and later versions.

MKDE–1019: The value specified for Maximum Active Clients is invalid

This message is obsolete in Pervasive.SQL 2000i and later versions. This setting is managed dynamically by the engine.

MKDE–1020: The value specified for Worker Threads is invalid

Obsolete in Pervasive.SQL 2000i and later versions. The number of Worker Threads is managed dynamically by the engine. If you receive this message, contact Pervasive Technical Support.

MKDE–1021: The value specified for Thread Priority Delta is invalid

Obsolete in Pervasive.SQL 2000 and later versions.

MKDE–1022: The value specified for Initiation Time Limit is invalid

Specify a valid value. For more information about valid values, refer to the Pervasive.SQL Advanced Operations Guide.

MKDE–1023: The value specified for Disk I/O Wait Time is invalid

Obsolete in Pervasive.SQL 2000 and later versions.

MKDE–1024: The value specified for Page Write Group Size is invalid

Obsolete in Pervasive.SQL 2000 and later versions.

MKDE–1025: The value specified for Auto-Terminate Delay is invalid

Obsolete in Pervasive.SQL 2000 and later versions.

MKDE–1026: The value specified for Number of Lines Allocated is invalid

Obsolete in Pervasive.SQL 2000 and later versions.

MKDE–1027: The value specified for Message Log File Limit is invalid

Obsolete in Pervasive.SQL 2000 and later versions.

MKDE–1028: The path specified for Home Directory is invalid

Obsolete in Pervasive.SQL 2000 and later versions.

MKDE–1030: The value specified for the option_name option is invalid

The MicroKernel Database Engine returns this message when the value specified for the option_name option is invalid. Specify a valid value.

MKDE–1032: The option specified is not a valid option

The MicroKernel Database Engine returns this message when the option you specified is not valid. Specify a valid configuration option.

MKDE–1152: MKDE cannot get sufficient memory to complete the operation

The computer has insufficient memory to allow the MicroKernel to load as it is configured. Configure the MicroKernel to use less memory or unload any unnecessary applications.

MKDE–1156: The log file filename cannot be written. Check disk space

The transaction log file filename cannot be written. Check the disk space. If the disk is full, free some space by deleting any unnecessary files. When an error occurs while writing to the transaction log file, the MicroKernel attempts to resume transaction logging after every update to a data file containing system data. Therefore, when the condition causing the error is corrected (for example, when more disk space is made available), the MicroKernel automatically resumes transaction logging.

MKDE–1157: System Error: nn.nn.nn

The MicroKernel Database Engine returns this message when a system error occurs. See MKDE–2039: System Error: nn.nn.nn for more information.

MKDE–1161: The file filename is rolling back

Rolling back is the procedure the MicroKernel uses to restore a file to a consistent state after a system crash. This procedure undoes the most recent changes to the file (changes in the most recent system transaction).

MKDE–1164: Error creating/accessing semaphore

The MicroKernel returns this message if an internal error occurs.

MKDE–1165: Error creating execution thread

Decrease the value of the Number of Input/Output Threads configuration option.

To perform this task, open Pervasive Control Center, double-click the database engine you wish to configure, double-click Configuration, click Performance Tuning, then double-click Number of Input/Output Threads.

MKDE–1166: Could not open Pervasive Event Log file. This file is created in the home directory. Verify that the directory is present and sufficient space is available

The MicroKernel returns this message when it cannot create the Pervasive Event Log (PVSW.LOG) in the directory. Make sure that the disk on your computer is not full.

The home directory is defined as \WINNT\SYSTEM32 (Windows NT), \WINDOWS\SYSTEM (Windows 95) or SYS:\SYSTEM (NetWare server).

MKDE–1167: Could not create IPC queue

The MicroKernel returns this message if an internal error occurs.

MKDE–1168: Client(s) active - Shutdown anyway?

The MicroKernel returns this message when you attempt to shut down the Workgroup engine while at least one application is still using the engine. If you choose to shut down anyway, you could lose data.

MKDE–1169: Could not open BTI.INI

The MicroKernel returns this message when it cannot open the file BTI.INI. Make sure that the file is in the home directory.

MKDE–1171: The file BTI.INI is flagged as read only. The MKDE can temporarily override this attribute to save the current settings. Do you wish to continue?

The MicroKernel returns this message if the BTI.INI file is flagged as read only and you attempt to save changes to the MKDE configuration settings, which are stored in the BTI.INI file. If you choose to continue, the MicroKernel updates the BTI.INI file but maintains its read only status. If you choose not to continue, the MicroKernel does not update the BTI.INI file. You can still change the configuration settings, but they are only in effect for the current session.

MKDE–1172: Error writing to BTI.INI

Make sure that your computer's disk is not full and that you have the appropriate rights to the file.

MKDE–1175: I/O error - filename

The MicroKernel returns this message when it encounters an I/O error while reading from or writing to a file. This message typically accompanies Status Code 2.

MKDE–1176: Variable page error - filename

The MicroKernel returns this message when it encounters an error on a variable page. This message typically accompanies Status Code 2.

MKDE–1177: Help is not available

This message is obsolete in Pervasive.SQL 2000 and later versions.

The MicroKernel returns this message when it cannot find the help file (BTRIEVE.HLP). Make sure that the file is located in the home directory.

MKDE–1178: Resources allocated

This is an informative message from the MicroKernel Database Engine. No action is required.

MKDE–1179: Resources released

This is an informative message from the MicroKernel Database Engine. No action is required.

MKDE–1180: System Error: nn.nn.nn

The MicroKernel Database Engine returns this message when a system error occurs. See MKDE–2039: System Error: nn.nn.nn for more information.

MKDE–1183: Not enough available cache to complete an operation

Configure the MicroKernel to use more cache memory or reduce the file's page size.

MKDE–1184: Unable to set number of file handles to requested value. Maximum open files reduced to nn.

This message is obsolete in Pervasive.SQL 2000i and later versions. This setting is managed dynamically by the engine.

The MicroKernel is unable to set the Maximum Open Files to the value you specified; instead the MicroKernel uses the value indicated in the message. To avoid receiving this message, run fewer applications at the same time.

MKDE–1192: Settings read from NOVDB.INI - To change to BTI.INI, save current settings

The MicroKernel returns this message when it loads and then finds a NOVDB.INI file where it expects to find the BTI.INI file. To use the BTI.INI file, open the configuration utility and save the current settings.

MKDE–1193: The MKDE is using default settings

The MicroKernel returns this message when it cannot find values for any configuration options in the location they are normally stored (BTI.CFG on NetWare, BTI.INI on Unix, and the registry on Windows). This message means that the internal default values are being used and saved off to the default location. You may update the configuration options using the Pervasive Control Center.

MKDE–1194: Additional worker thread spawned

The MicroKernel returns this message when it must create more worker threads than the number specified by the Number of Worker Threads configuration option. To avoid receiving this message, increase the value for the Number of Worker Threads option.

MKDE–1207: The log file format is invalid

The MicroKernel returns this message when the log segment file format is incompatible. Ensure that the version of the MicroKernel doing the roll forward is the same as the version of the MicroKernel that created the log file.

MKDE–1208: An Open operation failed on "xxxx" with MKDE error nn

The MicroKernel returns this message during roll forward operations when an error occurs. The MicroKernel returns the specified status code for the specified file. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–1209: An unexpected MKDE error nn occurred on INSERT to "xxxx"

The MicroKernel returns this message during roll forward operations when an Insert error occurs. The MicroKernel returns the specified status code for the specified file. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–1210: An unexpected MKDE error nn occurred on UPDATE in "xxxx"

The MicroKernel returns this message during roll forward operations when an Update error occurs. The MicroKernel returns the specified status code for the specified file. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–1211: An unexpected MKDE error nn occurred on DELETE from "xxxx"

The MicroKernel returns this message during roll forward operations when a Delete error occurs. The MicroKernel returns the specified status code for the specified file. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–1212: The system is out of memory

The MicroKernel returns this message when the server has insufficient memory to allow the program to operate. Unload any unnecessary applications and retry the roll forward operation.

MKDE–1213: An internal error nn occurred

The MicroKernel returns this message when an internal error occurs. Try to perform the operation again.

MKDE–1214: An unexpected MKDE error nn occurred on GET EQUAL in "xxxx"

The MicroKernel returns this message during roll forward operations when a Get Equal error occurs. The MicroKernel returns the specified status code for the specified file. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–1215: The log file is corrupt

The MicroKernel returns this message when the log segment file is damaged and unreadable. The MicroKernel cannot perform roll forward operations using this log segment.

MKDE–1216: An error occurred while reading the log file

The MicroKernel returns this message when an error prevents the program from reading the log segment file. The MicroKernel cannot perform roll forward operations using this log segment.

MKDE–1217: An unexpected MKDE error nn occurred on CREATE INDEX to filename

The MicroKernel returns this message during roll forward operations when an error occurs on a CREATE INDEX operation for the specified file. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–1218: An unexpected MKDE error nn occurred on DROP INDEX to filename

The MicroKernel returns this message during roll forward operations when an error occurs on a DROP INDEX operation for the specified file. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–1219: An unexpected MKDE error nn occurred on BEGIN TRANSACTION to filename

The MicroKernel returns this message during roll forward operations when an error occurs on a BEGIN TRANSACTION operation for the specified file. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–1220: An unexpected MKDE error nn occurred on END TRANSACTION to filename

The MicroKernel returns this message during roll forward operations when an error occurs on an END TRANSACTION operation for the specified file. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–1221: An unexpected MKDE error nn occurred on ABORT TRANSACTION to filename

The MicroKernel returns this message during roll forward operations when an error occurs on an ABORT TRANSACTION operation for the specified file. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–1222: An unexpected MKDE error nn occurred on CLOSE to filename

The MicroKernel returns this message during roll forward operations when an error occurs on a CLOSE operation for the specified file. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–1223: An unexpected MKDE error nn occurred on GET POSITION to filename

The MicroKernel returns this message during roll forward operations when an error occurs on a GET POSITION operation for the specified file. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–1224: An unexpected MKDE error nn occurred on BEGIN TRANSACTION

The MicroKernel returns this message during roll forward operations when an error occurs on a BEGIN TRANSACTION operation. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–1225: An unexpected MKDE error nn occurred on END TRANSACTION

The MicroKernel returns this message during roll forward operations when an error occurs on an END TRANSACTION operation. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–1226: An unexpected MKDE error nn occurred on ABORT TRANSACTION

The MicroKernel returns this message during roll forward operations when an error occurs on an ABORT TRANSACTION operation. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–2001: The value specified for the Cache Allocation option is invalid

The MicroKernel returns this message when the value specified for the Cache Allocation Size option is invalid. Use the Configuration utility and specify a valid value for this option. In Pervasive.SQL 8 and later, this value can be managed dynamically by the MicroKernel.

MKDE–2002: The value specified for the Largest Compressed Record Size option is invalid

This message is obsolete in Pervasive.SQL 2000i and later versions.

The MicroKernel returns this message when the value specified for the Largest Compressed Record Size option is invalid. Use the Configuration utility to specify a valid value for this option.

MKDE–2004: The value specified for the Number of Open Files option is invalid

This message is obsolete in Pervasive.SQL 2000i and later versions. This setting is managed dynamically by the engine.

The MicroKernel returns this message when the value specified for the Number of Open Files option is invalid. Use the Configuration utility and specify a valid value for this option.

MKDE–2005: The value specified for the Operation Bundle Limit option is invalid

The MicroKernel returns this message when the value specified for the Operation Bundle Limit option is invalid. Use the Configuration utility and specify a valid value for this option.

MKDE–2007: The value specified for the Number of Handles option is invalid

This message is obsolete in Pervasive.SQL 2000i and later versions. This setting is managed dynamically by the engine.

The MicroKernel returns this message when the value specified for the Number of Handles option is invalid. Use the Configuration utility and specify a valid value for this option.

MKDE–2008: The value specified for the I/O Threads option is invalid

The MicroKernel returns this message when the value specified for the number of Number of Input/Output Threads option is invalid. Use the Configuration utility and specify a valid value for this option.

MKDE–2009: The value specified for the Active Clients option is invalid

This message is obsolete in Pervasive.SQL 2000i and later versions. This setting is managed dynamically by the engine.

The MicroKernel returns this message when the value specified for the Active Clients option is invalid. Use the Configuration utility and specify a valid value for this option.

MKDE–2010: The value specified for the Sort Buffer Size option is invalid

This message is obsolete in Pervasive.SQL 2000i and later versions. This setting is managed dynamically by the engine.

The MicroKernel returns this message when the value specified for the Sort Buffer Size option is invalid. Use the Configuration utility and specify a valid value for this option.

MKDE–2011: The path specified for the Temporary Directory option is invalid

The MicroKernel returns this message when the value specified for the Working Directory option is invalid. Use the Configuration utility to specify a valid path.

MKDE–2012: The value specified for the –option option is invalid

The MicroKernel returns this message when the value for an option is not valid. Return to the Configuration utility and enter the correct value.

MKDE–2013: The option specified is not a valid option

The MicroKernel Database Engine returns this message when the option specified is not a valid option. Return to the Configuration utility and remove the invalid option.

MKDE–2015: MKDE cannot get sufficient memory to complete the operation

The MicroKernel returns this message when the server has insufficient memory to allow the MicroKernel to load as it is configured. Use the Configuration utility to reconfigure the MicroKernel to use less memory (Cache Allocation Size attribute), or unload any unnecessary applications.

MKDE–2019: The log file filename cannot be written. Check disk space

The MicroKernel returns this message when log file filename cannot be written. Check the disk space. If the disk is full, free some space by deleting any unnecessary files. When an error occurs while writing to the transaction log file, the MicroKernel attempts to resume transaction logging after every update to a data file containing system data. Therefore, when the condition causing the error is corrected (for example, when more disk space is made available), the MicroKernel automatically resumes transaction logging.

MKDE–2024: The file filename is rolling back

The MicroKernel returns this message when the file filename is rolling back. Rolling back is the procedure the MicroKernel uses to restore a file to a consistent state after a system crash. This procedure undoes the most recent changes to the file (changes in the most recent system transaction).

MKDE–2027: Error creating/accessing semaphore

The MicroKernel returns this message if an internal error occurs.

MKDE–2028: Error creating execution thread

This message is obsolete in Pervasive.SQL 2000i and later versions. This setting is managed dynamically by the engine.

MKDE–2029: Could not open Event Log file.

The MicroKernel returns this message when it cannot create the Pervasive Event Log (PVSW.LOG) in the home directory. Make sure that the home directory exists and that the disk on your computer is not full. Also, ensure that the MicroKernel has rights to the home directory and event log file.

The Home directory is defined as \WINNT\SYSTEM32 (Windows NT), \WINDOWS\SYSTEM (Windows 95), and SYS:\SYSTEM (NetWare servers).

MKDE–2039: System Error: nn.nn.nn

The MicroKernel returns this message when a system error occurs.

The MKDE uses the System Error messages to record unexpected errors resulting from an operating system call made by the MKDE. For example, if an error is returned when the MKDE makes a file
I/O call to the operating system, that error is recorded in the PVSW.LOG as a System Error.

The format of a system error is id.op.rc where:
Table 2-3 System Error Explanation
id | Unique System Error identifier
op | Btrieve operation being performed at the time
rc | any unexpected return code from the operating system.

The id corresponds to a section of code in the MKDE where the OS call took place. There are different id ranges depending on which MKDE is being used:
Table 2-4 System Error Code Area
100-299 | Common source base
300-399 | NetWare
400-499 | OS/2 (no longer supported)
500-599 | Windows 16-bit (Win16 engine longer supported)
600-699 | Windows NT/2000
700-799 | Windows 95/NT

The common code base contains all the file I/O requests, variable allocations, caching, and so on. The platform specific ranges cover other file open, close, read, and lock requests. These codes can guide us to the portion of the MKDE code that was executing when the System Error occurred. For example, ids ranging from 110 - 124 correspond to the I/O Subsystem of the MicroKernel where disk I/O calls are made, and system errors with these ids usually correspond to file corruption problems. A list of ids is not available publicly because a list without the specific MKDE and knowledge of the code would not have much value.

The second piece of the system error is the operation code. This corresponds to the Btrieve request that was being processed when the error occurred. For example, a 5 is a GetEqual operation. Refer to the Pervasive.SQL Programmer's Reference for more information about Btrieve operation codes. If the system error occurs while the MKDE is performing some task that is not specifically associated with a Btrieve operation, the op will be set to -1.

The third piece of the system error is the OS return code. The meaning of the values reported here varies depending on the OS call made and the type of failure that occurred. A return code value of 0 for different IDs is likely to have different meanings, but in each case the OS did not return an actual error code. An example of a System Error where the OS return code is zero is when the OS call returns successfully, but the data returned by the call is not what was expected. In many cases, the appearance of an occasional System Error does not indicate a problem. It is likely that the operation being performed was retried without an error and processing continued normally.

If there is a problem that would cause an interruption in normal operation, the System Error would correspond to a Pervasive status code returned to the application. For example, attempting to access a physically corrupt file will produce a system error such as 116.5.0 and the application will receive a Status Code 2.

If you experience repeated occurrences of a specific system error, along with abnormal behavior of your application, and you do not find any documentation in our knowledge base about the error, you should contact Pervasive with a description of the system error and the symptoms of failure in the application, and we will provide more details about the system error in question.

The list of Win32 error codes is available on Microsoft's website at http://msdn.microsoft.com/library/en-us/debug/base/system_error_codes.asp.

The main list of OS error codes is contained in the Microsoft file, winerror.h.

Note
One common System Error on NetWare 4.x is a known problem in NetWare's Turbo FAT feature. This problem often manifests as error "MKDE-103 System Error 116.2.0." For more information on this particular topic, please see the following Pervasive Knowledge Base article:

http://support.pervasive.com/eSupport/publisher.asp?id=6bf0e1d1-09fb-11d5-b22b-00508b5d6b61

MKDE–2053: Additional worker thread spawned

This message is obsolete in Pervasive.SQL 2000i and later versions. Worker threads are managed dynamically by the engine.

This is an informative message the MicroKernel returns when it must create more worker threads than the number specified by the Number of Worker Threads configuration option. To avoid receiving this message, increase the value for the Number of Worker Threads option.

MKDE–2055: Error creating named pipe

The MicroKernel returns this message when it is unable to create a named pipe for the pipe-manager thread.

MKDE–2060: Error reading the registry. Error code: nn

The MicroKernel returns this message when it is unable to find a predefined setting in the registry. Use the –REGINSTALL startup parameter next time you start the MicroKernel. This parameter forces the MicroKernel to recreate its section in the registry with the default values for each configuration option.

MKDE–2061: Error writing the registry. Error code: nn

The MicroKernel returns this message when it encounters an error while trying to write into the registry. Use the –REGINSTALL startup parameter next time you start the MicroKernel. This parameter forces the MicroKernel to recreate its section in the registry with the default values for each configuration option.

MKDE–2065: Error calling Service Control dispatcher

The MicroKernel returns this message when it encounters an error during the service initialization.

MKDE–2067: There is no suitable protocol available on this computer

The MicroKernel returns this message when none of the supported protocols are installed on the computer. The Communications Server cannot initialize.

MKDE–2068: The communications server is not available

The MicroKernel returns this message when it encounters an error loading the Communications Server. Make sure the system path includes the directory where the Communications Server that was shipped with this version of the MicroKernel.

MKDE–2075: The transaction log file LAST_SEG.LOG cannot be opened

The MicroKernel returns this message when the log file format is invalid or the Transaction Log Directory does not exist. Ensure that the version of the MicroKernel that returns this message is the same as the version of the MicroKernel that created the log file.

MKDE–2076: An Open operation failed on "xxxx" with MKDE error nn

The MicroKernel returns this message during roll forward operations when an error occurs. The MicroKernel returns the specified status code for the specified file. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–2077: The log file format is invalid

The MicroKernel returns this message when the log segment file format is incompatible. Ensure that the version of the MicroKernel doing the roll forward is the same as the version of the MicroKernel that created the log file.

MKDE–2078: An Open operation failed on "xxxx" with MKDE error nn

The MicroKernel returns this message during roll forward operations when an error occurs. The MicroKernel returns the specified status code for the specified file. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–2079: An unexpected MKDE error nn occurred on INSERT to "xxxx"

The MicroKernel returns this message during roll forward operations when an Insert error occurs. The MicroKernel returns the specified status code for the specified file. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–2080: An unexpected MKDE error nn occurred on UPDATE in "xxxx"

The MicroKernel returns this message during roll forward operations when an Update error occurs. The MicroKernel returns the specified status code for the specified file. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–2081: An unexpected MKDE error nn occurred on DELETE from "xxxx"

The MicroKernel returns this message during roll forward operations when a Delete error occurs. The MicroKernel returns the specified status code for the specified file. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–2082: The system is out of memory

The MicroKernel returns this message when the server has insufficient memory to allow the program to operate. Unload any unnecessary applications and retry the roll forward operation.

MKDE–2083: An internal error nn occurred

The MicroKernel returns this message when an internal error occurs. Try to perform the operation again.

MKDE–2084: An unexpected MKDE error nn occurred on GET EQUAL in "xxxx"

The MicroKernel returns this message during roll forward operations when a Get Equal error occurs. The MicroKernel returns the specified status code for the specified file. Refer to Chapter 1, Status Codes for a description of Status Code nn.

MKDE–2085: The log file is corrupt

The MicroKernel returns this message when the specified log segment file is damaged and unreadable. The MicroKernel cannot perform roll forward operations using this log segment.

MKDE–2086: An error occurred while reading the log file

The MicroKernel returns this message when an error prevents the program from reading the log segment file. The MicroKernel cannot perform roll forward operations using this log segment.

MKDE–2087: An unexpected MKDE error nn occurred on CREATE INDEX to filename

The MicroKernel returns this message during roll forward operations when an error occurs on a CREATE INDEX operation for the specified file. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–2088: An unexpected MKDE error nn occurred on DROP INDEX to filename

The MicroKernel returns this message during roll forward operations when an error occurs on a DROP INDEX operation for the specified file. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–2089: An unexpected MKDE error nn occurred on BEGIN TRANSACTION to filename

The MicroKernel returns this message during roll forward operations when an error occurs on a BEGIN TRANSACTION operation for the specified file. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–2090: An unexpected MKDE error nn occurred on END TRANSACTION to filename

The MicroKernel returns this message during roll forward operations when an error occurs on an END TRANSACTION operation for the specified file. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–2091: An unexpected MKDE error nn occurred on ABORT TRANSACTION to filename

The MicroKernel returns this message during roll forward operations when an error occurs on an ABORT TRANSACTION operation for the specified file. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–2092: An unexpected MKDE error nn occurred on CLOSE to filename

The MicroKernel returns this message during roll forward operations when an error occurs on a CLOSE operation for the specified file. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–2093: An unexpected MKDE error nn occurred on GET POSITION to filename

The MicroKernel returns this message during roll forward operations when an error occurs on a GET POSITION operation for the specified file. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–2094: An unexpected MKDE error nn occurred on BEGIN TRANSACTION

The MicroKernel returns this message during roll forward operations when an error occurs on a BEGIN TRANSACTION operation. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–2095: An unexpected MKDE error nn occurred on END TRANSACTION

The MicroKernel returns this message during roll forward operations when an error occurs on an END TRANSACTION operation. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

MKDE–2096: An unexpected MKDE error nn occurred on ABORT TRANSACTION

The MicroKernel returns this message during roll forward operations when an error occurs on an ABORT TRANSACTION operation. You may have a corrupted file, or your log file may be corrupt. For more information about Status Code nn, refer to Chapter 1, Status Codes.

Prev
BUTIL 		Up
Check for Revisions 		Next
NWBSRVCM


NWBSRVCM

NetWare Server Communications Manager Messages

NWBSRVCM-4: Communication Manager is using default settings

The Communications Manager displays this message when it cannot find the configuration file (BTI.CFG). It will use the default configuration settings.

NWBSRVCM-5: Communication Manager detected an invalid command line option

Obsolete in Pervasive.SQL 2000i and later versions.

NWBSRVCM-6: Communication Manager terminating - could not initialize properly

The Communications Manager could not load the TCP/IP or SPX communication module. Verify that the configuration file (BTI.CFG) entry for Supported Protocols is correct.

NWBSRVCM-7: Communication Manager terminating - insufficient memory to execute

An error occurred during a memory allocation operation. Free memory by unloading NLMs or reconfiguring NLMs to use less memory. Retry the operation. If the error persists, contact Technical Support at Pervasive Software.

NWBSRVCM-8: Communication Manager could not load/initialize BTCPCOM.NLM

An error occurred during the loading or initialization of BTCPCOM.NLM. The operating system error number is displayed as errno. Refer to your operating system documentation for the definition of the errno value.

NWBSRVCM-9: Communication Manager could not load/initialize BSPXCOM.NLM

An error occurred during the loading or initialization of BSPXCOM.NLM. The operating system error number is displayed as errno. Refer to your operating system documentation for the definition of the errno value.

NWBSRVCM-10: Communication Manager terminating - invalid Supported Protocols specified in configuration file (BTI.CFG)

Verify that the configuration file (BTI.CFG) entry for Supported Protocols is correct.

Prev
MKDE 		Up
Check for Revisions 		Next